chubigans  [developer] Dec 27, 2013 @ 12:52pm
Pinning down errors (need feedback)
There have been a few users with the Mac version of CSD that have had problems with the game either not starting or crashing, as well as users having progressive slowdown. This thread is to help me gather information so that I can report back to the GM Studio team on getting this bug fixed, as it seems to be an issue with GM Studio games and not this specific game.

It will also help me in getting a version that works for those who have issues with the game. So please post in this thread if you've had problems with the game crashing, and include the following information:

-What type of computer/laptop, and the year.
-What OS you're currently running.
-The specifics on how the game crashed, or what you were doing before it crashed.


AFTER posting that, for Mac users not being able to start the game, please try the below solution and report whether it worked for you or not:


-Right click on CSD in your Steam library, and select Properties. Click the BETAS tab.

FOR MAVERICKS OSX:
-In the text box, type in rollbackmavericks and press enter.

FOR ALL OTHER OSXs:
-In the text box, type in rollbackmacversion and press enter.

-Now select from the drop down menu "roll back mac" branch.


Thanks everyone and I hope to get this resolved quickly!
Last edited by chubigans; Dec 31, 2013 @ 12:19pm
Showing 1-15 of 21 comments
< >
Judge Gregg Dec 27, 2013 @ 4:01pm 
Model: MacBookPro9,2, BootROM MBP91.00D3.B08, 2 processors, Intel Core i7, 2.9 GHz, 8 GB, SMC 2.2f41
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 1024 MB

running 10.9 Mavericks

I launch the game, and it crashes - no load screen, just goes straight to the error report window.

Same result as always:

Thread 4 Crashed:: Dispatch queue: NSOperationQueue 0x2bc55f0
0 CSDSteamMac 0x000a60e0 GetResolution(unsigned char*, int) + 27
1 CSDSteamMac 0x00007a78 BeginToEnd() + 100
2 CSDSteamMac 0x00004d9d -[Mac_RunnerAppDelegate performGameStep] + 2557
3 CSDSteamMac 0x00005066 -[Mac_RunnerAppDelegate doGameEngine] + 196
4 com.apple.CoreFoundation 0x9844711d __invoking___ + 29
5 com.apple.CoreFoundation 0x9844704b -[NSInvocation invoke] + 315
6 com.apple.Foundation 0x93c98297 -[NSInvocationOperation main] + 217
7 com.apple.Foundation 0x93d60d9c -[__NSOperationInternal _start:] + 702
8 com.apple.Foundation 0x93c906f1 -[NSOperation start] + 71
9 com.apple.Foundation 0x93d62fb8 __NSOQSchedule_f + 50
10 libdispatch.dylib 0x930accd9 _dispatch_async_redirect_invoke + 158
11 libdispatch.dylib 0x930a6a6a _dispatch_client_callout + 50
12 libdispatch.dylib 0x930ad794 _dispatch_root_queue_drain + 257
13 libdispatch.dylib 0x930a7ddf _dispatch_worker_thread2 + 39
14 libsystem_pthread.dylib 0x95a0ddaf _pthread_wqthread + 336
15 libsystem_pthread.dylib 0x95a11cd2 start_wqthread + 30
MedusaMeows Jan 2 @ 5:47am 
iMac
OS X Version 10.6.8
No background apps running. When game was launched right after downloading and install, Steam status showed I was In-Game and the game icon on the Dock was active but the screen just went white or nothing happened. Tried the rollbackmacversion solution and an update appeared. After updating, the game launched perfectly. :)
MedusaMeows Jan 8 @ 9:57pm 
After the latest steam update, CSD wont launch with or without the rollbackmac beta. Help.
chubigans  [developer] Jan 10 @ 9:56pm 
The latest Steam client update, or the game update? The game shouldn't have updated the rollbackmac version. Can you try uninstalling and reinstalling the rollbackmac build?
Mr. Sapphire Mar 29 @ 5:09am 
I'm having progressive slowdown. It's really slow and it lags. I'm not using a Mac, but a really good computer and i don't have any problems with other games. Please help
chubigans  [developer] Mar 29 @ 11:43pm 
Have you tried updating your graphics drivers to the most current?
Jhops Apr 4 @ 10:03pm 
I'm also having issues with decreasing FPS

I've checked and reinstalled the newest drivers for my video card, tried the integrated graphics option, tried changing compatibility (for all users - win95 through XP), disabled DPI scaling, ran as administrator, and waited at the main splash for over a minute. I typically don't post in forums because I do my due diligence in troubleshooting, but I can't find any more solutions.

System info:
Manufacturer: I built this system in January
OS Windows 8.1 Pro
CPU Intel i7 4660K @ 3.5
GPU 4gb EVGA Geforce GTX 760
Samsung 840 SSD
WD 500gb HDD
RAM 16gb
Motherboard: Asus Maximus VI Hero

If you have any other tips I could try, please let me know. I can barely get through one day in CSD before the FPS tanks. The only other game I know is a GM game, that I play, is Nuclear Throne. It's been a week or so since I played that, but it was fine last I knew. Thanks in advance.
chubigans  [developer] Apr 5 @ 7:45pm 
Currently I'm waiting on the Game Maker devs to make GM Studio 1.3, which should help solve the issue. But the next patch will not be running 1.3, so it may not help. Sorry for that but I will definitely update on this problem as soon as I get some concrete release info.
blockgolde Apr 14 @ 10:03pm 
i update today. (XP professional 2002 service pack2 ) now i cannot open the game
chubigans  [developer] Apr 14 @ 10:06pm 
Now that is very strange. Have you tried restarting your computer, and redownloading the game? Worst case scenario, I can set up a previous build so you can "roll back" to the last version.
blockgolde Apr 15 @ 3:30am 
restart and redownload ...... it doesn't work. when i open the game, I'v heard :''cooooooooooooooooooook,se..'' then close..but that OK, i have another computer (win7) goodbye XP
Last edited by blockgolde; Apr 15 @ 5:46am
chubigans  [developer] Apr 15 @ 9:00am 
Really strange. I guess I need to pull out my old computer from my closet and see what might be happening. Sorry about that!
KujiUn Jul 5 @ 7:25pm 
Crazy Dave isn't giving me the $600 after fulfilling the requirements, happening in both Extreme and Normal difficulty, both laptop and desktop, running W8.1U1.
Penny Dreadful Jul 18 @ 9:48am 
OSX 10.9.4; Mid-2011 Macbook Air; 1.7GHz Core i5; 4GB RAM

Game icon appears in the Dock, loading indicator flashes, but the game never launches. Also refuses to launch via in-home streaming from my Windows 8 desktop, if that's relevant -- it runs and plays fine on that machine, but doesn't appear on my Mac.

Have tried both the current and Mavericks rollback versions with no change.
Last edited by Penny Dreadful; Jul 18 @ 9:49am
Catasplurge Jul 18 @ 7:35pm 
Whenever I open the game I get this in a different window, the window just stays as a black screen.
XPS Dell desktop, got in 2013.
Windows 7

___________________________________________
############################################################################################
ERROR in
action number 1
of Alarm Event for alarm 0
for object initvarsO:

File not opened for writing.
at gml_Script_SCRPT_SaveClouds
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_SCRPT_SaveClouds (line 0)
gml_Object_initvarsO_Alarm_0
Showing 1-15 of 21 comments
< >
Per page: 15 30 50