m3rcur Nov 6, 2012 @ 5:29pm
[Solved] Not enough space in home folder
Hello

My home folder only have 2 gb free. After adding another folder in a different partition to "steam library folders" I still can't install any game.
I'm using Ubuntu 12.10. Thanks
Last edited by m3rcur; Nov 12, 2012 @ 5:03am
Showing 1-15 of 15 comments
< >
blackout24 Nov 6, 2012 @ 5:32pm 
How big is your disk? /home is usually the biggest partition if you let Ubuntu do everything on it's own. /root gets about 7 GB and almost everything of the rest goes to /home.

You could post your "df -h" output here.
boot Nov 6, 2012 @ 5:34pm 
Same issue, it doesn't let me choose where to install the games. The drop box is missing.
Lews Therin Telamon Nov 6, 2012 @ 5:35pm 
You have a number of options. The easiest is to symlink the "Steam" directory to another directory on your free partition. Move the "Steam" directory to where you want it on the other partition, then run the following in your home directory:

ln -s /path/to/Steam Steam

Another option would be to directly mount the new partition in the Steam directory.
m3rcur Nov 6, 2012 @ 5:41pm 
My Ubuntu partition have 15 GB (root and home). I have one big partition (2 TB, ntfs) shared with windows (50 GB partition):

/dev/sda5 15G 12G 2,8G 81% /
/dev/sdb1 1,9T 1,2T 678G 64% /media/default/BIG
/dev/sda2 51G 40G 11G 79% /media/default/WIN7
Netist Nov 6, 2012 @ 5:45pm 
Originally posted by m3rcur:
My Ubuntu partition have 15 GB (root and home). I have one big partition (2 TB, ntfs) shared with windows (50 GB partition):

/dev/sda5 15G 12G 2,8G 81% /
/dev/sdb1 1,9T 1,2T 678G 64% /media/default/BIG
/dev/sda2 51G 40G 11G 79% /media/default/WIN7
Well there's your problem.

Make a symlink that links ~/Steam to some folder in /media/default/BIG
Shigutso Nov 6, 2012 @ 6:04pm 
Your partition /dev/sdb1 probably is NTFS, right?
If positive, your Steam Linux folder may not work properly. You may need to have a big EXT3/EXT4 partition.

15GB for your whole Linux with Steam is not enough.
Vash Nov 6, 2012 @ 9:13pm 
Considering ~/.steam/root is a symlink to ~/Steam, the more elegant solution would probably be to just change the symlink ~/.steam/root to wherever you want it to be stored.
m3rcur Nov 12, 2012 @ 12:51am 
After some partition resizing and UUID changing I finally got it working :) Great work Steam
The Gym Man [ITA] Nov 14, 2012 @ 12:30pm 
Hi, I have your same problem. I need to install the games in the NTFS partition because I have not more free space in the ext4 /home partition. So, can I installl the games in the NTFS partition or do I have to install them in an ext4 partition?

Sorry for bad english, I'm italian ;)
o-bin-lad3n Dec 11, 2012 @ 11:52am 
I tried that exact thing (symlinking Steam to NTFS) and had it working till yesterday, but todays update broke it. Now Steam tries to verify my TF2 files and hangs at 100%, or rather causes mount.ntfs to use 100% CPU and wait indefinitely.
An Infinite Number of Monkeys Dec 11, 2012 @ 11:54am 
Steam generally dislikes symlinks. This same (hanging at 100%) problem would happen running it in Wine if you had tried to move it to a different volume and use symlinks. If you have another, larger partition available, I'd suggest mounting that volume, rsyncing your homedir to it and then remounting it as home.
crinkled Dec 12, 2012 @ 4:43am 
Filesystem Size Used Avail Use% Mounted on
/dev/loop0 17G 7.8G 9.1G 47% /
udev 1.9G 4.0K 1.9G 1% /dev
tmpfs 772M 908K 771M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1.9G 3.0M 1.9G 1% /run/shm
/dev/sda3 578G 170G 408G 30% /host

I kinda got lost in you guys' discussion. It seems there is a solution depending on each case. I guess I'd like to avoid the symlinks. Can anybody help me out on what would be my easiest solution so I can get to playing some TF2 on my linux? cheers
o-bin-lad3n Dec 29, 2012 @ 8:08pm 
@crinkled: sorry for the late answer, I did not notice your post until now.
You should be able to just move your ~/.steam folder to /host/steam for example and start steam. It will complain that it can't find your content data or something and will offer you to search for it. In the upcoming dialog, select /host/steam or wherever you put it and you should be good to go.
crinkled Jan 6, 2013 @ 6:37am 
thanks osama. i'll give it a go and let you know
crinkled Feb 14, 2013 @ 4:34am 
it worked. my games are downloading. thanks for the help, binlad3n!
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Nov 6, 2012 @ 5:29pm
Posts: 15