Fionn Feb 27, 2013 @ 9:22am
Ubuntu crashes when steam loads
I have installed Ubuntu 12.1 64bit and installed steam. I checked for broken package dependencies in synaptics and I have installed some of the suggested packages in other posts on the forum but every time I load steam, Unbuntu crashes and restarts. I get to see the library and splash screen after logging in for 1 second before it crashes.

I don't really know where to start troubleshooting, any suggestions would be appreciated.
Showing 1-15 of 18 comments
< >
さくら Feb 27, 2013 @ 9:27am 
Start an xterm, try to start Steam from it (usually 'steam')

You probably need to install the i386 libc6 too.
Shark Feb 27, 2013 @ 9:46am 
If you get logged out it's probably a graphics driver issue, if it really restarts the entire system their might be something wrong with your hardware.
Last edited by Shark; Feb 27, 2013 @ 9:46am
Fionn Feb 27, 2013 @ 9:51am 
It doesn't go back to the bootloader, it goes to a crash screen and then the GUI reloads without any applications loaded.

Is there a way I can log the output of xterm so I can check for error messages? Should I try to install some other nvidia drivers?
Shark Feb 27, 2013 @ 9:58am 
just to be sure try this in terminal:
sudo apt-get update
sudo apt-get install linux-headers-generic ia32-libs
sudo apt-get upgrade

after that reboot and it might work, if it doesn't you'll need to reinstall your drivers.

You can get into a terminal window with ctrl+alt+f3 and go back with ctrl+alt+f7
Last edited by Shark; Feb 27, 2013 @ 10:47am
Fionn Feb 27, 2013 @ 12:23pm 
It definitely seems to be a graphics driver problem. Thanks for the help.

I disabled the default driver and steam works now. I'm trying to install the nvidia driver now.

Thanks for the help.
Fionn Feb 27, 2013 @ 2:24pm 
Steam has started working now. I had problems installing the nvidia drivers and in the end I gave up. I tried loading steam while the desktop was using a lower resolution and it worked. I switched back to 2560x1440 and steam loads now without errors. I'm not sure if it had something to do with the splash screen that was appearing advertising steam deals(that has stopped appearing) or my bigger than normal resolution. I can't reproduce the problem now.

Downloaded one game( Bastion ) and that is crashing when I try to run it. I'm downloading some others now to check if it's isolated to that game.
Last edited by Fionn; Feb 27, 2013 @ 2:25pm
ThOR27 Feb 27, 2013 @ 2:31pm 
You need nvidia drivers to play most games on steam.
Fionn Feb 27, 2013 @ 2:41pm 
Ok, i guess i'll have to try getting those to work then. Thanks.
Shark Feb 27, 2013 @ 3:04pm 
Just install it from the additional drivers tab in software sources, that should work.
Fionn Feb 27, 2013 @ 5:00pm 
It wasn't listed in the additional drivers tab, that's empty on my install for some reason. I had to get it with apt-get and then I had problems getting the correct resolution. I managed to fix that by editing xorg.conf and now I have everything working correctly.

Thanks alot for the help in getting this sorted.
さくら Feb 27, 2013 @ 6:06pm 
Check /var/log/Xorg.0.log (and Xorg.0.log.old, /var/log/syslog or syslog.0 (or .1 if it's far enough back), what you're looking for is what happened around the time things imploded.

Easiest way is if you can repeat the error, then just force it, jump to a tty and start looking in the relevant logs (midnight commander (aka mc)) is useful here.

What you're looking for would most likely be a segfault in xorg, or something along those lines.
Last edited by さくら; Feb 27, 2013 @ 6:07pm
MrTheSoulzツ Feb 27, 2013 @ 7:45pm 
to install nvidia drives you need linux-hearders-generic on ubuntu 12.10, thats why you get low resulotion and compiz dosent work
Junior s2 Camila Feb 27, 2013 @ 7:57pm 
Post the output of
uname -r
Shark Feb 28, 2013 @ 12:05am 
Originally posted by Fionn:
It wasn't listed in the additional drivers tab, that's empty on my install for some reason. I had to get it with apt-get and then I had problems getting the correct resolution. I managed to fix that by editing xorg.conf and now I have everything working correctly.

Thanks alot for the help in getting this sorted.
Are you sure that you aren't using an Nvidia optimus setup with an intel gpu?
Fionn Mar 1, 2013 @ 12:27pm 
This is fixed btw, in case anyone thinks I am still having a problem. Nvidia drivers are installed, resolution is at 2560x1440 and my steam games are working.

Thanks for the tips on checking the log files, I'll keep that in mind next time I am troubleshooting. I had installed the linux-headers-generic before installing the nvidia drivers, it didn't help in my case. I also installed another one that was recommended, I think it was linux-source. I was trying to change the resolution with xrandr but I kept running into problems. Evenually I edited xorg.conf and added my resolution in there and it worked.

/var/log$ uname -r
3.5.0-25-generic

The board has an onboard intel graphics, the graphics card is a 670 GTX. It's not setup to use Optimus however or at least I have never used it that way. I built the pc and I didn't change anything in the bios to enable that.
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Feb 27, 2013 @ 9:22am
Posts: 18