Half-Life 2 > General Discussions > Topic Details
Puglet Jul 6, 2013 @ 2:12am
game stutters/freezes often
Well, I've played HL2 before the "file conversion" and I've never had problems. I've always played it with max graphics settings and I've never had stuttering/freezing problems during the game, so... I'm wondering what the hell is happening now? I've even set the graphics settings to minimum and the problem still persists. Is there a fix or I'm doomed?

P.S. Just so you know, I'm playing Alan Wake at max graphics settings and I don't have any kind of problem <.<
Showing 1-15 of 102 comments
< >
CallaWolf Jul 13, 2013 @ 4:34pm 
I'm having the same exact issues. I'm playing Half-Life 2 again (I've played it so many times I've lost count now. I also have it running at high settings), and it's stutters/freezes, then resumes again. And it seems to happen randomly. Before it loads, after it loads, after I save it, while I'm shooting down a drop ship. Never happened before the recent "file conversion" so I'm thinking it's something to do with that but I'm not sure.

It's happened not only in Half-Life 2, but also in Episode 1 for me (I started playing it before deciding to play the core Half-Life 2 first). I even tried to verify the game cache (when you right click -> properties -> local files, all within steam) and it did nothing. Maybe it has to do with that conversion and Valve needs to fix it.
Bennster Jul 20, 2013 @ 3:21am 
I'm having the same issue, having played the game on max settings ages ago, now I get little stutters at loading points - makes me wonder if there's a problem with the game not being able to preload data before I reach an area that wasn't there before...any solutions out there?
Bennster Jul 21, 2013 @ 4:01am 
BUMP - anybody able to help?
Puglet Jul 21, 2013 @ 4:41am 
I'm waiting for a solution too
Bennster Jul 21, 2013 @ 2:32pm 
Well, my friend, I have a solution that's worked for me - but no guarantees it'll solve all your problems (or bring world peace etc etc)
I used a regisrtry cleaner (free one) which found 745 reg issues to resolve and cleaned up all the temp files etc. - I also disabled multicore rendering.
Amazingly - it worked, which makes me think as I've had the game ages I may have had something clogging up the registry.
CallaWolf Jul 21, 2013 @ 8:30pm 
I'll try that as well to see if it fixes it. Thanks for posting that!
Puglet Jul 21, 2013 @ 11:21pm 
I always do a regular registry cleaning but that's not the solution for this issue. Multicore rendering may be. I'll let you guys know if anything changes. Thanks.
Thunderfury Jul 22, 2013 @ 11:23am 
Any update on this? It's really killing me with the stuttering, freezing, and longer than normal load times. I can't play more than five minutes with a huge freeze spike for about twenty seconds.
olephart Jul 24, 2013 @ 4:24pm 
I'm having this issue too. The console says the video driver has crashed.

Never had this issue before the conversion.
Thunderfury Jul 24, 2013 @ 6:00pm 
I never had a problem with it up until this latest update.
Puglet Jul 25, 2013 @ 12:57am 
I'm told this problem is also happening with the first Portal (of course after the conversion). At this point I think there's nothing we can do. Let's hope Valve will fix it asap.
Thunderfury Jul 25, 2013 @ 4:15pm 
It's sad when the game worked better on my old PC before this damn conversion. :P
Puglet Jul 25, 2013 @ 10:31pm 
It's a paradox.
DBThanatos Jul 27, 2013 @ 8:56pm 
Same here. I know Im late to join the conversation, but Im getting this issue constantly, and is annoying as hell.
Thunderfury Jul 28, 2013 @ 9:08am 
It's still a great game, it's just a problem of immersion for the load times.. and the insanely random freezeups.
Showing 1-15 of 102 comments
< >
Per page: 15 30 50
Date Posted: Jul 6, 2013 @ 2:12am
Posts: 113