Mizipzor Oct 2, 2012 @ 12:14pm
Unable to play sound
I'm following the "catch the clown" tutorial (http://sandbox.yoyogames.com/make/tutorials) but having some problems getting the sound to play. It works fine when the sound object is created (when the file imported) in the "preview" dialog. But not when the game is actually launched. I don't think I made any mistakes, I've done the same tutorial with older versions of GM.
Showing 1-5 of 5 comments
< >
Funny name for a girl Oct 2, 2012 @ 12:20pm 
Try nipping into Global Game Settings and unticking "Use New Audio Engine". They've recently changed the sound system and I think the latest update defaults to the newer system rather than the old which the drag and drop relies on.
DarkChaplain Oct 2, 2012 @ 1:03pm 
That did the trick, thanks RobF!
FireFox Bancroft Oct 2, 2012 @ 2:05pm 
I get an error that it can't find a specific file when I try to open the Global Game Settings. Something about a missing Android file. Not sure why. The file it's referring to is an icon file for android. and it's looking for icon170.png which for some reason is missing.
Last edited by FireFox Bancroft; Oct 2, 2012 @ 2:08pm
Funny name for a girl Oct 2, 2012 @ 2:29pm 
I think, no promises as I've hit upon similar disappearing resources in the past but not this particular one, you can fix this fairly easily if it happens.

If you open up one of the demo projects it should create a folder in documents/gamemaker/projects (or similar) for that project. In there, there should be a configs folder.

Copy that, nip back out to documents/gamemaker/projects and go to the project folder you were trying to get to run and paste it in there.

That's fixed missing icons etc... before now for me. As I say, can't promise on that one but it sounds similar.
Mizipzor Oct 3, 2012 @ 3:53am 
Originally posted by RobF:
Try nipping into Global Game Settings and unticking "Use New Audio Engine". They've recently changed the sound system and I think the latest update defaults to the newer system rather than the old which the drag and drop relies on.

And here I was in the settings dialogs hunting around for exactly something like that. I saw that they have a new theme and assumed something related to sound playing had changed as well. I'll test your advice as soon as I get off work, thanks!
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Oct 2, 2012 @ 12:14pm
Posts: 5