branwen-mel-vlonylene Apr 29 @ 2:31am
Is it possible to play on 64 bit linux?
Hi, I am posting from my university machine so i will be brief.

is it possible to play this game on 64 bit arch? I downloaded it yesterday but games fails to start. A little googling says the linux version runs on 32 bit.

Just for info, I have multilib enabled.

specs:
Arch, X86_64 , nvidia properietry drivers, xfce

Thanks a lot in advance.
Showing 1-4 of 4 comments
< >
Dr.Disaster Apr 29 @ 5:11am 
LoG runs on 64 bit Linux too so there might be something missing on your linux distribution. Any error message i.e. missing libs?
branwen-mel-vlonylene Apr 29 @ 9:00am 
Yep , the missing is libopenal.so. but pacman -Ss openal informs that openal is installed.

additionally, the executable is bin.x86 ,
branwen-mel-vlonylene Apr 29 @ 10:12am 
Here is the output of gdb



Reading symbols from Grimrock.bin.x86...(no debugging symbols found)...done.
(gdb) r
Starting program: /home1/xxxxxxx/SteamLibrary/SteamApps/common/Legend of Grimrock/Grimrock.bin.x86
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
szCmd: /bin/sh -c '"/home0/xxxxxxx/.local/share/Steam/steam.sh" steam://run/207170' &
[Inferior 1 (process 1448) exited normally]
(gdb) Running Steam on arch 64-bit
STEAM_RUNTIME is enabled automatically
bt full
No stack.
(gdb)

I don't even get a blank screen.
Dr.Disaster Apr 29 @ 11:17am 
Originally posted by branwen-mel-vlonylene:
Yep , the missing is libopenal.so. but pacman -Ss openal informs that openal is installed.

additionally, the executable is bin.x86 ,
odd .. LoG's 64 bit executable is Grimrock.bin.x86_64

When the _64 is missing it seems to me that your Steam client (or the LoG installer, dunno) failed to detect your 64 bit kernel and set up the 32 bit version instead.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50