DiRT 2 > General Discussions > Topic Details
Eugene Dec 21, 2012 @ 4:35pm
Dirt 2 won't start
I just purchased and installed this game and it won't start. It appears not to install properly, as in there is no install process. It just downloads and it says it's ready to play but it's clearly not. I've verified the game cache and it says it's all fine, it just won't work. I've un-installed and re-installed multiple times, and even completely uninstalled and re-installed steam.
I tried installing the demo from Windows Live Marketplace and that worked fine.
I'm pretty sure the issue is somehow related to the steam client.
I'm running Windows 8 Pro.
Showing 1-15 of 15 comments
< >
Daniyyel Dec 22, 2012 @ 2:25am 
I have exactly the same problem on Windows 8 x64. The game does not start. I hit "play" and nothing... The same game worked on Windows 7 x64. I also tried to uninstall/reinstall Steam and the game, same result.
Damien Dec 22, 2012 @ 5:54am 
This worked for me: Uninstall the Games for Windows Live client that Dirt2 installed, reinstall a fresh copy from www.xbox.com (choose XBox Live - bottom of that page).

EDIT: This was on Windows 8 64-bit.
Last edited by Damien; Dec 22, 2012 @ 5:54am
Eugene Dec 22, 2012 @ 6:56am 
As Damien suggested, I managed to fix my problem by re-installing the GFWL client... As detailed in this thread...

http://forums.steampowered.com/forums/showthread.php?t=2849054

The version of the GFWL client included with Dirt 2 doesn't seem to work. It has to be the one from here...

http://www.xbox.com/en-GB/LIVE/PC/DownloadClient
Damien Dec 22, 2012 @ 8:12am 
Thanks eugenejobrien, I only had the swedish URL to link here :)
Daniyyel Dec 22, 2012 @ 12:01pm 
Unfortunately nothing from above fixed my problems. I tried installing/reinstalling them all, I even cleaned everything related to DiRT2 and GFWL from my hard drive or registry and still nothing.

The last thing that I wanted to check was to create a new Windows user and try to run the game from the new user. The game did not started but this time I received an error and this was all I needed.

Faulting application name: dirt2.exe, version: 0.1.0.8, time stamp: 0x00000000
Faulting module name: avcuf32.dll, version: 3.10.7143.4226, time stamp: 0x509d2a97

A quick search revealed that the dll above was in "C:\ProgramFiles\Bitdefender\Bitdefender 2013\Active Virus Control"

I disabled "Active Virus Control" from my Bitdefender 2013 AntiVirus and voila ! The game runs again.

Thank you.
Last edited by Daniyyel; Dec 22, 2012 @ 12:01pm
Sam.45 Dec 28, 2012 @ 10:40am 
you have Nvidia? or ATI? Unistall Nvidia PHysX , PhysX Crash Games : Metro 2033, GTA IV, DIRT2... Esect. I Dont speak English , But, I could help you :)
Emeerio Dec 31, 2012 @ 1:00pm 
I disabled Virtu MVP for Dirt2 like I did for Metro 2033 to make it work, and it seems to startup fine now. Hope this helps.
Lowlander Mar 16, 2013 @ 7:48am 
Originally posted by Daniyyel:
Unfortunately nothing from above fixed my problems. I tried installing/reinstalling them all, I even cleaned everything related to DiRT2 and GFWL from my hard drive or registry and still nothing.

The last thing that I wanted to check was to create a new Windows user and try to run the game from the new user. The game did not started but this time I received an error and this was all I needed.

Faulting application name: dirt2.exe, version: 0.1.0.8, time stamp: 0x00000000
Faulting module name: avcuf32.dll, version: 3.10.7143.4226, time stamp: 0x509d2a97

A quick search revealed that the dll above was in "C:\ProgramFiles\Bitdefender\Bitdefender 2013\Active Virus Control"

I disabled "Active Virus Control" from my Bitdefender 2013 AntiVirus and voila ! The game runs again.

Thank you.

OMG, thank you so much Daniyyel! I have been beating my head against a wall on this issue and your post made me look at BitDefender 2013, I have it too, when I disable it, it makes the game run. Sillyness... Thanks again!


UPDATE: I just had to add dirt2.exe to the list of exclusions now it works everytime without having to turn off the Active Virus Control.
Last edited by Lowlander; Mar 18, 2013 @ 12:36pm
Pur3Bolt May 28, 2013 @ 1:42pm 
Originally posted by Daniyyel:
I disabled "Active Virus Control" from my Bitdefender 2013 AntiVirus and voila ! The game runs again.
This worked! Thanks so much for this :D
PsychoBR Jul 14, 2013 @ 7:04am 
Works for me also! Thanks so much for this :D
[BC]Frerol Jul 14, 2013 @ 1:38pm 
Same thing has been happening to me
cann.abal Jul 20, 2013 @ 2:44am 
You guys are the shizzz, Thank you so much!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
SlantyShanty Jul 20, 2013 @ 9:23pm 
I really had no clue what was going on, and there is so much advice here! thank you for advice guys!
zaphodikus Aug 24 @ 4:55am 
Run as Administrator. That fixed it. The game is clearly needing permissions to do stuff that Microsoft have subsequently disabled - I did patch it, which did not help untill I spotted the thread and it gelled n my mind how to solve this.
Aurora Aug 24 @ 5:46am 
try run dirt 2 in xp sp3 compatible
Showing 1-15 of 15 comments
< >
Per page: 15 30 50