Cities: Skylines

Cities: Skylines

Arrowhead Valley (Official Map)
Flux  [developer] Sep 25, 2016 @ 12:48pm
Having Trouble? Check Here! (Troubleshooting and FAQ)
Frequently Asked Question:

Do I need to download all the asset dependencies?

Nope! The only *true* dependency is the Network Extensions mod. Of course, if you load the map without the custom map theme it will not have the same desert textures, so we highly recommend you also install the custom map theme. If you’d prefer to not bother with the custom foliage, feel free to load the map without them and add your own!

-----------------------------------

I loaded the map and the textures are not showing up, what do I do?

First, make sure you’re subscribed to the “Arrowhead Valley” map theme. Next, ensure when you load your map you’re selecting the “Arrowhead Valley” map theme in the dropdown menu. Finally, it appears there’s a bug with map themes right now where simply clicking “continue game” will load the map without the custom map theme. Using “load game” is the most reliable way to avoid having issues.
If for some reason you still can’t get your map theme to load (or any map theme on any map, for that matter. This seems to be a global issue) you can try using the “environment changer” mod to “refresh” the save by first loading the game with the “none” map theme enabled, saving, closing the game, then loading the save with the correct map theme again. I can’t 100% confirm or give detailed instructions on what combination of saves/loads will properly refresh the savegame, but I’ve been told by others that this method is effective

-----------------------------------

I get a “System.NullReferenceException” error, how do I fix it?

“System.NullReferenceException” occurs when an object is “called” in-game, but the asset the game is calling isn’t found. This can happen for a number of reasons, so it isn’t always easy to diagnose.
If this happens while loading the map: make sure you have the Network Extensions mod not only installed, but enabled in the mods menu
If this happens while playing the game: ensure you haven’t accidentally disabled all the possible vehicles in a given category in the Advanced Vehicle Editor. If this is the case, once the game tries to spawn on of these vehicles, you will get the error.
Beyond that, the best thing to do is try removing all the mods you don’t need to run the map. 99% of the time, it’s either a mod incompatibility, a missing mod that you may have previously had enabled, or a setting in a current mod causing the problem. Troubleshooting game crashes comes with the territory when using lots of mods, unfortunately.

-----------------------------------

My game crashes when loading the map, why?

Sometimes when loading a map with lots of assets in Cities: Skylines the loading screen will “hang” for long periods of time (even upwards of 15 minutes, depending on how many mods you have and how fast your storage device is). This is completely normal, and sometimes your OS will tell you “Cities: Skylines.exe has crashed!”. If this happens, and you are given the option to “wait for the program to respond”, click that option and continue to wait. Sometimes, however, your game will simply crash. If you can’t seem to get the map to load with a large number of assets, try the “Don’tCrash” mod. This mod is often times critical for loading savegames with a large number of assets (and is included in our Arrowhead Junction mod collection!).

Keep in mind that the only true dependencies for this map are Network Extensions and the map theme, so you don’t need to subscribe to our collection (or the foliage listed in dependencies) in order to run the map!

-----------------------------------

I have another problem that is not listed here, how can I get help?

You can post a comment below describing the issue you are having. Please be as detailed as possible, tell us the steps you took and don’t be afraid to post screenshots/gifs/videos (you can upload them to Imgur.com).
< >
Showing 1-15 of 22 comments
Picturacy Sep 26, 2016 @ 10:28am 
I've this Error box:
"The Mod E:\Jeux\Steam Jeux\steamapps\workshop\content\255710\422554572 [EightyOne.dll] has caused an error [ModException]

Details:
System.ArgumentNullException: Argument cannot be null.
Parameter name: key
at System.Collections.Generic.Dictionary`2[System.Reflection.FieldInfo,System.Reflection.FieldInfo].Add (System.Reflection.FieldInfo key, System.Reflection.FieldInfo value) [0x00000] in <filename unknown>:0
at EightyOne.Unlimiter.GetFieldsFromStruct (System.Object newArray, System.Object oldArray) [0x00000] in <filename unknown>:0
at EightyOne.ResourceManagers.FakeWaterManager.Init () [0x00000] in <filename unknown>:0
at EightyOne.Unlimiter.EnableHooks () [0x00000] in <filename unknown>:0
at EightyOne.ModLoad.OnLevelLoaded (LoadMode mode) [0x00000] in <filename unknown>:0
at LoadingWrapper.OnLevelLoaded (UpdateMode mode) [0x00000] in <filename unknown>:0 "
xXN0SK0P3ZXx Sep 26, 2016 @ 5:20pm 
@Prolapsus: Install "Don't Crash" and then unsub and resub to 81 tiles
DontH8ImOnly9 Sep 26, 2016 @ 9:15pm 
when i got to place water pipes i dont get a view map for where i have already put pipes or the range the pipes work
Picturacy Sep 27, 2016 @ 5:12am 
Originally posted by xXN0SK0P3ZXx:
@Prolapsus: Install "Don't Crash" and then unsub and resub to 81 tiles

Ok that's work. But i've the same problem than "Give Me The Formuli"

"when i got to place water pipes i dont get a view map for where i have already put pipes or the range the pipes work"
Last edited by Picturacy; Sep 27, 2016 @ 5:44am
Flux  [developer] Sep 27, 2016 @ 4:45pm 
That's a result of the "no more whiteness" mod (or whatever it's called). If you want to see the overlay when placing pipes click on the "information overlay" button on the top left while placing pipes and it'll toggle it back on
Oct 1, 2016 @ 1:07pm 
MAP THEME DOESNT LOAD UP: Ok, so i tried everything said in "I loaded the map and the textures are not showing up, what do I do?" and help from forums on the internet but nothing seems to work. Im out of ideas so decided to ask you guys, do you have any idea how to get the theme to work?
Dr.Dean Oct 2, 2016 @ 3:02pm 
How do you use the custom ressource texture. When I place farms, it uses the default flashy green and it doesn't fit the theme.
Flux  [developer] Oct 3, 2016 @ 2:51pm 
@Dr. Dean To get a proper green "fertile land" texture, we had to make it a bright green color (which is applied in a diluted manner when using the "fertile land" brush in the advanced landscaping mod). Unfortunately, this means assets that use this color at 100% oppacity (ie. farms) will look odd. I believe you can simply use the surface painter tool to removed the farmland that comes with the farms, but I would reccomend instead using the building theme manager to remove farmland from your city when playing with this map theme. It looks much better to instead have only the farmhouses/silos/etc. themselves spawn (lots of good custom stuff for them) then create the farmland yourself.

I'm sorry I can't offer a more elegant solution other than "don't place vanilla farms", but this is the only way to get the "fertile land" tecture looking like nice green grass
Oct 3, 2016 @ 3:35pm 
So is there no fix to my problem above? ^ I would really like to start with the map. Please, anything, you can add me on steam and we can figure it out via private messages.
simnonymous007 Oct 11, 2016 @ 7:46pm 
Because the complete Arrowhead Junction Collection crashed my game, I am adding mods and assets gradually. And, maybe because of that, my version of the map does not include any shrubbery. Otherwise, the map and theme work; are there specific shrubbery assets that I need to subscribe to to get the map to display in its full glory? (Similar Q asked at AJ episode 1 on YT.)

Edit and Answer: Yes, I needed to subscribe to plant assets. What I did was go to the AJ Collection (It's in Strictoaster's workshop) and subscribe to all the plant, shrub and tree assets. Now, if I start a NEW game, I have the map in all its glory. Unfortunately, the game I already started, with a cool power station and waste disposal site, still uses the barren map. So I guess I have to start over. It'll be worth it to have the map complete with vegetation.

I hope this addition to the discussion might help anyone else in a similar situation.
Last edited by simnonymous007; Oct 11, 2016 @ 8:28pm
I have map and theme subscribed, the theme is selected when I start the new game in the map, but no trees and bushes are spawning, why?
Flux  [developer] Oct 30, 2016 @ 11:33am 
@Mercurl von Kastilien You need to subscribe to the "required items" on the right hand side of the custom map's page. All the foliage in this map is custom, so if you aren't subscribed to it the map will load blank
Nov 2, 2016 @ 4:30am 
Can anyone still help me with my problem above? ^
what a bałagan Nov 5, 2016 @ 11:00am 
Method not found: 'NetSegment.GetLeftAndRightLanes'. [System.MissingMethodException]

Details:
No details

and my map is bllured all the time unless i zoom in
Flux  [developer] Nov 16, 2016 @ 7:42pm 
@fLowWs0n looks like you don't have the Networks Extensions mod enabled. Did you subscribe to it? Have you double checked that it's enabled in the mods menu?
< >
Showing 1-15 of 22 comments
Per page: 15 30 50