XCOM 2
Stop Wasting My Time - WotC
 This topic has been pinned, so it's probably important
BlueRaja  [developer] Feb 9, 2016 @ 11:13pm
How to disable specific changes made by this mod:
For slow-mo changes, delete the following file:
Steam\steamapps\workshop\content\268500\620600092\Config\XComCamera.ini


For increased Avenger movement:
Steam\steamapps\workshop\content\268500\620600092\Config\XComGameData.ini

All other changes require unsubscribing from the mod.
Last edited by BlueRaja; Mar 11, 2016 @ 9:24am
< >
Showing 1-15 of 21 comments
Bigfoot Boomer Feb 9, 2016 @ 11:17pm 
Thx man ur a LEGEND
Perchin2k Feb 10, 2016 @ 9:36am 
Thanks for adding this, even tho i think it's fine how it is
Last edited by Perchin2k; Feb 13, 2016 @ 8:45am
petes117 Feb 11, 2016 @ 12:20am 
Any way to remove or customise the movement speed of the Avenger? Excellent work though, much appreciated
Dick Justice Feb 11, 2016 @ 7:53am 
Appreciate this. Mod is great, but I'm personally fine with the default running speed.
Blackdragonbird Feb 11, 2016 @ 12:05pm 
Thank you. The increased movement speed of soldiers are very strange, too fast to my tastes. And the Avenger speed increase was showing wrong hours and time, AM to PM and vice versa, in the clock when moving.
BlueRaja  [developer] Feb 11, 2016 @ 12:12pm 
Originally posted by Blackdragonbird:
The Avenger speed increase was showing wrong hours and time, AM to PM and vice versa, in the clock when moving.

That is just how the Avenger works, it does that even without any mods. Watch it sometime - the time as it moves is meaningless because the time jumps by a large amount immediately after the Avenger lands.
Last edited by BlueRaja; Feb 11, 2016 @ 12:12pm
I've noticed the time actually jumping backwards when I land. It'll jump forward on takeoff, move while moving, then jump back on landing. Very odd. (not an effect of the mod, just something I noticed in general about the Avenger)
petes117 Feb 11, 2016 @ 10:58pm 
The Avenger still goes faster even after deleting that ini file. Oh well not a deal-breaker for me this mod still rocks :)
Scorpicullis Feb 15, 2016 @ 9:45pm 
I chalk up the time adjustments to the Avenger resetting based on the time zone you land in.

No idea if that's actually true lol
Daassie  [developer] Feb 18, 2016 @ 6:57am 
For posteriority: the standard values in the game's base XComanimation.ini file are as follows (on 2016-02-18):

[XComGame.X2Action_MoveDirect]
MaxUnitRunRate=1.0; Max animation play rate for units running
MinUnitRunRate=0.7; Min animation play rate for units running
Last edited by Daassie; Feb 18, 2016 @ 6:58am
gokkel Feb 19, 2016 @ 7:30am 
Deleting XComGameData.ini did not change back Avatar movement speed, but the other instructions appear to work.
BlueRaja  [developer] Feb 19, 2016 @ 10:09am 
@gokkel: That's due to a game-engine bug, please see here.
Last edited by BlueRaja; Feb 19, 2016 @ 10:09am
AngelOfIron Mar 5, 2016 @ 2:41pm 
Finally found out how to access this file, but I'm still not certain what all needs to change. I want my XCOM units to continue firing as quick as they are now, but I don't want the untargeted aliens to remain running at normal speed as they scatter for cover.
Daassie  [developer] Mar 5, 2016 @ 3:34pm 
If you are in the right file (as instructed in the OP for slow-mo changes; it is NOT all just one file) things should be very straightforward, see here: http://i.imgur.com/K6JfskU.png. Tweak that value to your liking.
AngelOfIron Mar 5, 2016 @ 4:51pm 
Originally posted by Rando Feederson:
If you are in the right file (as instructed in the OP for slow-mo changes; it is NOT all just one file) things should be very straightforward, see here: http://i.imgur.com/K6JfskU.png. Tweak that value to your liking.

This isn't what I'm referring to. One of the changes that I've seen made has to do with the targets that're being targeted during Overwatch. Before, when Overwatch came into effect, all units on the opposing side slowed down. Now it only slows down the unit being targeted, while all the others are at normal speed. This is seen most easily when pods are activating; one unit will be the focus of everyone's fire, and be rendered in slow motion, while all his buddies continue on moving at normal speed. That's what I'm looking to fix.
< >
Showing 1-15 of 21 comments
Per page: 15 30 50