Arma 3
Athena - An Arma 2nd Screen Application
bus  [developer] Nov 2, 2017 @ 4:21am
Bug Reports
Please post any bug reports to this discussion.

Known bugs:

1. ACS.exe false positive as a virus - this is being resolved with a minor update today 2017/11/02

2. Cannot rewind recording playback - this has been resolved by a pending update 2017/11/02

3. Cannot load/save file - this has been resolved by a pending update 2017/11/02

4. Exporting a map over wifi to a 2nd device is extremely flaky. Some temporary work arounds are to export using Athena running on just your PC and then copying the map folder to your 2nd device (My Docs\Athena\Maps) or downloading from my ACS: acs.athenamod.com.

5. Changing the settings in the AthenaExtensionSettings.txt has no effect. This issue is resolved. Just waiting to release.

6. ACS (Athena Community Server) is buggy. This is being actively worked on.
Last edited by bus; Nov 4, 2017 @ 12:05pm
< >
Showing 1-15 of 18 comments
Ryu Dec 8, 2017 @ 6:39pm 
Athena is not detecting the Chernobyl map, and the connection just says "pending".
I have given the mod permisions when that window popped up.
bus  [developer] Dec 8, 2017 @ 8:39pm 
I'll try the Chernobyl map. Does 'any' map work for you?
TheNightstalk3r Dec 14, 2017 @ 10:40am 
the entire program stopped working. This morning I could use it just fine, but now it won't even detect the map when joining the server fresh
bus  [developer] Dec 14, 2017 @ 2:47pm 
NightStalker: check the battleeye log, make sure the relay is running, did athena auto open?
Dr.Shimapan Dec 20, 2017 @ 6:56am 
group tracking appears to be non-responsive
fullscreen app on second (tiny) monitor omits bottom parts of UI, screen size is 7"
bus  [developer] Dec 21, 2017 @ 3:54pm 
Doc Shim - I'll look into both issues, attempt to recreate them and include fixes in next release.
New to Arma and Athena.

Getting app crash when zoom in/out of a loaded map. I'm using dual monitors on latest windows 10. Error log from event viewer:

Faulting application name: athena desktop.exe, version: 0.0.0.0, time stamp: 0x5a06322e
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x034cdd1c
Faulting process ID: 0x593c
Faulting application start time: 0x01d38a4ced65ee84
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Arma 3\!Workshop\@Athena - An Arma 2nd Screen Application\app\athena desktop.exe
Faulting module path: unknown
Report ID: 2028dd16-8c49-4e7c-807f-3a3cc115ef38
Faulting package full name:
Faulting package-relative application ID:

Let me know if you need any further info.
bus  [developer] Jan 10 @ 2:24pm 
Fiery - Haven't seen that one before. Some users may have experienced it but noone's reported it before. 0xc00000005 is a video driver related issue. I'm not going to advocate that you jump through hoops reinstalling or changing video card drivers just for Athena but without being in front of the device, that's kind of the only pointer I can give you. What video card/driver do you have?
it's a GeForce GTX 960, found this also on the relay.exe.log around the time of the error

10/01/2018 20:04:15 :: Listener.ReceiveCallback :: An error occurred. More info: An existing connection was forcibly closed by the remote host
10/01/2018 20:04:15 :: HandleClientDisconnected :: Unexpected error during read operation. More info: An existing connection was forcibly closed by the remote host
10/01/2018 20:05:07 :: SendPipeMessage :: Error: Pipe is broken.
10/01/2018 20:05:08 :: Listener.AcceptCallback :: Connection failed during connection acceptance. More info: Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'.

will repo again, 2 secs
yup repoed, as soon as I mouse wheel over the map it crashes

10/01/2018 22:28:28 :: Listener.ReceiveCallback :: An error occurred. More info: An existing connection was forcibly closed by the remote host
10/01/2018 22:28:28 :: HandleClientDisconnected :: Unexpected error during read operation. More info: An existing connection was forcibly closed by the remote host
Last edited by FieryCosta; Jan 10 @ 2:29pm
fyi, I'm a dev, noticed the ath_debug=false, is there something I can help with this end?
configured it on a separate PC, a Surface Pro 4, and I'm afraid I also managed to repo it, but only once I pinched in/out then tried the zoom slider:

on second pc:

Faulting application name: Athena Desktop.exe, version: 0.0.0.0, time stamp: 0x5a06322e
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x03a1c5fc
Faulting process ID: 0x378c
Faulting application start time: 0x01d38a67fab45e15
Faulting application path: C:\Users\PedroCosta\Documents\Arma 3 Athena\Athena Desktop.exe
Faulting module path: unknown
Report ID: 137d47d3-b3bf-47ef-aa7b-0472229b3c9c
Faulting package full name:
Faulting package-relative application ID:

on relay.log on the Arma PC i got the same errors as before (repoed it a couple of times):
10/01/2018 22:48:54 :: HandleClientDisconnected :: Message received from client but disconnected before sending response
10/01/2018 23:08:38 :: Listener.ReceiveCallback :: An error occurred. More info: An existing connection was forcibly closed by the remote host
10/01/2018 23:08:38 :: HandleClientDisconnected :: Unexpected error during read operation. More info: An existing connection was forcibly closed by the remote host
10/01/2018 23:10:19 :: Listener.ReceiveCallback :: An error occurred. More info: An existing connection was forcibly closed by the remote host
10/01/2018 23:10:19 :: HandleClientDisconnected :: Unexpected error during read operation. More info: An existing connection was forcibly closed by the remote host

I think this discards it as GFX issue, let me know if you need anything else from me. happy to help :)
Last edited by FieryCosta; Jan 10 @ 3:15pm
bus  [developer] Jan 11 @ 5:15pm 
Just to update status on this issue: there's apparantly something in the East Wind: Refuel? mission that causes Athena to crash when the zoom level is changed. Will investigate after I wrap up the stuff I'm already working on.
Hey, i got an error here on Athena
I host a server on A3, go to Athena connect with address "localhost" and default port, it says "Connected, Authenticating" but doesn't get out of that stage, everything else is responsive so it's not frozen, any ideas?
bus  [developer] Jan 11 @ 8:01pm 
...authenticating? There's no authentication with the connection to the relay. I think you're trying to connect on the community tab? Click "Start" on the bottom.
< >
Showing 1-15 of 18 comments
Per page: 15 30 50