Stellaris

Stellaris

57 ratings
Otter Editor Expanded
4
   
Award
Favorite
Favorited
Unfavorite
File Size
Posted
3.768 MB
Jul 2 @ 1:44am
1 Change Note ( view )
You need DLC to use this item.

Subscribe to download
Otter Editor Expanded

Description
This is the Otter Editor, Expanded, based off of Seamoo's 3.0.* version of Otter Editor. Previous version is here: https://steamcommunity.com/sharedfiles/filedetails/?id=2327333737

The authors of the previous version, the orginal OTE, and those who worked on this one are listed above. We do plan to expand on this, but haven't decided on *what* function to add.

Thanks for playing your stellaris with this mod!


We think we've got it working, play and tell us!


"Required" DLC have features that are integrated into this mod, and will only work with the DLC installed.


Compatible with and integrates the features of:

Guilli's Planet Modifiers and Features:
https://steamcommunity.com/sharedfiles/filedetails/?id=865040033

Planetary Diversity:
https://steamcommunity.com/sharedfiles/filedetails/?id=819148835&searchtext=planetary+diversity

Archaeology Story Pack:
https://steamcommunity.com/sharedfiles/filedetails/?id=1993869579


Note: You *must* not be subscribed to PETLOL's version, otherwise it'll conflict.

Bug reports: Be as complete as possible, with *detailed* descriptions of what you are trying to do. While we can and will bug fix, we need to be able to replicate the problem.

We are also both on Stellaris' Modding Den Discord, under the same names we use here, therefore, you can reach us directly there.

[discord.gg]

To be clear: This (as well as it's non GPM/PD/ASP version, the original and awesome Otter Editor), does not modify start planets/start system choices, nor can you spawn individual Planets. The only ability to spawn is systems as a whole (which are random on planets), megastructures, special systems from the DLCS and ASP/PD, et al.


Lem Update: At this time, while the editor itself works for *owned* systems (I do not know about spawning, but I would not be surprised), the observer mode *DOES NOT WORK* We are aware, and until that code is fixed, do not use the clam.1 event to attempt to enter observer mode.
Popular Discussions View All (3)
10
Sep 22 @ 12:00am
Missing Features from Guilli's Planetary Modifiers and Planetary Diversity
Faulty AI
7
Sep 16 @ 2:15pm
What additional Features would you all like?
MageOhki
0
Jul 3 @ 11:59pm
General Bug Reports
MageOhki
< >
51 Comments
Seamoo  [author] 20 hours ago 
@cyber i looked into it alittle. They are spawn but because scopes are Fed they are spawning where ever. So, its the same issue as clam.1
Cyber Saint Omega 20 hours ago 
My Mod List is as follows

1. Dynamic Mod Menu
2. UI Overhaul Dynamic
3. UI Overhaul Dynamic - More Tradition Categories
4. UI Overhaul Dynamic - Ascension Slots
5. Bigger Planet View
6. 16 Building Slots
7. Expanded Starbases
8. Habitat Customizable Districts
9. Guilli's Planet Modifiers and Features
10.Expanded Diplomacy and Espionage
11. Deassimalated Machine Worlds
12. A Deadly Tempest
13. Rival Just Anyone - Pathetic/Overwhelming - FGRaptor
14. Machine Shipset
15. Known Precursor
16. Otter Editor Expanded 3.0

I did notice I could spawn the systems manually using

effect solar_system = { spawn_system = {min_distance = 10 max_distance = 30 initializer = basic_init_04 hyperlane=yes is_discovered=no } }

Not sure if that helps.
MageOhki  [author] Sep 21 @ 10:23am 
Also: I've been away from Stellaris for a bit, so, it will be a bit (trying to get mods *I* like back up and running...) before I can tear into what's wrong with the basic system spawning, that might be Seamoo code.
MageOhki  [author] Sep 21 @ 10:22am 
We will look into the basic systems not spawning, not sure what's going on there. If you have that issue, please post what other mods you are using. It's quite possible we're hitting a conflict we don't know about.
Seamoo  [author] Sep 21 @ 8:44am 
3.1 reworked the scopes system so the mod is touch and go
Cyber Saint Omega Sep 21 @ 7:29am 
Seems like the unique systems still work, but basic systems won't spawn from the galaxy editor.
Tubercle1801 Sep 21 @ 7:24am 
is the add system function broken? nothing happens when i tried adding systems to the game via the editor.
MageOhki  [author] Sep 15 @ 4:00am 
At this time, the errors are around the observer mode. DO NOT USE Observer mode
MageOhki  [author] Sep 15 @ 2:58am 
Yes, I and Seamoo are aware of the issue, am working on a fix. And how to upload it... *sssssssssigh*
MageOhki  [author] Sep 15 @ 2:31am 
Okay, it appears to be a 3.1.1 Lem issue, at this moment I'm not currently in Stellaris, so... give me a bit and I'll see what I can do.