The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

Mark Books as Read
< >
44 kommenttia
҉҈҉҈☼҈҉҈҉ 13.7.2017 kello 7.30 
it was working weeks ago but now it's not??????
Idolismo 18.4.2016 kello 10.26 
Grat mod! I have a question though - does it work with every book? I've ventured to the vampire castle and read a couple of books there and they didn't seem to be marked as "read" even after a couple of tries (Dawnguard DLC).
Essy 4.2.2016 kello 14.16 
doesn't seem to be working :C
BaconHotdog 28.7.2014 kello 5.32 
Someone please tell me how to get to that inventory screen?
Ipecac 15.12.2013 kello 10.40 
Mod seems to have no effect.
Daniël Fortesque 23.8.2013 kello 1.02 
I like the idea but there are mods out there that do this alot better.
Super Normal Man 17.6.2013 kello 20.39 
This mod does not work for me, for whatever reason.
RT_34 5.3.2013 kello 11.41 
Excellent mod, but for some reason it doesn't want to rename Kodlak's journal
Leo Star Dragon 1 16.2.2013 kello 14.06 
This wouldn't work for me either, so I had to uncheck it from the load-up files. Now my game works again.
Redferne 16.2.2013 kello 14.06 
I tried those files too. The problem is not to load the game after removing the mod. The problem is that you can't save after you loaded the game without the mod with a save that has the mod. There is no problem with a new game.
XJDHDR  [tekijä] 16.2.2013 kello 13.48 
Can you please visit the Skyrim Nexus mirror and try install the "Uninstaller files" to see if that stops the game from crashing?

I have had a few other people report this same problem but have had difficulty figuring out the cause. Part of the problem is that I can't reproduce the problem. I have this mod installed in my copy of the game yet I can uninstalling it then load up either of my two characters and then save without any problems.
Redferne 16.2.2013 kello 9.49 
Do not download. If you uninstall the mod, your game will crash everytime you try to save.
Leo Star Dragon 1 7.2.2013 kello 19.54 
Hi! There is a mod like this for "Oblivion" and I've been looking for it for "Skyrim", and I finally found it! Thank you very much!
!ce.Cream<3 6.1.2013 kello 9.17 
I wrote a comment there, but again: Thanks so much for translating it. :D
XJDHDR  [tekijä] 6.1.2013 kello 6.01 
I know. I collect books as well.

It is possible to make a German version and I have done so. You may find it here:
I did try translating the title as well. Is it correct?
!ce.Cream<3 29.12.2012 kello 19.53 
Nice mod - now I won't pick up books dozens of times anymore (am collecting them). :D Is it possible for you to add a german version of this? Just replace "(read)" with "(gelesen)" and "Book marked as read." with "Buch als gelesen markiert.". Since it's using SKSE I don't know how to replace this, but I'll try to find out if you don't want to. It's just easier to ask you, at first.^^
XJDHDR  [tekijä] 9.9.2012 kello 12.41 
Well, I never got a reply to my post on the Bethesda forums. I have thought of a possible way of preventing the bug which causes books to be renamed inappropriately. Can anyone who has experienced this bug please test version 1.0.2? No clean-save should be necessary but if you experience any problems, you can give it a try.
XJDHDR  [tekijä] 30.8.2012 kello 9.12 
Sorry for this late reply. I've asked for help on SKSE's Bethesda forum thread. Hopefully, we can get to the bottom of this strange bug:
RT_34 24.8.2012 kello 10.17 
Still doesn't seem to work... But anyway, thanks for the advice, and sorry for wasting your time
Neithan Diniem 23.8.2012 kello 16.23 
Load order was changed minimally before/after using this mod, but it was done through BOSS. SKSE was used at all times (launcher shortcut was modified to launch SKSE instead of Skyrim) and the game was not loaded without it except through NMM up to the point of the initial Skyrim launcher window (for editing resolution of the game).

Sorry for needing 3 posts, Aparently your restricted to 1000 characters.
Neithan Diniem 23.8.2012 kello 16.22 
When the bug was noticed, 3 of these non vanilla books, 2 vanilla books, and a spell tome lost their names. A variety of others including all of the nameless ones all had more than one ~(Read) tag. The name changes were baked into the save, so once they lost their names it was gone, even after the mod was deactivated. One of these books oddly gained a ~(Read) tag once read again, making me believe the mod was not remembering the names of the read books (or at least these books considering their names were now forgotten or something). Once the mod was removed new books with the same initial name as the multi-tagged books were NOT tagged with any ~(Read)s, and books were all named normally afterwards.
Neithan Diniem 23.8.2012 kello 16.22 
@XJDHDR It worked correctly on books that I just picked up, properly marking them and all. When the books were placed into a bookshelf however is when the problem started. When the cell was reloaded after a save/restart as well as some time afterwards, I returned to Breezehome to add books ot the shelf to find their names were replaced with 1 to 3 ~(Read) tags, and all books with more than one tag were missing their book name. I was annoyed by this, but then noticed it happen again with books in the inventory after another save/load latter on. Those books had been stored in a follower's inventory, as well.

The mods I was using at the time that might effect the books were:

Breezehome fully upgraded (workshop)
Better Item Sorting (workshop)
Unlimited Bookshelves (workshop)

As well as at the time 2 book mods that added a few dozen non-vanilla books to the game.
XJDHDR  [tekijä] 23.8.2012 kello 12.42 
I don't believe any new spell books would cause a problem. Try deactivate this mod in Skyrim's launcher, do a clean save then activate the mod again. I doubt it will work but worth a try I guess.
RT_34 23.8.2012 kello 2.09 
I'm afraid it is... Don't suppose it could conflict with the fact I used a mod that adds an extra spell book? Seems unlikely, but this is the only mod I have that could feasibly conflict with this
XJDHDR  [tekijä] 22.8.2012 kello 20.45 
Finally, check that the ESP is activated in Skyrim's launcher. If it is, I have no idea what else it could be.
RT_34 22.8.2012 kello 13.09 
Yep, they're in there
XJDHDR  [tekijä] 22.8.2012 kello 12.40 
Open Skyrim's Data folder and check that there are two files there named "Mark Books as Read.esp" and "Mark Books as Read.bsa".
RT_34 22.8.2012 kello 3.06 
Yes, I run it fairly regularly to make sure that my various mods are up to date
XJDHDR  [tekijä] 21.8.2012 kello 22.16 
No, that's the way you run the game with this mod installed. Have you run the Skyrim launcher since subscribing to this mod? The Skyrim launcher is run by either clicking on the "Play" button in your Steam library or double-clicking on TESV.exe or SkyrimLauncer.exe.
RT_34 21.8.2012 kello 12.24 
Through a desktop shortcut to the SKSE loader, otherwise SkyUI says SKSE doesn't work properly. Would that cause a problem?
XJDHDR  [tekijä] 21.8.2012 kello 9.54 
How are you starting the game?
RT_34 21.8.2012 kello 9.45 
Have skse installed, and SkyUI is working properly, but this mod doesn't seem to be doing anything for me at all, despite going in and out of my inventory, and reading books lying around. Any advice?
XJDHDR  [tekijä] 19.8.2012 kello 22.22 
@Neithan Diniem
NVM, I can't send messages to non-friends. Anyway, what I suspect is that there is a bug in SKSE's SetName command that is causing it to modify the books' names in an incorrect manner. Here's the script I use:
String BookName = akBaseObject.GetName()
If Substring(BookName, 0, 7) != "~(Read)"
akBaseObject.SetName("~(Read) "+BookName)
As you can see, there is nothing there which commands the game to delete the book's name and replace it with "~(Read)"s.

I'm going to send a message to the people maintaining SKSE but I would appreciate some additional info:
1 - Does this bug happen with books you have just read, books which you read previously after loading a game or both?
2 - Does this bug affect specific books or is it a random book each time?
XJDHDR  [tekijä] 19.8.2012 kello 21.44 
@Neithan Diniem
Your first report wouldn't make any sense if you didn't have SKSE installed. My previous comment was directed at those who were complaining about my mod not doing anything at all. As for the rest of your report, I'm sending a message to you.

As for the second report, it's not my mod that has problems. If NMM is trying to enforce the installation/loading/whatever of mods that have been removed through official interfaces, then there is clearly a bug in the NMM and you need to report this to the maintainers. You can do so here:
Neithan Diniem 18.8.2012 kello 19.44 
An additional problem I had was when I tried to remove this mod.I've had this mod unchecked for a while, and Use BOSS for sorting. I deleted and unsubbed from the mod, however after that I could no longer add mods using NMM. an Error popped up about a BOSS log missing pertaining to Mark Books as Read, and wouldnt allow the mod to be installed. Required me readding the file to fix. This mod needs a proper uninstalation instruction.
Neithan Diniem 14.8.2012 kello 18.23 
Having same problems as the guys below, books with names erased and replaced with ~(read), ~(read) ~(read), even two as ~(read) ~(read) ~(read). I have the latest skse installed and running, SkyUI is properly going so I know its working. This is NOT related to not having skse installed/working. I had unlimited bookshelves (removed it thinking it was the problem, it wasn't), which increases the number of books/items allowed onto a bookshelf, as well as "Breezehome Fully Upgradeable," available on the workshop. Using Better Sorting, so all vanilla books have their names edited, however that doesn't require skse to operate. Seems somethings gone wrong somewhere in your mod.
XJDHDR  [tekijä] 1.8.2012 kello 12.46 
Again, do all of you have Skyrim Script Extender installed? This mod will not work at all if you haven't got it installed.
AntiHuman 1.8.2012 kello 9.06 
Same here
Just installed. Restarted game. Allowed all of my mods to check for updates. Checked some books that I have found where I know I have read some but not all and there is no ~read against any of them including after I re-read sme
Spade 31.7.2012 kello 15.27 
doesn't work for me either
XJDHDR  [tekijä] 28.7.2012 kello 10.11 
Sorry but I won't do that. One of the features of this mod is to sort read books to the bottom of your inventory screen. If I remove the ~, that would no longer be possible. If you would prefer a different character that preserves this feature, I can do that instead.

Did you install Skyrim Script Extender? This mod won't work if you don't have it.

@Rusty Gunns
I'll see what I can do. If I do manage to implement that, it will be a seperate mod though. It won't become a feature in this one.
Matt 27.7.2012 kello 19.17 
Simple idea, but greatly needed in Skyrim.
HanaNoKimi 27.7.2012 kello 7.55 
I don't know why, but it doesn't work :(
lLeyfon 26.7.2012 kello 13.34 
Could you remove the "~"?
wt⑨ 25.7.2012 kello 8.08 
It could be helpful. Thanks.