The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

173 valoraciones
Fixing the Bound Sword Crash
Por Big Hoshiguma
Does the game crash when you cast Bound Sword? If so, look here for a quick, easy, and tested fix for the crash.

Thanks to the Skyrim players on the Skyrim Forum for finding and posting the fix for this.

Also thanks to the Skyrim Wiki for the Bound Sword image.

4-16-2013 Updated how to get Item IDs for quest items to make it simpler.

12-4-2014 Edited the guides grammar and step names for a more professional and easy to understand guide.
3
   
Premio
Favoritos
Favorito
Quitar
The Problem
Hello and thank you Steam User for viewing my guide, whether you have this issue yourself, or are just merely curious to see what it is. This fix will only require very minor console usage and should take no more than 5 minutes. You'll also wind up with a free full set of iron armor afterwards.

This glitch mostly occurs when you download a Workshop item from the Steam Workshop, then delete or unsubscribe the item from Skyrim. However, this does not actually 100% remove the item from your inventory or the game, and leaves a invisible item in your bags. It took a little bit of searching, but I found the fix on the Skyrim Forums.

I have a hypothesis for how these Workshop Items affect the spell, which you can read at the bottom of the guide.
Store Everything
The steps to fix the bug are quite simple, and should only require some minor console usage. In the end you will also wind up with a full set of iron armor, do with it as you will.

  • Go to your home, or wherever a chest/container may be. (Your home is still the better option for safety)
  • SAVE YOUR GAME
  • Deposit all items you have into your container.

Your inventory should be bare of items, quest items excluded. You can find the item ID's of them by typing "player.showinventory" into console which is required to continue. (I'll provide the IDs for the 2 I had in the next section)
Getting Quest Items Back
For all of the quest items you have, you need to make a copy of them before you move on, otherwise they will be lost.

Open up your console (the ` key) and type "Player.Drop ItemID #" then press ENTER. (The # being the number of said item you need.)

To see the ID for your quest items type into the console player.showinventory

In example, since this will be a VERY common item for players to have, I had acquired 3 of the Unusal Gems (Stones of Barenziah), so I typed "player.drop 9dfbb 3"

Then I had a Meridia's Beacon, so I typed "player.drop 0004e4e6 1" and pressed ENTER.

Use the console command stated earlier in the guide to get all quest items and ensure that all your quest items are now on the floor. But do not pick them up yet.
Fixing your Game
Having completed the previous steps correctly, all of your inventory should now be in a chest, and all quest items should be on the floor in front of you.


The last step now is to type "player.resetinventory" into console.

You're inventory has now been completely cleared of all items glitched and otherwise, and has been replaced by a "Starter" set. You should have a full set of iron armor and a few potions now. You can do with this what you will, the only thing you have to do is pick up your quest items off the floor and remove your items from the chest.

All of your spells, spent perks, unspent perk points, experience and levels will remain untouched.

Now equip the "Bound Sword" spell and cast it and it should work as intended without crashing the game.

Questions, Problems, Feedback
If everything went as intended you should be able to continue the game and use the bound sword spell as it was meant to be, without the game CTD'ing (Crashing To Desktop).

If you encounter any problems/glitches/or have any questions, please leave a comment below. I appreciate them greatly.

Thank you and enjoy!

What I believe occurs when you delete a item from the workshop is that the item will be "removed" from your inventory by becoming weightless and invisible, unable to be seen by you. When you cast the bound sword spell, the game creates/uses a weightless/invisible item in your inventory to be used in your hand. Instead of the game loading the correct Bound Sword item into your hand, the game tries to load a item that no longer has a proper model or behavior, crashing the game.
< >
120 comentarios
『RasDingo』 4 OCT a las 10:01 
Helped, Much love :)
Lofgren 13 SEP a las 11:18 
Near as I can tell, there is no need to remove everything from your inventory. Player.ResetInventory, ditch the extra set of iron armor, and move on. All of my quest items and equipment appear to still be there.
Omnical 19 AGO a las 16:54 
does entering a cave while casting bound sword cause this as well?
Kraut Trout 30 JUL a las 14:07 
A++ Worked perfectly! Well-written instructions!
AustralMike 30 JUN a las 13:01 
Thank you! :cozybethesda:
TyraelElDruin 26 JUN a las 4:34 
I did not have to do any steps besides player.resetinventory. Seems to have worked! Thanks!
Vladislavislun 23 JUN a las 11:25 
I love you, man!
Easy_Flow 5 JUN a las 13:32 
i still get the crash, under by favorite weapons i can select it as righthand weapon its all okay, after i draw my weapon on go again on my favorite weapons and select it again as righthand weapon it crashes without any errors and places me to my deskop. pls help
-LPW- Jak1900 28 ABR a las 5:28 
Thanks a lot. Fixed my game :)
Bloodfistdeathpunch 18 ABR a las 11:23 
THANK YOU!!!!!!!!!! Works in SE with heavy modded game. This post needs stickyed in the SE guides! This is such a great post. It saved my 200+ hour play through. Thank you sooooo much!!!!