Left 4 Dead 2
Оценок: 118
How to fix the annoying "Model not precached" CTD bug
От Pheabus2K9
Recently I returned to L4D2 to play with friends who just got the game during Christmas giveaway, it is still a nice experience, abeit some newly found bugs, like the "Model not precached" CTD errors while hosting local server on L4D1 maps, however I've figured how to fix them, here it is:

The Bug
If you've installed certain addons (either via Steam workshop or downloaded from web), when you host a local server on L4D1 maps (namely: The Sacrifice, Dead Air, etc), after a new level is loaded (usually the 2nd level), your game will crash to desktop with the error message "... UTIL_SetModel: not precached: model/xxx..."(the xxx can be a survivor model or infected model, it doesn't matter)poping up, and all players in your server will be disconnected or told "lost connection".

The Cause
According to discussions on l4dmaps.com, some mods (e.g. a custom campaign or a custom model) use an older .txt list of files to be precached, but since the game has updated, the list is no longer the same, if you load the game with the said mods, some models might not be precached, thus the error message pops up. This is especially prevalent on L4D1 maps ported to L4D2, where the game uses a separate file list.

The Fix
1. If you have encountered this error, make sure to verify your game cache first (right click on L4D2--properties--local files--verify integrity of game cache), it may not be necessary, but can resolve other problems this guide cannot fix.

2. If you have less than 5 addons installed, you may better try disabling them (untick the box before the addon name in game menu) and enabling them one by one, in this way you can find out which mod has caused the problem, then you can nicely inform the mod's author that his/her mod needs updating.

3. If you have installed more than 10 addons (like myself with 20+skins and 10+ campaigns), the above No.2 solution should be a headache. Don't worry, you just need simply put the following text " +precache_all_survivors 1"(without the quotes) in your game lauch options (properties--set launch options), you can use this together with other launch options, like this: "-heapsize 1572864 -nojoy -high +precache_all_survivors 1".
Alternatively, you may add the line "precache_all_survivors 1"(without the "+") to your autoexec.cfg (loacted in \Steam\steamapps\common\left 4 dead 2\left4dead2\cfg), it has the same effect as launch options.

Et voilà! The errors are gone, you can now host local server on all maps without the annoying CTD. Have fun with the game and happy 2014:D
 
Оценить  
В избранное
В избранном
Удалить
< >
Комментариев: 65
PopTheseFools 29 мая в 22:37 
whats the name of this file with precached models?
Dethlord91 12 мар в 19:16 
Tried this, i have 0 mods and get - 405/ - infected: UTIL_SetModel: not precached: models/infected/common_femal_tshirt_skirt.mdl
Hakenlien 19 авг. 2018 в 11:22 
thank you so much c:
2FA_jj 28 июн. 2018 в 19:52 
If you're reading this in the summer of 2018, somewhere in between removing Nacht, adding the launch option from this guide, and being sure to enable the consol to where I type in "sv_consistency 0" got some of this working. Now I can actually host Yama myself and not be on some dumb whacky 3rd party server where there's zero gravity and pink all over my screen.
Yuu ユー 28 мая. 2018 в 17:45 
I did the command but it still didn't work
Hartz4Life 3 мая. 2018 в 7:02 
Maybe someone can help me. I subscribed the "Infected Population Mix" mod. Everything worked just fine. When I desubscribed, (because it annoyed me that the L4D1 skins doesn`t have the L4D2 gore) the game crashed every time. I tried out disabling other mods, that could lead to the Problem (still everything worked as they had been active with "infected population mix") but nothing helped. Until i subscribed again to the "IPM" mod. I tried out the local save thing too, but it didn`t work. Seems like the game wants to run files I have deleted by unsubscribing and I think deinstalling all mods and the whole game would fix it. But maybe someone has a better opinion for me? :D Pls? Anybody?
LancerBlitzFTW 10 апр. 2018 в 1:34 
Thanks, it seems Nacht Der Untoten v2, is the problem. Thanks Pheabus, and others who had the same issue!
❄ℱℛօՏƬㄚ❄ 27 мар. 2018 в 19:25 
Sweet! I just had to disable the Nacht Der Untoten v2 addon
Horde 18 мар. 2018 в 16:41 
Unfortunately using this: -novid -heapsize 1572864 -nojoy -high +precache_all_survivors 1 .. it only happens less. The error still happens.
UFO 29 янв. 2018 в 20:08 
good job ty