Age of Empires II: HD Edition

Age of Empires II: HD Edition

57 évaluations
How to play AoE2HD on Mac 10.11 El Capitan
Par DoctorWillCU et 1 collaborateur(s)
This show you my way to install AoE2HD on Mac OS X El Capitan 10.11, also work in 10.6.8 Snow Leopard.
 
Évaluer  
Favori
Favoris
Non-favori
Prologue and Credit
Updated on 2017-04-23

I would thanks to sudo from the guide in following link,
https://steamcommunity.com/sharedfiles/filedetails/?id=247537337
sudo is the first one to written steam guide which bring the way play on mac by using Wine Wrapper in Steam community, this is no doubt and can be find out easily on internet.
I use sudo method AOE2HD in my mac since 2013 until its broken due to AOE2HD Patch 4.0, a big changed of patch.

This is how this guide be created while I figure out using PlayOnMac.
Unfortunately my 6-year-mac was dead in 2016. I can't update this guide anymore.

If anyone would be interest to update this guide, continue in fixiing in latest MacOS. Feel free to take any information and pictures from this post. Giving credit to me and TeslaStormX is optional. I would suggest you to give credit to sudo who the one first bring method in steam community.
Video Tutorial by TeslaStormX
Download PlayOnMac & Steam(Windows)
http://store.steampowered.com/about/
Download Steam.exe Windows Version by click Windows.

https://www.playonmac.com/en/
Download PlayOnMac which can run Steam games and other Windows Applications.
Install PlayOnMac and Wine



Install Steam (Windows Version)
Install AoE2HD and Fix Launcher
Optional 1: Change "Quit Wine"
Optional 2: Make new shortcut
Optional 3: SmoothMouse
Optional 4: Fix Text not showing up
Optional 5: Fix Video Memory Size
Optional 6: Fix Windows Version
< >
333 commentaires
malik algerian héros 9 juin à 21h13 
and for aoe 3
KleinerBrandy 16 mai à 3h15 
Anyone else having issues with joining a game lobby? I am using Wine 2.12+Win7 settings.

When I try joining a game lobby I am stuck in the joining screen (... "press ESC if you don't join after 15 seconds"). I can perfectly refresh and see the list of games.

Any hints appreciated.
spudybudy 3 févr. à 4h52 
Got to have it working! My problem was: 'No games matching those parameters' in the lobby. I found the solution here:

http://steamcommunity.com/app/221380/discussions/2/558746017943121343/

and here

https://gaming.stackexchange.com/questions/127901/is-there-a-way-to-manually-update-a-game

It's working now!
spudybudy 3 févr. à 3h18 
I can play single player against the computer but can't play on multiplayer mode. I basically can't see anybody on the multiplayer lobby... I can create a game and am the only player playing in that game. Anybody has had the same problem and know how to fix this? I'd really like to play agains other human players!
angelojosephablog 24 janv. à 18h48 
For any updates for the game, I completely uninstall Steam and reinstall everything
TiOwnoLaNonna 24 janv. à 16h46 
i'd installed aoe on mac with this guide and was perfect, could play with friends online without any problem; now with new patch my friends have 5.7 and my game still 5.6... i tried autoinstall the patch but it doesn't work, i tried also to fix integrity of files and i'd to rename the launcher as wrote at the end for this guide but... it doens't work... any tips for fix it?
angelojosephablog 19 janv. à 19h27 
Does anyone have the issue where multiplayer works but every other game? I'll get into a game and then it Steam Crashes, but it only happens every other game
angelojosephablog 14 janv. à 16h18 
anyone having the "validating subscriptions" screen going on for long periods of time? I'm at 6 min
Madtroli 12 janv. à 11h52 
i use 2.22 wine
Madtroli 12 janv. à 9h31 
Hi, although AOE II HD launches fine and i can play multiplayer. I am having a latency issue where every game i play i usually end up having the turtle icon next to my score or having 200 more ping that people playing with me on the same room (he plays with windows). Has anyone had this problem and/or knows how to solve it?

Thx in advance