RimWorld

RimWorld

358 ratings
Argonians of Blackmarsh
   
Award
Favorite
Favorited
Unfavorite
Mod, 1.0
File Size
Posted
Updated
2.343 MB
Jun 29, 2017 @ 10:31pm
Oct 20, 2018 @ 7:58pm
8 Change Notes ( view )

Subscribe to download
Argonians of Blackmarsh

Description
Argonians (in their native tongue of Jel they call themselves the Saxhleel, or People of the Root) are the reptilian natives of Black Marsh, a vast swampland province in southeastern Tamriel. The other races often prefer to refer to them as 'lizards' or the 'Lizard Folk' instead, especially when meaning to be derogative. They are known as the foremost experts in guerrilla warfare throughout the Starry Heart, a reputation brought upon them by defending their borders from enemies for countless centuries.


NOTE!!

Needs Alien Framework by Erdelf!
https://steamcommunity.com/workshop/filedetails/?id=839005762


-----------------------------------
Support your modders! Become a patron!
https://www.patreon.com/EmpireXen
Popular Discussions View All (4)
2
Oct 29, 2019 @ 6:39am
Missing heads
liebana
1
Jan 27, 2019 @ 6:19pm
Please update and add Rah's Bionics compatibility!
NationalAlien
1
Nov 20, 2018 @ 9:54am
FOR THOSE, WHO DON'T LIKE THE INCREASED MINING SPEED
Moltozar
< >
222 Comments
Xen  [author] Mar 9 @ 4:48pm 
Check my workshop for 1.1 versions - keeping them separate for the moment due to some steam issues.

I'll provide links in the descriptions later - for now just hit my workshop link at the top above the mod title.
ratboys Mar 8 @ 4:21pm 
Is this ever going to be updated by the original creator? The patch still contains XML errors
Bob Mar 4 @ 2:52pm 
Squeek CheeseTaker Mar 1 @ 9:43pm 
I don't know if it was just me, but for some reason whenever I started a game as this faction, I was unable to make any of the tribal headresses or war masks, or any of the tribal headgear basically. If that's a bug with the mod, can that be fixed for the 1.1 release?
Eualien Mar 1 @ 5:03am 
Great!
Bosh Feb 26 @ 2:53am 
Noice
Xen  [author] Feb 26 @ 2:52am 
Yeah, I'm in the process of getting all my mods updated to 1.1
I'll have everything published in the next few days
Bosh Feb 26 @ 2:37am 
1.1?
Galengar Feb 25 @ 1:37am 
I just installed this mod and I was really wanting to use it, but then the newest mini updates came out and I'm afraid it'll break my game - hopefully you can jump back on this with a new update for us all!
Kyyndle Feb 24 @ 6:39pm 
+1 for an update. Can't live without this mod. <3