Not enough ratings
Change Research Speed - A17
File Size
0.115 MB
May 25, 2017 @ 11:51pm
Nov 15, 2017 @ 3:14pm
12 Change Notes ( view )

Subscribe to download
Change Research Speed - A17

A18 version: http://steamcommunity.com/sharedfiles/filedetails/?id=1182992587

Change the speed of research both globally and per-save whenever you want.

In Mod Settings a new tab will be available, Modify Research Time with a single field input fields.
-Global Factor - The value all research times will be multiplied for New Games (this will override scenario research muiltipliers)[/li]
-Current Game Factor - The value all research times will be multiplied for the Current Game (if no game is going these fields will be hidden)

Press Apply in either case to make the change.

A Factor of:
1 means the research times will be the same as the base game.
5 means research will take five times longer to complete
0.1 means research will take a tenth of the time to complete

This does not require a new game. Old saves can have their research speeds modified.

Ludeon Studios Mod Post: https://ludeon.com/forums/index.php?topic=32854

GitHub for this mod: https://github.com/KiameV/rimworld-modifyresearchtime/releases

Direct Download: https://github.com/KiameV/rimworld-modifyresearchtime/releases/download/20170528/ChangeResearchTime.zip

Like my mods? Consider supporting me!
< >
Kiame Vivacity  [author] Nov 14, 2017 @ 12:07am 
I made one last adjustment to which will allow finished research to remain finished. There were some cases where modifying the factor in the middle of a game could cause problems.

The first time loading a save (saved using the previous version/s and loaded with the newest) there will be an error in the logs which can be ignored.

Thanks again for having patient with me!
Kiame Vivacity  [author] Nov 13, 2017 @ 9:46pm 
I just fixed a problem I introduced with the last update. There is a chance when loading a save with the previous version of the mod where previous research is no longer finished. If you run into this problem please enable debug mod (from the settings page) and in the research window, click on the research that should be done and select "Debug Insta-Finish".

Again I am really sorry for any trouble this causes!
Scheigy Nov 12, 2017 @ 11:54pm 
Indeed, fixed! Thanks, that was quick.
I hope the coffee tastes good!
Kiame Vivacity  [author] Nov 12, 2017 @ 1:42pm 
Kiame Vivacity  [author] Nov 12, 2017 @ 12:45pm 
Thank you for the extra work. Yes i see it now. I'll look into it
Scheigy Nov 12, 2017 @ 11:19am 
Picture here: https://i.imgur.com/WcHCtSq.png

After a few tests, I think I got how the bug appears and why you didn't catch it. You need to start two new games without quitting the game and then the researchs points of researchs that should be finished will be divided by the global factor.

I tried with 0.1 and indeed the electricity research was 10% complete, same goes for 0.5 => 50%.

Probably the function where you apply your patch isn't the correct one. I didn't had time to look through your code though.
Kiame Vivacity  [author] Nov 12, 2017 @ 11:00am 
Not sure i follow. I've tested this with tribal and crash landing starts and the starting research is correctly done from the beginning.

Are you saying that this is not how yours worked? ie Crash landing and you had no research done? If so there's more than likely a mod conflict somewhere...

I went ahead and ran the test I think you're describing to make sure it is working. I set the Global factor to 0.5. I started a new game w/ the crash landing/classic scenario. All starting research which should be finished are:

Scheigy Nov 12, 2017 @ 3:05am 
Unfortunately it messes with all the research you should have after the start of the game.

I started a new classic scenario and researchs like Electricity and such were completed only at half (I started with a 0.5 research speed modifier). You should check if you can get what research comes with the scenario and if so finish them accordingly.
Cells Nov 4, 2017 @ 11:24am 
idiot noobs dont cry kiame xd
Kiame Vivacity  [author] Jun 27, 2017 @ 10:13am 
how odd... I'll see if can reproduce that. Thanks for the information