Project Zomboid

Project Zomboid

91 ratings
Craft helper Mod (v1.1.2) for PZ 36.4
 
Rate  
Favorite
Favorited
Unfavorite
Mod: Mod
File Size
Posted
Updated
0.168 MB
Apr 22, 2017 @ 9:08pm
Nov 4, 2018 @ 1:36pm
3 Change Notes ( view )

Subscribe to download
Craft helper Mod (v1.1.2) for PZ 36.4

Subscribed
Unsubscribe
Description
This is Peanut's Craft helper Mod (v1.1.2): http://pz-mods.net/professions/CraftHelperMod112/
Updated to work with PZ 36.4.

This mod will primarily add a "Craft Helper" context menu item when right-clicking on any item in your inventory or a container.
Selecting that will bring up a dialogue of every recipe that that item is part of. Selecting a recipe will show the recipe components and what
is already obtained by the player ('+' signs) and what needs to be obtained ('-' signs), as well as quantities.
I prefer this to the default crafting windows. This mod also had a crafting book icon that goes on the GUI, that is similar to the default
crafting window, which I removed, since it so slow when using mods like Hydrocraft. Rename recipesBook.lua.bak to recipesBook.lua to enable it.
Omegpl has developed enhancements to CrafterHelper up to v1.5g, that I was not aware of when I developed this. Those worked up to build 32.4.: https://theindiestone.com/forums/index.php?/topic/9267-craft-helper-12/
There were extensive code changes to get this to work in 36.4, due to changes in how the game now relates items with recipes.
All credit to Peanut.

Workshop ID: 911399676
Mod ID: CraftHelper
< >
64 Comments
ddraigcymraeg  [author] Mar 16 @ 6:58am 
C:\Program Files (x86)\Steam\steamapps\workshop\content\108600\911399676\mods
Boruba gro-Ramak Mar 15 @ 6:57am 
what is the directory of recipesBook.lua.bak exactly? (I can think of a few reasons to want to have both)
Igams Feb 25 @ 5:30pm 
@Shadow Wolf
Actually the same thing has always happened to me as well with the mod.

It's a bit of a pain but it looks like the only way to avoid it is to always remember to close the recipe before closing the Craft Helper menu. If you don't the recipe gets stuck there permanently with no way to close it. Opening a new craft helper window doesn't close the first stuck one either so it looks like the only way to get rid of it is by reloading.

Out of curiosity do you play with a controller? I do and my first guess was that this is some kind of issue with the controller interface since the menu system is quite a bit different from the keyboard interface.
Igams Feb 25 @ 4:10am 
Alright I'll do that. Thanks!
ddraigcymraeg  [author] Feb 24 @ 8:48pm 
it should be all client side... but to be safe enable it on the server. I'm not 100% sure... I ported this for a newer version of PZ and cannot remember.
Igams Feb 24 @ 12:46pm 
Awesome mod thanks! Just wondering but is this client side? Can I use it on a server that doesn't have it?
ddraigcymraeg  [author] Feb 18 @ 11:05pm 
you can re-release as a translated version sure thing.
Shadow Wolf Dec 18, 2018 @ 3:41pm 
Just a clarification > Crafting helper windows is where show all recipes the item can be used , the recipe window is when you check a recipe puting mouse in front of the recipe, when puting the mouse outside the recipe window it closes auto.

The problem is, when the recipe is oppen, he overlays the crafting helper window including the [x] button to close the window, when you close the crafting helper with the recipe open > the bug happens, the crafting helper window closes but the recipe window stay open forever, even when i take the mouse of of the window.



Sorry for my bad english.
Shadow Wolf Dec 18, 2018 @ 3:37pm 
Yes, happens on SP too, my friend have the same error too, same reproduce.
Shadow Wolf Dec 18, 2018 @ 3:36pm 
Only fix when closing the game, no error messages, i found how to reproduce the error: Use crafting helper on some item > put mouse in front of some recipe to show the item he makes > close the windows from craftwing helper without taking out your mouse cursor from the recipe window. 100% chance to bug the recipe window and stay there forever, need to exit and enter game again (game i mean session, not the actual .exe program)