Paladins

Paladins

48 ratings
Ways to fix Hi-Rez Studio games errors
By Skull Ð. ★
   
Award
Favorite
Favorited
Unfavorite
1.- Uninstall & Install Hi-Rez Diagnostics and Support tool
  • Go to\Steam\steamapps\common\Paladins\Binaries\Redist and click on InstallHirezService.exe
  • Execute it and when it says "Remove all the files" click on Ok/Yes
  • When it is done, click again on it and do a normal installation
  • Take a look and see if it is fixed
2.- Fixing using Hi-Rez diagnosticate
  • In the launcher, click the gear shift in the bottom left of the login window.
  • Click "Troubleshoot"
  • Next, click "Restart Service."
  • Relaunch the game
3.- Downloading the Repair Tool
  • Go to this link -> Repair Tool[cds.q6u4m8x5.hwcdn.net]
  • Once it is downloaded, execute it and let it work
  • Relaunch the Hi-Rez game and check if it's fixed
4.- Uninstall & Install the game [HIGHLY RECOMMENDED]
If any of the previous ways didn't work, uninstall the game and delete any files that have been undeleted.

After that, install the game again.
5.- Error featuring missing MSVCP.DLL
This can be used aswell for any of the other Hi-Rez Studios games, instructions extracted from here[hirezstudios.force.com].

Go into your Smite install folder and navigate to the REDIST folder.

Standalone Launcher: ...\Program Files (x86)\Hi Rez Studios\HiRezGames\Smite\Binaries\Redist Steam: ...\Program Files (x86)\Steam\steamapps\common\SMITE\Binaries\Redist

Run 'UE3Redist_vs2012.exe' from this folder.

If this does not work, follow the instructions below to uninstall and reinstall your Microsoft Visual C software.
Thank you to NoXiouS for finding the solution
< >
25 Comments
ErikNoXiouS Nov 14, 2017 @ 1:29pm 
Thank you
ErikNoXiouS Nov 14, 2017 @ 10:35am 
Can you add my actual account?? This is my dad's.
Its :

/noxiousofficial
Skull Ð. ★  [author] Nov 13, 2017 @ 11:04am 
Thank you! Going to add it right now
ErikNoXiouS Nov 13, 2017 @ 10:23am 
fixed, reinstalling C++ visuals libraries
Skull Ð. ★  [author] Nov 11, 2017 @ 4:35am 
Just uninstall PunkBuster if you're afraid of getting banned, I don't know.
ErikNoXiouS Nov 11, 2017 @ 4:23am 
no hacks. i dunno what to do. missing MSVCP.DLL, tried everything, nothing works from your guide
Skull Ð. ★  [author] Nov 11, 2017 @ 4:21am 
If you're planning to hack, I cannot help you.
ErikNoXiouS Nov 11, 2017 @ 4:20am 
Hum....

I've done some cracking and .DLL fixing ez cracked games and even nowadays games or apps that wouldnt start asking for .DLL

But this is paladins and MSVCP.DLL is missing and wont let me play. wtf should i do without risking getting banned by punkbuster?
‡ ‡ I B U ‡ ‡ Mar 19, 2017 @ 11:13am 
Just unplug and plug the router. It worked to me :)