The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

Not enough ratings
The Juggernaut Weapon
File Size
0.002 MB
Jul 25, 2012 @ 1:50am
1 Change Note ( view )

Subscribe to download
The Juggernaut Weapon

Have you ever wanted to just send your targets flying with one hit? Wanted to shake the ground with a swing of your weapon? Or just wanted revenge on those moon launching Giants? Well now you can!

The Juggernaut is a powerful weapon that can knock your targets back when hit, even so much as sending them to the moon when they are hit on the ground.

The weapon is located within a respawning chest in Dragon's Reach just near the bottom of the stairs. The weapon can also be disenchanted to use its enchantment elsewhere.
< >
Baboom1 Mar 11, 2016 @ 5:17pm 
this is kind of weak (in damage)
megaCreep Jul 31, 2015 @ 6:07am 
just 24 damage points !??! i have an epic dagger with 90 points damage. i've kill two dragons with my one-hand weapon.when they come on the ground,i hit them with the dagger and burns them :bryhild::steamhappy:u can see my Skyrim screenshots :steammocking::heart:
sock Jul 29, 2015 @ 12:42pm 
but its still an overlap
sock Jul 29, 2015 @ 12:42pm 
Its not a greatsword overlap, its a bound sword, which is a conjuration spell that makes a purple daedric sword (one handed not two handed), it doesnt do as much damage as a daedric sword tho
harry pote Jul 11, 2015 @ 4:17pm 
and also a request but whatever u want to do, can you remove the greatsword overlap? it kinda takes away from the badass feel for me
harry pote Jul 11, 2015 @ 4:16pm 
okay everybody @ednug @christopher @TheNoobThatWas what happened for me cuz i couldnt download it was that in the "Data Files" option of the starting screen the mod was unchecked. Check it, and it worked for me
harry pote Jul 4, 2015 @ 7:50am 
cant find it and ive tried everything
EdNug Aug 5, 2012 @ 10:09am 
Cant Find it without DawnGaurd too.
shit, bish | Aug 3, 2012 @ 5:28am 
Either it doesn't work with Dawnguard DLC but the chest is not there.
TheGhostThatWas Jul 31, 2012 @ 11:13am 
Wont let me download