Stellaris

Stellaris

47 ratings
Sins of the Prophets: RS Legacy Compatibility Patch
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
3.406 MB
Jan 13, 2017 @ 1:32pm
Dec 7, 2017 @ 6:07pm
9 Change Notes ( view )

Subscribe to download
Sins of the Prophets: RS Legacy Compatibility Patch

Subscribed
Unsubscribe
Description
Sins of the Prophets: RS Compatibility Patch v0.1.1

Compatible with 1.8.*, 1.9.*. Legacy build of RS only!

Come join our Discord: https://discord.gg/9durxEz

Building off of our main Sins of the Prophets: Stellaris mod, we are pleased to present this compatibility patch for use with Realistic Ships.

Currently, only the UNSC has been converted and works entirely with RS; there are no plans to add in support for the Covenant at this time.

UNSC model changes:
Cruiser: Halcyon
Support Cruiser: Artemis
Electronic Warfare Cruiser: Zeus
Battlecruiser: Marathon
Dreadnought: Punic
Heavy Dreadnought: Infinity

Do not redistribute without permission.
< >
41 Comments
Lavo  [author] Jul 10 @ 2:10pm 
I am pleased to announce that our new RS compatibility patch is now live, huge thanks goes out to Tal for helping us with one bit: https://steamcommunity.com/sharedfiles/filedetails/?id=1437630372
Porter Jul 10 @ 12:03pm 
thank you !
Lavo  [author] Jul 9 @ 7:14pm 
Hi there, I am pleased to announce that we will soon re-enabled full support for Realistic Ships; I am currently working on updating this patch. Stay tuned!
Hayate121 Apr 26 @ 3:46pm 
the battle cruisers thrust doesnt work
Hayate121 Apr 26 @ 2:28pm 
will this work with the downscaled ships mod?
Zeratul Vergil Mar 20 @ 6:55pm 
@Lavo @Unikraken
hi, i know it sounds funny, but can you let me handle the SIns of the Prophet RS patch?
Occidere Feb 16 @ 5:44pm 
it isnt changing my loading screen or title screen, neither does it change the voice lines.
Lavo  [author] Feb 5 @ 5:41pm 
We do not support RS any more; that compatibility patch is provided on an "as is" basis due to difficulty working with RS. Further, we do not plan to do a Downscaled Ships version of the mod at this time due to the amount of compatibility patches we have done and also now due to how certain ship exhausts have been made.
xnadu27 Feb 5 @ 3:26pm 
This needs a Downscaled Ships patch. I have talked with Tal’ Aranh and he said that the problem of UNSC RS ships not being downlscaled was a problem with this mod. I can create a patch to fix this if you allow me.
Ashura Jan 24 @ 12:32pm 
thats a damn shame, i really love those ship designs.