The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

649 ratings
Bromjunaar Extended
File Size
0.123 MB
Feb 8, 2012 @ 9:51am
Feb 18, 2012 @ 12:44am
21 Change Notes ( view )

Subscribe to download
Bromjunaar Extended

The reward for collecting all 8 Dragon Priest Masks is somewhat a letdown, so I decided to create this mod, which increases the reward significantly.

None of the masks have been tampered with, except for the Wooden Mask. In fact there's hardly any change for players before all 8 masks have been collected. When that happens, however, this mod adds two things:
1) The Wooden Mask gets the ability to teleport you to the sanctuary from any place, as long as you can fast travel from it. You'll even be teleported back to the same place, when you take off the mask again.
2) The door in the sanctuary unlocks, and you'll be able to use the place like a home. The area has been filled with everything you may need, and there's quite enough space for storage and display for most people.

Since there always seems to be people who suppose something isn't in the mod and complain about it without bothering to check, here's a list of the facilities:
- Bed
- Alchemy table (x2)
- Enchanting table
- Forge, workbench and grindstone
- Smelter
- Tanning rack
- Cooking spit
- 10 new containers of various sorts
- Loads of bookshelves, display cases, weapon racks and mannequins


Technical Stuff

The masks haven't been altered, as mentioned earlier. Only the script of the Wooden Mask has been changed, which means that there should be no conflicts with mods changing the texture of any of the masks, nor any conflicts with mods that change the behavior of the nine named masks.

Two of the urns in the sanctuary, the two big ones by the door, originally respawn their contents, which is a bug in Skyrim. I've change them to not respawn, so they're safe to use. however, I don't know what'll happen when an official update, that fixes the issue, comes. Hopefully it won't cause any problems.


R21: I believe I have fixed the problem with the door locking again. However, I still have no idea what's causing the door not to open in the first place for some people. Some have said it helped not being overencumbered, for some it helped going out and back again, and there's generally not much sense in any of it. For those it still won't work for, you can open the console (use the key beneath Esc. For some it's ~, for others something else, it depends on your country), click the door with the mouse, type 'unlock', and press enter.

R20: There's been added a way to remove the Wooden Mask while inside the sanctuary, without being teleported back. Look for the note descriping it by the throne.

R19: There's been added a variety of containers, some lighting has been changed, and I found out that the invisible wall I'd fixed earlier, wasn't actually fixed. I have no idea what's causing it, then, unless it's the collision box of the sanctuary itself which is being weird, in which case I have no idea how to fix it


I don't know where to find this place:
Look around by the Labyrinthian ruins, until you find a wooden mask and a note.

The door is locked/I can't teleport to the sanctuary:
Be sure to have collected and placed all 8 mask on the altar in the sanctuary. In the case of not teleporting, be sure to be at a place from which you can fast travel as well. If it still doesn't work, ask in the comments.

I want a spouse:
I considered it, but since you need the mask to get to the sanctuary and there's only one, I've decided not to let let spouses move there. Also, it's bothersome and I'm lazy.

Can I use this with Psychosteves mod:
Yes. Read the 'Technical stuff' part above.

Can I use this mod with some other mod:
Read the 'Technical stuff' part above and judge for yourself. If all else fails, try it out.


Some people have been getting a blue screen after teleporting back from the sanctuary. I haven't been able to recreate it yet, so if you're one of those people, please tell me which other mods you're using, so I can try to find a solution.

Noone has complained about this yet, but I've experienced a weird glitch with the distortion effect of the barriers in the sanctuary myself. If it should happen to anyone else, know that it can be fixed by turning anti aliasing on.
< >
sgtseano Aug 10, 2017 @ 4:32pm 
aaaahhhhhahaha! thats why the bookcase is now in front of the fireplace. ohh, thats funny. and yeah, its been a while, but finding the mods has made this a new game for me. im still greatfull for the work youve done, and, i appreciate (sp) the respones. thanks.
Kristjan  [author] Aug 10, 2017 @ 2:53am 
@sgtseano It's also several years since I messed with this, so I don't remember it too well myself, but IIRC the mod opens up the area after you collect all the masks, and that's it.

There's some bugginess with the home in Whiterun, since I copied the bookshelves from there and apparently messed something up in the process. I looked into fixing it at one point, but it ended up being a lot harder than expected, so never got it done. Other than that there'll be incompatibilities with other mods that change the script of the wooden mask, but other than that is should be fine, I think. Again, I don't remember this stuff too well.
sgtseano Aug 9, 2017 @ 8:01pm 
yeah, unable to collect final reward, is there supposed to be a last mask or something? if its just the place as a hideout, then thats cool. i was under the assumption that there was a mask.
sgtseano Aug 4, 2017 @ 10:15am 
ive been away from this game for years, probably four years, untill i was introduced to skyrim mods via youtube. its nice to be back, and it's so very nice to have a mod such as this. two thumbs waaaayyy up, my friend, thank you.
Although..... its a little buggy when combined with the lakeview dragon priest mod. other than that its awsome, though for some reason i cant "collect my reward" ill work it out, or not. thanks.
%%% Nov 1, 2015 @ 2:53pm 
I wish it was extender farther so that you had like an entire castle. I'd love to do it myself if you showed me the tools I'd need.
cinnadude Jun 30, 2015 @ 3:25pm 
Also, there's this mod on Nexus that makes the masks look badass.
...The problem is, my PC (one of them old windows 7 nasty ACER laptops) can't run the nexus website.
himoverthere.young737 Jun 5, 2015 @ 7:58am 
@yrmama The alter is right smack in the middle of the outside of labyrinthian. It isn't inside the dungeon it's in a mound outside.
yrmama May 31, 2015 @ 9:39pm 
I don't know what's going on. The quest is listed under "Quests", but nothing is marked on the map. (I have all the masks.) Wandered around Labyrinthian. Found a plaque "hailing" Bromjaar, but all the passageways just took me through Labyrinthian Thoroughfare, Labyrithian Something Else, & then back outside.
So I can't find the altar where I should put the masks. And why don't I get an arrow on the map?
opusGlass May 23, 2015 @ 10:22pm 
I love this mod!

@Kristjan I've written a fixed version of the Wooden Mask script and uploaded it as a stand-alone mod, Portkey to Bromjunaar. It's compatible with this mod. Let me know if you would like to exchange some source code. The only thing I wish you would add is more mannequins! I'd do it myself but I really only know how to script. :)
Osujin Mar 17, 2015 @ 11:22am 
I just came back to play the game again and I loved this mod...when it worked. I disabled all mods except this one but it still won't teleport me aside from the normal way, the door is locked (needs key) and, if I unlock it, I am perma-slow, as in, walk like I am encumbered. I tried so many combinations, but alas, it looks like this one is borked.