Arma 3
62 ratings
Road Flare DEMO
 
Rate  
Favorite
Favorited
Unfavorite
Data Type: Scenario
Scenario Gameplay: Singleplayer, Multiplayer, Coop, Persistent
Scenario Map: Altis
Meta: Collection
Tags: Tag Review
File Size
Posted
Updated
0.452 MB
Nov 30, 2016 @ 4:34am
Sep 26, 2018 @ 4:13pm
8 Change Notes ( view )

Subscribe to download
Road Flare DEMO

Subscribed
Unsubscribe
In 1 collection by ALIAScartoons
ARMA 3 SCRIPTS AND DEMO MISSIONS
48 items
Description
Road flare script featuring a chemlight tweak which can be enabled or disabled via a public variable.
Flares' lifetime, brightness and range are customizable via script parameters.
For more info watch the video tutorial.

If you want to have an object placed in editor work as road flare place this in its init field:
null=[[[this],"AL_roadflare\static_flare.sqf"],"BIS_fnc_execVM",true,true] spawn BIS_fnc_MP;

Video tutorial:
https://youtu.be/-57zQci_jNc

Demo mission on ALTIS. Tested on dedicated.
You can run the script from init.sqf, a trigger or another script.
Un-pbo the mission and read the comments or watch the video tutorial for more information.

If you like my work and want to support:



For those who prefer to donate via PayPal here it is the link
[www.paypal.com]

My Patreon Page:
https://www.patreon.com/aliascartoons

Direct Download link
http://www.armaholic.com/page.php?id=31990

My Twitter account
https://twitter.com/ALIAScartoons

Other Scripts
http://steamcommunity.com/sharedfiles/filedetails/?id=660222301

DO NOT INCORPORATE THIS SCRIPT OR PORTIONS OF IT IN MONETIZED PRODUCTS OR SERVERS WITHOUT ASKING FOR PERMISSION AND OBTAINING APPROVAL FROM ME!!!
< >
76 Comments
ALIAScartoons  [author] Dec 20, 2018 @ 12:15am 
@GrannyMan
Yeah, is the EH, you need to double check the classname you used for flares, the script should trigger only when you use those chemlights or whatever you set up to work as road lfares
GrannyMan Dec 19, 2018 @ 8:33pm 
Hey Alias, I get an error with this script every time I shoot a gun.
\AL_roadflare\static_flare.sqf, line 90?
Error undefined variable in expression: _culoare_elem
and
\AL_roadflare\al_roadflare_effect.sqf, line 156
Error undefined variable in expression: _culoare_elem

Any idea what could be causing this?
Anfo Oct 11, 2018 @ 5:26am 
@alias
Thanks for the advice, have replaced the RHS objects with 1m texture objects and haven't seen errors since.
ALIAScartoons  [author] Oct 11, 2018 @ 3:36am 
@Anfo
If the class name for object you use is correct that shouldn't be the problem. Could be that the object you use to throw is deleted very fast and something else is placed instead, i don't know how flares in RHS work. Do you have same issue if you use another object?
Anfo Oct 11, 2018 @ 2:44am 
Alias, although there is every chance I have implemented something incorrectly, I still get these script errors which mean when I run a mission from Eden sometimes the flares work, sometime they don't:
https://pastebin.com/bZi5ZWJ9
Any thoughts? Could it be the object I've chosen to be the 'flare'?
"rhs_weapon_rsp30_red"
ALIAScartoons  [author] Oct 9, 2018 @ 2:01am 
@Anfo
In theory there is no limit, tho i never tested it but should work fine.
Anfo Oct 9, 2018 @ 1:06am 
@alias
Is there a maximum <al_Roadflare_lifetime> that I cannot exceed? Is 7200 too high?
ALIAScartoons  [author] Sep 28, 2018 @ 9:17am 
@kullervo
Compare the flicker you get on your map with the flicker you get on altis in demo mission and see if there is any difference
kullervo Sep 28, 2018 @ 8:48am 
thanks for a quick response though :-)
kullervo Sep 28, 2018 @ 8:47am 
i'll do more testing, it's on a ww2 map so idk, maybe that's it