rFactor 2

rFactor 2

123 ratings
Adelaide Street Circuit
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
339.285 MB
Oct 3, 2016 @ 9:41am
Apr 23, 2019 @ 11:50pm
3 Change Notes ( view )

Subscribe to download
Adelaide Street Circuit

Description
➡️ original Track created by wizzfactor2
➡️ converted to rfactor by Redhawk and Flaux
➡️ converted and updatet for rfactor2 by digga (www.simracingteam.net)

Special thanks to McNolo for some great stuff, Nuno Lourenço for help and feedback and Simracingforlife

Chancelog v1.07
➡️ change curb texture
➡️ added IPB
➡️ ao map for pitbuild
➡️ adjust tree colours textures

good race for all, have fun 😃

< >
39 Comments
GBJ sch Apr 19 @ 6:26pm 
Great work... but the replay always is in slow motion, and from what I read it seems to be related to the track, but I don't know, if you could try to do something to solve it would be incredible ...
DA-DIGGA  [author] Mar 16 @ 8:28am 
All fine here.. I subscribed > steam is downloading the file > restart rfactor 2 launcher > the file will be installed.. Don´t know where´s the problem. (Old UI)
D4G_LawrenceBernardo Mar 15 @ 3:34pm 
same thing with me. Subscribed but not installed
capster_1 Mar 14 @ 8:38pm 
I'm subscribed but cannot see on my track list.
ManBearPig Nov 13, 2019 @ 11:30am 
Great work...so immersive in VR but needs optimization.
Luke Rosella Sep 7, 2019 @ 6:06pm 
Great mod only thing would be to make the ai be more aggressive on the kerbs
sadeso Aug 25, 2019 @ 3:35am 
Nice to see the track I created back in 2004, has been updated and is still being used in the current RFactor 2 game 🙂
DA-DIGGA  [author] Apr 25, 2019 @ 7:24am 
Something is wrong with your system settings. I have a gtx1080, a little bit faster, resolution 2560x1440, full settings everything on maximum. Cockpit view with mirror I have min 142 and max 170 fps. So what should I say? Settings in the player.json all standard
Paul Au Apr 25, 2019 @ 5:00am 
I get massive framedrops in turn 3 and turn 13. The green bar hits almost maximum only on those turns. Everywhere else it's less than half. I suspect it's the trees that's causing this.
Paul Au Apr 25, 2019 @ 4:29am 
Hi Da-Digga thanks for responding I appreciate it. I am capping my fps to 55 actually (set in player.json) and vsync is on. Only on this track and road america im having massive framedrops in multiplayer. When pressing ctrl+h the green bar (gpu) is reading high, unlike in silverstone where i get very smooth gameplay even on maxxed. I even tried putting every display setting to low and i still get framedrops. I have a 1070 and an i5 8400. Can you recommend some other settings i could turn down in the json file perhaps? Again, everything's on low (in display settings) already.