Sid Meier's Civilization V

Sid Meier's Civilization V

110 ratings
[BNW] Beothuk Civilization - Colonialist Legacies
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
16.424 MB
Nov 16, 2015 @ 5:55am
Feb 14, 2016 @ 10:14pm
6 Change Notes ( view )
You need DLC to use this item.

Subscribe to download
[BNW] Beothuk Civilization - Colonialist Legacies

Subscribed
Unsubscribe
In 3 collections by TPangolin
[BNW] Colonialist Legacies: Histories of the New World Modpack
31 items
[BNW] Colonialist Legacies: Canadian First Nations Civs
9 items
TPangolin's Recommended Civs for 2016!
52 items
Description
In this mod you'll play as Nonosbawsut, the Great Red Chief of the Beothuk! In the days before the coming of the white man, a splinter tribe of the Wabanaki found remnants of Viking technologies among the ruins of what would later be known as Newfoundland. Armed and empowered by these tools and relics, these people would build a new way of life and become known as the Beothuk.



Coming soon: Kimberley Aboriginals, Malaysia and more!

Features voice acting by Charlatan Alley and Custom Leader Music!

Leader: Nonosbawsut

Rules of Acquisition: Antiquity Sites are visible from the beginning of the game, and give +2 Production and +1 Science when worked by a city.

Demon's Head: Unlike the Catapult which it replaces, the Demon's Head does not need to set up, but has limited ammunition. The Demon's Head is a lousy siege engine but very effective at crushing land troops and nearby watercraft. Demon's Heads give the Beothuk a strong defense in early combat. They can be used to protect against early attacks gone bad, or against early enemies. Position them on stone or forests to speed up their reload times. When a Demon's Head runs out of ammunition it turns into a Spearman until the ammunition is replenished.

Mythic Emblems: Mythic Emblems are available earlier than the Lighthouse, which they replace. Many different Mythic Emblems exist, each with different powers, but only one can be constructed in each City.

Visit the wiki to find out what each of the Ship, Song, Hunt, Festival, Moon, and Council Mythic Emblems do!

Requires BNW

Direct Installation Instructions:

1. Download 7zip (it's freeware, and takes next to no time to install)
2. Download the Civ5Mod file from here -> Steam Workshop Downloader[steamworkshopdownloader.com].
3. Place the Civ5Mod in MyDocuments> MyGames> Sid Meiers Civilization 5> MODS
4. Right click the Civ5Mod file and select 7zip -> Extract to "[BNW] Colonialist Legacies - (insert civilization here)
5. Start the game up and hit Mods
6. Enable the mod
7. Play the game

Mod Compatibility:
- YnAEMP v23
- Piety/Sovereignty
- C&C
- Events and Decisions
- Map Labels
- Cultural Diversity
- ExCe
- R.E.D
- Civ IV Traits
- UCI

Colonialist Legacies CivFanatics Thread[forums.civfanatics.com]

Credits:

Concept by Neirai and Reedstilt
City List by Reedstilt
Translation by Neirai
Decisions by Neirai
Mod Support and Direction by TPangolin
Lua by Neirai
Special thanks to Sukritact and LastSword
Map by Regalman
Leaderscreen by Specialize, with improvements from RawSasquatch and TPangolin
Pedias by NameUndisclosed, NiaoMeow and SuperWaffle
Compilation by Senshidenshi
Music by Michal Esz
Unit Graphics by Civitar and RawSasquatch
Icons by Specialize, Kujarim_Wuniver, TPangolin and DJSHenninger
Popular Discussions View All (1)
1
Nov 21, 2015 @ 6:50pm
]
sonofvl
< >
63 Comments
Thirram Apr 4, 2018 @ 8:06am 
Also the civ and everything about it (apart from the leader) does not appear in the civilopedia
Thirram Apr 4, 2018 @ 8:00am 
I found a glitch while using this mod with jfd's jfdlc collection (more specifically the progress in time file). The deamon's head unit is non-existant and is replaced with the council mythic emblem while the mythic emblems themself aren't changed
Kid Ink󰀉 Feb 6, 2018 @ 10:42pm 
The civilization doesn't even appear as an option when I've enabled the mod and set up my game!
Not even the fixed version works!
Anyone got any answers? I'm from Newfoundland and I really want to play as the Beothuk, but NOTHING is working!
qqqbbb Jul 19, 2016 @ 1:36am 
If the mod does not work for you , get fixed version here [forums.civfanatics.com].
Silas May 27, 2016 @ 5:13am 
It seems like this mod clash with JFD civ mod, is there anyway to figure out how to fix it?
Kinojitsu_Asahi May 18, 2016 @ 11:30pm 
So I tried to play this mod, but there are no antiquity sites visible throughout the game for me. I started the game from ancient era and now I am already in Industrial era. Do I have to research archaeology to see antiquity sites or is there some kind of bug?
qqqbbb May 11, 2016 @ 1:14am 
And there is error in database.log. Did you not test your mod?
qqqbbb May 11, 2016 @ 1:08am 
When you start the game "BeothukTrait.lua" throws an error.
The Specialize May 5, 2016 @ 11:41pm 
Tpang, Just noticed this but you spelt my name wrong in the Icon credits x.x
stephen_l.sheridan Feb 28, 2016 @ 1:52am 
i love this civ, but the civ iv traits do not show up.Not only do they not appear next to the leader's name, but they aren't working either...any ideas?