The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

736 ratings
Assassin's Creed Rogue Colonial templar Coat
Category: Armor
File Size
16.307 MB
Oct 23, 2015 @ 1:52am
1 Change Note ( view )

Subscribe to download
Assassin's Creed Rogue Colonial templar Coat


Why my mod is upload on this site??

Model,Tex:Assassin's Creed Rogue

2. You make female version.? →I do not intend to create a female version .

3.Where is it crafted? → Check the Forge /xx000065

4.How do you Mod download ?→+subscried click

< >
Bigby Sep 16 @ 6:16am 
I have made a video on how to get the armor, here
The Silver Ginger Jun 1, 2017 @ 12:30pm 
It'd be cool if you were to port all of your assassin's creed armors to fallout 4.
Dovahkiin Apr 10, 2017 @ 11:50pm 
thanks for sharing
Master Templar Mar 13, 2017 @ 1:39am 
Love these outfits. Though I know XiNAVRO did these originally. I recall this mod as well as his mod together - the big in-game difference is that the armour pieces in this upload aren't seperated, in other words, the boots and coat are one item, which isn't good for some of those vanilla light armour perks. Whereas, XiNAVRO had them seperated.

XiNAVRO, if you're reading this, it's a shame that something like this has happened, but I wouldn't give up on modding. These armours are proof you have some serious skill.
Guard  [author] Feb 19, 2017 @ 9:36pm 
XiNAVRO Feb 18, 2017 @ 10:59pm 
Leaving this in case anyone demands proof (e.g. incvIζ):

Also google "XiNAVRO's Conversions". I've been modding since Morrowind days, and I have a track record of mods that I have worked on with evidence to show that I am the person who actually worked on these.
incviZ Feb 18, 2017 @ 9:29pm 
@XiNAVRO thats really yours? Give us a fuckin' proof
XiNAVRO Feb 18, 2017 @ 4:49pm 
"Your mod"? I don't mind you uploading my mod on Steam Workshop, but:

1) You have not asked for my permission, and
2) Now you are falsely claiming this as "your mod".

It's shit like this made me quit modding. Seriously, WTF mate.
pepijnwillems48 Dec 23, 2016 @ 5:55am 
where in the forge is it i cant find it help
Xpro Oct 30, 2016 @ 4:59am 
very nice