Age of Empires II: HD Edition

Age of Empires II: HD Edition

60 ratings
How to play AoE2HD on Mac 10.11 El Capitan
By DoctorWillCU and 1 collaborators
This show you my way to install AoE2HD on Mac OS X El Capitan 10.11, also work in 10.6.8 Snow Leopard.
 
Rate  
Favorite
Favorited
Unfavorite
Prologue and Credit
Updated on 2017-04-23

I would thanks to sudo from the guide in following link,
https://steamcommunity.com/sharedfiles/filedetails/?id=247537337
sudo is the first one to written steam guide which bring the way play on mac by using Wine Wrapper in Steam community, this is no doubt and can be find out easily on internet.
I use sudo method AOE2HD in my mac since 2013 until its broken due to AOE2HD Patch 4.0, a big changed of patch.

This is how this guide be created while I figure out using PlayOnMac.
Unfortunately my 6-year-mac was dead in 2016. I can't update this guide anymore.

If anyone would be interest to update this guide, continue in fixiing in latest MacOS. Feel free to take any information and pictures from this post. Giving credit to me and TeslaStormX is optional. I would suggest you to give credit to sudo who the one first bring method in steam community.
Video Tutorial by TeslaStormX
Download PlayOnMac & Steam(Windows)
http://store.steampowered.com/about/
Download Steam.exe Windows Version by click Windows.

https://www.playonmac.com/en/
Download PlayOnMac which can run Steam games and other Windows Applications.
Install PlayOnMac and Wine



Install Steam (Windows Version)
Install AoE2HD and Fix Launcher
Optional 1: Change "Quit Wine"
Optional 2: Make new shortcut
Optional 3: SmoothMouse
Optional 4: Fix Text not showing up
Optional 5: Fix Video Memory Size
Optional 6: Fix Windows Version
< >
342 Comments
Ragobsky Sep 15 @ 4:00am 
I don't know why the game worked very well. I could play online. And now, i appear offline. So i did installation and all instructions again.
When i open Steam (PC), and press download Age of Empire II HD, it say : "Steam - error : An error occurred during installation of AOEII HD Edition" and the download stay at 0%...
It look like i'm offline so i can't download the game :'(

Someone know how to make it work ?
I'm on iMac mid-2010 / MacOS Sierra 10.12.6
Durian Sep 6 @ 12:14pm 
If you're having issues installing the game, try following these instructions:
https://www.reddit.com/r/wine_gaming/comments/8r0gh6/steam_in_winedevel_content_servers_unreachable/
bvickstrom19 Aug 13 @ 7:41pm 
Same Problem as MrSpock
MrSpock Aug 11 @ 4:33pm 
As mentioned below (@fuenfeuro), I tried changing wine's windows version to XP, which let me go online. However, considering the fact that windows XP will not be supported by steam after the end of 2018, a permanent solution would be useful.
MrSpock Aug 11 @ 4:16pm 
Hello, I followed the instructions. The game runs smoothly, however I have a problem with steam: In the friends window, everyone appears offline, including me (it says under my account name "Last Online: xx seconds ago" ). When I click the little arrow next to my name I have two choices: "online" and "invisible". I click "online" but nothing changes. Any suggestions? because of this I can't send/receive messages, nor invites.
dr.nick Aug 9 @ 3:52pm 
Hi all! When I open Browse Local Files I cannot find any file over there. The folder is completely empty! Maybe I have some problems with installing the game. Has someone the same problem or can help me in solving it? Thanks!
lucie0290 Jul 31 @ 10:14am 
Anyone has a problem when Steam logs in, but nothing happens afterwards? Any help how to fix this? I have re instal steam 3 times and I obtain the same result each time
fuenfeuro Jul 31 @ 6:25am 
@
Poloch I´ve the same problem. I fixed it by changing the Windows version of my wine to XP, but its not a long term solution..
Poloch Jul 29 @ 11:03am 
Is anyone having issues since the last update of steam ? I can't go online anymore. I am stuck in the invisible mode. I try to reinstall steam, it does not work and now I can't even download AOE again because the servers are unreachable. Does anyone know how to fix this issue ?
malik algerian héros Jun 9 @ 9:13pm 
and for aoe 3