Source Filmmaker

Source Filmmaker

Not enough ratings
Steam Library Fix
By Tumbolisu
What to do when the Steam Library won't give you easy access to SFM.
 
Rate  
Favorite
Favorited
Unfavorite
Check Library
All non-games are located in Software or Tools. Tools don't have their own storepages and can only be installed from the Tools tab. Software is similar to Games, as these can also be bought and downloaded from special pages in the store. Check the Software tab to see If SFM is there and you simply missed it. Nothing there? Keep reading.
Check Files
Who knows, maybe you haven't actually installed SFM yet?
Simply go to
\Steam\SteamApps\common
and search for the folder SourceFilmmaker.



None found? In that case you should go to the Storepage and download it. Or check the Downloads tab in your Library. Maybe the download just hasn't finished yet?

In case the folder does exist, and it actually has a bunch of stuff in it (enough to even run the .exe and actually use it) you should, well, keep reading now.
Check .acf File
What is a .acf file?
A .acf file is being used by Steam to tell what Games and other Software you have installed. (Tools do not have .acf files.) This file also tells Steam a whole bunch of other things, like properties about background downloads. Without this file, Steam doesn't even know you have whatever-it-points-to installed. In case it's something you have to buy, removing the file will give you option to install it right from your library. In case it's something free, like TF2 or SFM, deleting the file will result in the specified object to not appear in your Library anymore.
So, we are gonna check if the file exists and is written properly. Go to
\Steam\SteamApps
and look for a file called appmanifest_1840.acf.



The 1840 at the end is the Game/Software ID. You can easily find it by looking at the URL of the storepage or the gamehub.

If you can find it, open it in Notepad. You can also use Notepadd++ if you like. Now, if all you can see is completely unreadable or just a bunch of "NULNULNULNULNUL", you should just go to the next section now.
In case the file does not exist, just create one! Make sure it is actually using the .acf extension, not .txt. Go to the next section as well.
Modifying The .acf File
Last step. Having the file opened in Notepad, delete everything in it and replace it with the following stuff:
"AppState" { "appid" "1840" "Universe" "1" "name" "Source Filmmaker" "StateFlags" "6" "installdir" "SourceFilmmaker" "LastUpdated" "1" "UpdateResult" "7" "SizeOnDisk" "1" "buildid" "1" "LastOwner" "76561198054722423" "BytesToDownload" "0" "BytesDownloaded" "0" "AutoUpdateBehavior" "0" "AllowOtherDownloadsWhileRunning" "1" "UserConfig" { "language" "english" } "MountedDepots" { "1840" "19367849625690" } }
Disclaimer: Some of the values might not be correct. I had to think up some numbers to fix it on my own. It is still enough to do what it is supposed to do: Make SFM appear in the Library.

Now save the file and restart Steam. Check the Software tab. SFM should now 99.9% guaranteed show up.
If not, you probably messed up something very badly.
< >
5 Comments
Tumbolisu  [author] Sep 13, 2016 @ 11:07am 
No need to be rude and use swears.
Well I'm assuming you read everything, which means you modified or added the appmanifest_1840.afc file because you absolutely had to.
It's strange that you can't edit it. Are you making sure that Steam isn't running while you do that? Whenever something can't be edited, it is because a program is currently using the file. So shutting down every program that could use it should fix that problem.
Also, it's possible that not every SFM file is on your PC. Did you try to directly run the .exe before? Did it work? In any case, try everything you can make it download anything that's missing.
Kowalski Sep 13, 2016 @ 10:17am 
Well thanks you fucker, now sfm is showing up but it wont start, it says it has a update and I get an error. I cant even delete the things in the appmanifest_1840.afc. What the fuck dude?!
didnt play for 3 years Jun 17, 2015 @ 1:34am 
I've tried it with my CS GO too, and verifying the cache didn't work this time either. Thanks for the help though.
Tumbolisu  [author] Jun 16, 2015 @ 1:56pm 
Have you tried to verify the cache yet? Right click on it in the library, go to properties, local files, and "VERIFY INTEGRITY OF APPLICATION CACHE...". Steam will check if all files are alright and download any broken ones.
Other than that I don't know what could possibly help.
didnt play for 3 years Jun 16, 2015 @ 1:43pm 
I'm not really sure if I should be asking this somewhere else, but I have a problem. I see my Source Filmaker, and when I press launch, it says to either launch SFM or SDK launcher or something. However, I can't launch SFM and can only launch that SDK launcher thingy. But even if I can load that, I do not know how that can help me with my problem. Anyone help please?