Arma 3
4,851 ratings
CBA_A3
 
Rate  
Favorite
Favorited
Unfavorite
Data Type: Mod
File Size
Posted
Updated
1.970 MB
May 28, 2015 @ 8:37am
Oct 11 @ 11:05pm
33 Change Notes ( view )

Subscribe to download
CBA_A3

Subscribed
Unsubscribe
Description
CBA: Community Based Addons for Arma 3
Current version: 3.9.0
What does the name Community Base Addons mean? It is a system that:
  • Offers a range of features for addon-makers and mission designers.
  • Aims to have community wide acceptance and to be used as much as possible by community addons to maintain compatibility.
  • The community is very much encouraged to request or submit functionality.
  • The most obvious example would be to submit functions to be included in the CBA function library.
Documentation
Full documentation is available at GitHub[cbateam.github.io]

Licensed Under GPLv2
Any addon which calls CBA-defined functions need not be licensed under the GPLv2
or released under a free software license. Only if you are directly including CBA code
in your addon's binarized PBO or redistributing a modified version of CBA itself would
your work be considered derivative and therefore be legally required to be released under
the terms of the GPL. (And there's no reason to ever do either of these.)
Popular Discussions View All (52)
11
Sep 28 @ 12:10pm
Starting Game, CBA_A3 Signature Mismatch
RET-USMC
10
Feb 28, 2017 @ 1:50pm
Why a new key everytime
kayakmainac
12
Jul 22, 2017 @ 12:45am
Script userconfig\cba\settings.sqf not found
Yoyo
< >
1,183 Comments
Pfc. S. Chase | 11th PD 15 hours ago 
That is MCC sandbox
Scorpion Dec 16 @ 3:12pm 
Hello there. Id like to report an issue. When i run cba i cant get into jets. It sais to me "you need to be a pilot to fly" and kicks me out. But the funny think i spawn as a fighter pilot. Once i disabled it the problem was gone. I did series of test so im 100% sure. Thank you for your time
snowdogs92 Dec 10 @ 8:45am 
so mine says need CBA 3.9 or better and i have 3.8 but i checked and i have the correct version i even deleted it and redownloaded what can i do?
HBAOplus Dec 10 @ 4:33am 
Some mods and campaigns(eg. range of death) that are intergating old version CBA components are now conflict with ACE. I think that's the reason for "ACE requires 3.9 or higher".
jeroenV1982 Dec 7 @ 1:17am 
Here also ACE requires 3.9
bennsheehan Nov 29 @ 10:57am 
@reptilienski how does one do this rebuilding you speak of
Reptilienski Nov 29 @ 2:24am 
Guys, I fully tested everything and fix the "ACE requires 3.9 or higher though" issue, it seems it was not CBA's issue but some other stuff. What I did was, I used have some missions with old CBA modulars and ACE modulars in it, and after the newest ACE update seem some of the ACE modulars use in the missions are out dated, so I fully rebuild all the missions with the new ACE and CBA modulars and now everything works fine, no error. I think whatever missions you are current using might be outdated and you need to update it youself or wait for an update from the original mission maker.
ruanui01 Nov 28 @ 11:59pm 
Ummm ... same problem . ACE requires 3.9 or higher though
Пролетарий Nov 28 @ 8:27am 
I added it for official launcher, donwload but in game it say what I have version 3.4... and need a 3.8. What I will do?
Rheinmetall Nov 28 @ 2:05am 
It says ace requires version 3.8.0 or higher, and I have the latest one.What should i do?