The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

245 ratings
How to complete broken quests
By Akalonian
If you are stuck on a broken or bugged quest, this guide may help you complete it.

The The way of the force and Forbidden Legend quests will be used as examples.

This is a step by step guide that will show you how to move a quest to a different stage.
 
Rate  
Favorite
Favorited
Unfavorite
Basic console usage for this guide
Read this if you do not know how to use or navigate the in-game console.
  • To open the console on an American-English keyboard, press the Tilde(~) key, To open the console on a British-English keyboard, press the key Grave(`) key. The key is usually located below Escape(Esc) and to the left of the One(1) key.
  • To navigate the console, press Page Up(PgUp) and Page Down(PgDn).
  • Press Enter to use a command in the console.
  • Use the Up and Down navigation keys to scroll through previous commands.
  • The terms quest_id and stage_number must be replaced by the ID of the quest and the number of the stage.
Basic step by step guide
  1. Find the quest ID
    Use one of these methods to get the ID:
    • In the console, type:
      ShowQuestTargets
      This will list all of your active quests.
    • Look up the quest ID on the Web.
      A good place to start is the UESP Wiki[www.uesp.net] page.
    • If this is a quest from a mod, read the the details on the mod page and make sure you installed everything correctly. If everything was installed correctly, you can use the first method to find the quest ID.

  2. Find the current stage your quest is in
    • Once you know the quest ID, type:
      Player.sqs quest_id
      This lists all of the stages in the quest. Each stage is marked with a 1 if you completed that stage or a 0 if you have not completed that stage yet.

  3. Move the quest to the desired stage
    • Look up the stage you want to jump to.
      You can either jump to the final stage ending the quest or to the next stage in the quest.
      In some cases you learn new spells or shouts, or receive new items during certain stages that you should not skip.
    • Once you know the quest stage you want to jump to, type:
      SetStage quest_id stage_number
      If you selected the correct stage, the quest will complete or move on.
Example: The Way of the Voice
This is how I used these steps in the The Way of the Voice quest.

Problem encountered and the reason behind it
In the Demonstrate your "Unrelenting Force" Shout stage, the Greybeards would attack me after using my Shout. This would repeat after the Learn the Word of Power from Einarth stage.

Why this bug happens:
  • You did other quests before the The Way of the Voice quest.
Known fix:
  • Start a new game.

How to fix the quest without starting from zero
  1. Get the quest ID.
    In this case, you should find this page[www.uesp.net] that gives the quest ID: MQ105
  2. Open the console and type:
    Player.sqs MQ105
    This will show you all the stages for the The Way of the Voice quest.
    At this point, you should be in stage 30, Demonstrate your "Unrelenting Force" Shout.
  3. Look up the stage you want to go to. Make sure you don't skip over any items, spells, or abilities that you need to gain.
    In this case, we want to skip to stage 50, Speak to Arngeir, because we will learn a new Shout.
  4. To skip to stage 50, type:
    SetStage MQ105 50
    The quest should now think you just used your Shout and will continue.
    At stage 58, Learn the Word of Power from Einarth, you learn the new Shout.
    Problem:
    • At stage 80, Demonstrate your "Unrelenting Force" Shout(3 times), the bug from stage 30 will repeat.
  5. Look up the stage you want to go to.
    Even though stage 100, Learn the Word of Power from Borri, is where we want to get to, we need to skip the quest to stage 90 if we want stage 100 to work.
  6. To skip to stage 90, type:
    SetStage MQ105 90
    They Greybeards should start moving outside.
    You will still see a quest marker asking you to complete what was in stage 80, but it is safe to ignore that.
    The final stages of the quest should not be bugged and after you complete them, you should no longer see the quest marker for stage 80 because the quest was marked as complete.
Example: Forbidden Legend
This is how I used these steps in the Forbidden Legend quest.

Problem encountered
In the Reforge the Gauldur Amulet section of this quest, the third of the three bosses would not come down and fight me.

How to fix the quest
  1. Get the quest ID.
    In this case, you should find this page[www.uesp.net] that gives the quest ID: dunGauldursonQST
  2. Open the console and type:
    Player.sqs dunGauldursonQST
    This will show you all the stages for the Forbidden Legend quest.
    At this point, you should be in stage 300.
  3. Look up the stage you want to go to. The Wiki does not list these stages, so we have to rely on the 1/0 marks.
    In this case, we want to skip to stage 301, the next stage.
  4. To skip to stage 301, type:
    SetStage dunGauldursonQST 301
    The third boss should now teleport down and start fighting you.
Other tricks
If changing the quest stage does not work fix the quest, there are a few other things you can try.

  • One of the first things you should always try is leaving the area and returning. This has worked several times because it reset everything.
  • If an NPC won't move, try getting him to attack you and then leave the area. When you return he may have reset and continued moving.
    Example:
    • In the Waking Nightmare quest, after stage 191 (Defeat Veren and Thorek), Erandur will not move to the next waypoint. I attacked him, forcing him to attack me, and I left the dungeon. Everything went back to normal when I re-entered the dungeon and there was no need to use any console commands.
  • If you can't enter an area, try looking up the ID of the location[elderscrolls.wikia.com] and use the console to move there. Example:
    coc location_ID
  • If a normal room to room door won't open or if your character is stuck, use this console command to enter a no-clip state:
    tcl
    Use the same command to resume.
If you have ever encountered a problem and found a fix for it, post the details in the comments and it will be added to the list.
Reference and contributors
These are the Web sites or guides that helped me fix my broken quest and helped me write this guide:

These are the contributors that added extra information that people could use to fix their broken quests:
< >
75 Comments
Daddy derek Jul 27 @ 6:53am 
It keeps saying "expected end of line" and then "Compiled script not saved!"
Princess 内穏泳 Mar 13 @ 5:36am 
It seems simply typing 'Help "Vonos" 0" worked to find the quest ID.
Princess 内穏泳 Mar 13 @ 5:32am 
Having difficulty with a quest mod, but this has shed some light. I'm trying to find a ring in Tools of Kagrenac, but the ring literally didn't spawn in and adding it into my inventory does not progress the storyline. I used showquesttargets but it only shows quests that have markers. The specific quest I'm looking for does not have a quest target, and was not listed. However, the other quest relating to the mod was, so I at least know the formatting the mod dev uses for their quest names. I might be able to figure it out, after countless guessing.
Sheidan Feb 10 @ 7:32am 
Dude you saved my game. I was stuck in the temple of Miraak. weirdly enough I read lots of topics about people beijg stuck in the Apocryphea but I didn't even get the chance to get there, I got stuck when I read the book, I couldn't move or go to my inventory. This helped me go to the moment I'm supposed to be back and really a big thank you because it took me some time to start this quest (I mean I didn't realise I had to be tracked down by Miraak's minions after being recognized as a dragonborn before I could do anything even though I was freaking out about the hypnotized people on this island for days xD) anyway. huge thank you dude
daddy lazer nips Jan 25 @ 3:29pm 
I have completed the eye of magnus quest. A previous stage, however is marked as incomplete or 0 when I enter player.sqs mg08. stage 1 is the only stage that is marked as 0. How do I change it to 1?
Viktor06 Dec 30, 2018 @ 4:12pm 
I am stuck at the quest after you give the crown to ulfric and tried doing this but it didn't work can anyone point me in the right dierection?
Jacob Dec 26, 2018 @ 9:47pm 
It wont work im on the quest "The Way Of The Voice" on the part "Speak to Arngeir" and when i talk to him (and try every option) it does not work I tried reverting my save and everything and it wont work...
marierporter Dec 2, 2018 @ 4:06pm 
I'm trying to complete the Bard's College quest "Tending the Flames", and there's a hidden quest that controls the ghost's progression through the dungeon. The problem is that the hidden quest won't start. I used the "sqv" command (sqv MS05_dunDeadMensRespiteQST), and it says that the quest isn't "enabled". Set stage won't work, neither does resetting the quest, or trying to start the quest with commands. How do I enable a quest? Do I have to go into the files? I've tried everything on this list (and some suggestions from the wiki) and apparently, this is a very rare problem, and no solution has been found. If anyone can tell me how to enable a quest, please do!
Skreed [G*] Oct 7, 2018 @ 12:40am 
@Kadafi, No. What you actually said was, and I quote: "I set to final stage (30)". 30 is different from 200, genius. You use the wrong stage number and then claim that it doesn't work. I then correct you and this is your idiotic reply. For someone who questions my ability to read, you fail at it pretty miserably here. Again, 30 =/= 200.

Furthermore, notice how most of the comments are like "Works great, thanks", yet here YOU are, Mr. "my setstage doesn't work" (whatever tf that means), unable to follow the simplest of instructions. Consider that your problem is likely between your chair and your keyboard. Know what I mean? No, you probably don't.
Kadafi Sep 21, 2018 @ 12:51pm 
@Skreed Himself [G*] lmao you cant read if i said it didnt work then it didnt work i know what google is but thank you for nothing