Cities: Skylines

Cities: Skylines

110 ratings
Cities Skylines Troubleshooting FAQ
By Ramses II and 1 collaborators
How to fix crashes, graphics problems, low fps, gameplay issues, broken save games, and more...
 
Rate  
Favorite
Favorited
Unfavorite
Introduction
This guide focuses on problems that can affect all users, regardless of operating system.

If you're suffering crashes or weird graphics problems, try the specific guide for your operating system first:
You might also be interested in:
You can use Ctrl+F to search this guide (Mac users: Cmd+F). Try manual browse if search fails.

The contents of this guide are ordered from start to finish as follows: Launching the app > Main menu & Content Manager > Starting/Loading a game > In-game > Exiting Game.

If you have a problem that's not solved by this guide, post details in the comments and we'll try and find a solution for you.

You can refer people to this guide by copying this URL.

Gameplay issues

If you're having problems setting up transport routes, powerlines, making tunnels, etc., there are some sections later in this guide that provide solutions. Also, you can view or download the game manual.
Install error: Content Server Unreachable
Change your Steam Download Region, then Refresh Steam Files and finally Verify Game Cache. Wait until everything has finished, then reboot your computer and try again.

Also, check to see if you have any incompatible virus protection, firewall, proxy server, parental controls, etc. Easiest way to do this is to google "Steam" and then the name of software that you think might be conflicting.
Startup crash: ColossalFramework.Steamworks.SteamInitializationException
You might also see an error like "Either you don't own the game or Steam is broken beyond repair".

Change your Steam Download Region, then Refresh Steam Files and finally Verify Game Cache. Wait until everything has finished, then reboot your computer and try again.
Startup error: Could not load type 'CustomContentPanel' from assembly
This is most often caused by old or broken versions of the Improved Asset Panel or Improved Mods Panel mods (see next section).
1 FPS / Lag in main menu (since 1.1.0 patch)
Laptop users: Game crashes, horrible lags
If your laptop only has a low power graphics card (usually made by Intel) you probably don't meet the minimum system requirements to run the game (see Appendix B at bottom of this guide).

If your laptop has a good graphics card (Nvidia, ATI, etc), the game will sometimes use the low power graphics card by mistake. Here's how to fix that[www.howtogeek.com].

Mac user? Try the gfxCardStatus app[gfx.io].
Mouse Cursor too high/shifted (since 1.1.0 patch)
Can't set desired screen resolution
If your screen resolution isn't shown in Game Options screen, you can use launch parameters (see Appendix A at bottom of this guide) to force a custom resolution.
Content Manager empty, Mods / Assets Missing
If your subscribed mods or assets aren't showing in the Content Manager, try these steps:

Change Download Region

Steam will refresh all your subscriptions when you change the Steam Download Region – be sure to give Steam chance to download any missing files before launching the game.

Verify Game Cache

See: verifying game cache. Restart Steam after verification finishes and next time you load Steam it will check for missing workshop items.

Do you have workshop/mod blocking launch parameters?

Make sure you don't have any Launch Parameters that prevent mods or workshop assets, particularly things like -disableMods and -noWorkshop.

Did you change location of game files?

Make sure the file "appworkshop_255710.acf" is moved to the new location.

Have you *manually* installed LUTs?

Make sure the there are no files in the following folder:

....Colossal Order\Cities_Skylines\Addons\ColorCorrections

Are you using broken Content Manager mods?

There are two mods that improve the Content Manager; both of these mods have broken versions and fixed versions:
If all else fails...

Refresh your Steam Files and if that still doesn't fix it consider reinstalling the game (see Appendix F at bottom of this guide).
Load/New Game menu button Greyed Out / Disabled
Only the New Game menu is greyed out?

If the Load menu item is working but the New Game menu item is disabled...

You need at least one map to be available in order to start a new game. Did you disable or delete all the maps from Content Manager? If so, either enable a map or subscribe to a map from Steam Workshop and then restart the game.

Only the Load is greyed out?

Do you have any save games? If not, you can't load one, Duh! :P

GNU/Linux:

Make sure /home/user/.config is writeable.

Also, disabling second monitor will sometimes bring the New Game button back.

Windows:

Easy fix: Close steam and run it as Administrator.

Better fix: Make sure the following folder has read and write permissions for your user:

C:\Users\<username>\AppData\Local\Colossal Order

Apple Mac:
  • Launch Finder.
  • Menu: Go > Go to folder. Enter ~/.config/
  • Select .config and press ⌘-I to open folder properties
  • In sharing and permission change all access from Read to Read and Write.
  • Next time you run the game it should create a folder called "Colossal Order" in the .config folder – if it doesn't, you've not set the permissions properly
If that doesn't solve it, try this:
  • Click on Macintosh HD then right click on your user name and select Get Info
  • Unlock the lock at the bottom of the popup and put in your password
  • Press the "+" (plus/add) button at the bottom left in Sharing and Permissions
  • Add "Administrator" to the list and set as "Read and Write"
If that doesn't solve it, are you running a custom resolution due to launch parameters (see Appendix A at bottom of this guide)? If so, try different resolution or remove those parameters.
All my saves are deleted!
If you load C:S to find all your saves are deleted, check which user account you are logged in to on the computer. Same user account as last time you played? If not, your saves will be in the other user account.
Unable to load saves
Check to see if they are listed in Content Manager.

If a save is broken, it will have either a red file name or a broken/empty image preview. Deleting broken saves (take a backup first if you want) might help.

Save game folders are listed in Appendix E at the bottom of this guide.
Game gets stuck on loading screen
If you see this for a very long time (more than 2 minutes) when loading a game or starting a new game...



...If you have any of the following mods installed, try unsubscribing them to see if that helps:
Object reference not set to an instance of an object
If you see something like this (particularly if your roads are all grey and broken)...



...it's usually caused by unsubscribing workshop vehicle assets (this mod can help fix that), in particular those associated with public transport such as buses and trains or services such as police and garbage. It can also be caused, to a lesser extent, by unsubscribing building assets.

Note: Even if you didn't unsubscribe, the asset might have been removed from the workshop (eg. due to copyright infringement, which happened with a few car assets).

Mod (code) authors: This error will affect your mods, making the error messages appear to come from your mods when in fact it's something from core game. Some details here as to things you can do to mitigate the impact the error has on your mod.

Solution #1: Unsubscribe the No Despawn Mod

Note: It's likely that the bug with this mod was fixed on 15th June 2015.

If you're using the No Despawn Mod, unsubscribe it to see if that helps.

Solution #2: Re-subscribe those assets and then try again.

If this works, you can delete the routes to cause those assets to despawn and then make a new save that doesn't contain them. There is no way from the log files to determine which assets are missing, so you just have to do trial and error.

Tip: See the "Loading/Starting a Game" section in this guide which lists variants of the "Object reference not set to an instance of an object" error along with suggestions of what type of asset would have caused it. This can help you work out more quickly which assets to resubscribe to.

Tip: You can use the Advanced Vehicle Options mod to prevent unwanted vehicle assets from spawning.


Solution #3: Resetting configuration

Note: We've had several confirmations that this method will solve the error or at least improve the situation (thanks peter.geri2, grapplehoeker and everyone else who provided feedback!), but we aren't sure what side effects it could cause so take a backup first.
  • Make sure you have a gamesave
  • Note down the mods you have running
  • Make sure you know your Paradox account info
  • From the main menu in C:S, choose Options > Misc > Reset configuration
  • Start a new city then exit that city
  • Re-enable all your old mods
  • Load your old gamesave
Test.MyCustomModSim:OnAfterSimulationTick
Unsubscribe the Alternative Siren Sound mod and run a virus scan and malware scan (the mod is a phishing attack that affects Windows users).

Note: As the mod is no longer in the Workshop you'll have to remove it via Content Manager or alternatively delete it directly from disk (it will be in the 418216826 folder).
Blurry text or map? Text too small? Color blind?
Shadows not showing
Check that Shadows are enabled in Game Options screen.

Windows users: Try the -force-d3d9 Launch Parameter to force DirectX 9 mode.
The phantom bridge lurking below the map
If you see something like this lurking under the map (eg. it appears when terraforming or when first person view in a tunnel, or with certain camera mods, etc)...



...that thing is the famed phantom bridge of C:S.

It's currently believed to be a side-effect of using the "Some Roads" mod.

Note: It's NOT caused by Traffic++, that bug was squished[github.com] some time ago[imgur.com].
Horrible sound effect!
Change volumes of any sound
There are several sounds in the game that people dislike, the quickest way to deal with it is using this mod:

http://steamcommunity.com/sharedfiles/filedetails/?id=455958878
Tip: The "bip bip bip beep bip..." sound is from the commercial district (it's merged in to the main sound file so you can't remove it on its own, you have to turn down the volume for whole commercial zone).

Siren sounds
You can instantly change the siren sound of emergency vehicles, and even use your own custom sound (.ogg format), using this mod:

Note: The police and ambulance are hard-coded in game to use same sound file :(

http://steamcommunity.com/sharedfiles/filedetails/?id=435167188
Where did the Alternate Siren Sound mod (American sirens) go?

The Alternate Siren Sound (American siren) was making connectiosn to external site. If you were using that mod on Windows do a full virus and malware scan.

As the mod is no longer in the workshop the only way to delete it (if you still have it installed) is via the Content Manager or by finding it's folder on disk (the folder will be called 418216826).

Chirper sound

Currently no way to change volume of the chirper, but you can use this mod to eradicate it completely:

http://steamcommunity.com/sharedfiles/filedetails/?id=405791507
Seagulls, make them stahp!

Currently no way to change volume of seagulls, but you can eradicate them with this mod:

http://steamcommunity.com/sharedfiles/filedetails/?id=421041154
Vehicles stopping in middle of road
If there is a subway going under a road, vehicles will sometimes stop and wait until the subway train has passed (known bug). Move the subway or the road to a new location to prevent this happening.

Also, there have been some reports of Traffic++ causing this problem: Disable "Realistic Speeds" option in mod settings.
Vehicles not spawning, lots of un-owned parked cars
If cars and service vehicles are disappearing from your city, or you've started to notice lots of parked cars that aren't owned by anyone, unsubscribe the broken VW Golf GTI 2010 vehicle asset and use the fixed Volkswagen Golf GTI 2010 vehicle asset instead.

Other broken vehicles include Alpha Romeo 164 and NoMads Semi class F.
A specific subscribed workshop asset isn't spawning in game
If you've subscribed an asset but it's not appearing in game (just that specific asset - other subscribed assets work fine) look for this error in your Player.log (Mac / Linux) or output_log.txt (Windows)...

System.IO.InvalidDataException: Loading custom asset failed

If you find it, the chances are the asset is broken. The most common cause for this is that the asset author had a mod installed that changed the assets AI class in the asset editor. In most cases the asset author will be completley unaware of this problem - they have the mod so they won't see the error messages.

The only way to fix the problem is to change the AI class of the asset – this is something the asset's author needs to do; please point them to the V10DeleteAI mod which can help them make the required changes.
Custom vehilcles don't spawn very often
Cargo trucks/trains not spawing
If you are having problems with cargo trucks/trains/ships not spawning, and you are also using the Traffic++ mod, follow these steps to fix the problem.
How to change direction of one-way roads?
Go in to the Roads menu and click the small Road Upgrade button, then right-click any one-way road to change it's direction.

To make a one-way road 2-way, or vice versa, select the type of road you want and then with the upgrade tool active click on the road on the map that you want to change.

There is a mod that provides an alternate way to change road direction and toggle between one-way and two-way:

http://steamcommunity.com/sharedfiles/filedetails/?id=408209297
There's also a mod that clearly displays the direction of one-way roads:

http://steamcommunity.com/sharedfiles/filedetails/?id=420500168
I can't build tunnels / bridges
Make sure you're not subscribed to Steeper Slopes mod (it's no longer in workshop but you can unsubscribe from Content Manager > Mods screen in C:S).

For other potential causes and their solutions, see "Tunnels aren't working?" section in 1.1.0b Patch Troubleshooting Guide.
How do I make underground powerlines?
To make underground powerlines, press PageDown while placing them (Mac users: Fn+Down arrow).

Thanks to /u/whisperproud for this tip!
No water flow arrows - where do I put my pumps and sewage?
Some maps don't have flowing rivers (no arrows on the water) on purpose to provide additional challenge. So how do you keep sewage and drinking water separate?

Use water towers for your drinking water, and be careful where you dump sewage. Also make sure your water towers aren't on polluted land, otherwise your cims will get sick.

Thanks to Phoenix C64 for the tip!
All my cims are getting sick/ill
If you're having a health crisis, try these things:
  • Make sure water pumps are not in/near polluted water
  • Make sure water towers / water treatment plants are not on/near polluted land
  • Make sure you have a sewage outlet to get rid of dirty water
  • Make sure you have sufficient health care coverage (you can click on service buildings to see how many ambulances are in use)
Bus / Metro / Train not working
Bus

You need at least 1 bus depot before you can create bus routes.

If you have a depot but still can't make bus routes, try using a different bus depot asset. (Asset authors: Republish your assets from the Asset Editor in C:S 1.1.0 or above and it will start working properly.)
  • Draw a route by left-clicking next to roads to create one or more stops.
  • ...The route must join at both ends.
  • Delete an existing stop by right-clicking its circle.
  • Move an existing stop by dragging it's circle to a new location.
  • Add new stops to an existing route by dragging the route line to the side of a road where you want the new stop to be.
  • To delete an entire line, delete all the stops on it, or click on a bus and "Modify Line" then "Delete Line".
Metro

You need at least 2 metro stations (otherwise people will go underground and never be seen again lol).

If you have metro stations but can't draw metro tunnel or metro routes, try using a different metro station asset. (Asset authors: Republish your assets from the Asset Editor in C:S 1.1.0 or above and it will start working properly.)

Draw metro tunnel between the stations so there is a path for metro trains.

Draw a metro route between the two stations, making sure the route joins at both ends.

You can delete, move or add stops in the same way as you do for buses. In underground view, you can click on a metro train and Modify Line to change colour, rename, delete, etc.

Avoid having more than two routes through the same station platform, it can cause metro jams!

Train

You need at least one passenger rail station to receive tourists.

You need at least two passenger rail stations before you can set up routes within your city.

If you have train stations but can't draw passenger train routes, try using a different passenger station asset. (Asset authors: Republish your assets from the Asset Editor in C:S 1.1.0 or above and it will start working properly.)

Draw a route between two passenger stations to set up local rail service between those stations. The route must connect at both ends.

Cargo stations are a bit easier to set up: Just connect them to the external rail network and resources/goods will be automatically imported/exported. You can also transport goods locally by having cargo stations on the same track.
Harbor or docks - can't build
Make sure your map has a shiping connection; you can see what connections a map has on the screen when you are starting a new game.

Note: The popular Copper Creek map doesn't have a shipping connection.

To build a harbour or docks you'll need to own an area on the map that has acces to a shipping lane; when buying areas (after reaching milestones) hover over an area and it will tell you what features are available in that area. You'll need an area that's very close to the shipping lane before you can place a harbor/dock.

Thanks to grapplehoeker for the tips.
Trees and buildings growing in roads!
If you see something like this...



...it's caused by using "Overlap" mode feature of mods like NoPillars or Road Anarchy; luckily it's easy to fix!

Go to the affected area and make sure the mod is running in "Collision" mode then upgrade a road or plop a small park or some other building nearby. This will force a reset of any nearby zoned areas, and zones that are colliding with roads will be removed (causing any buildings on them to despawn).

There might be some trees and stuff left over but those can be removed using the bulldozer tool.

Note: The mods are safe to use and give far greater flexibility when constructing things, just be sure to always switch back to collide mode and upgrade or place something nearby to make sure the stuff you built is properly deteced by the game engine.
Menu icons not loading
If you see something like this...



...did you install a mod in the wrong folder? It's best to subscribe to mods via Steam workshop rather than manually install them.
Asset Editor: Unable to exit to menu
The following mods are known to cause this:
  • Help Button Remover
  • Traffic Manager (may have been fixed since time of writing this)
You can either disable them before using asset editor, or unsubscribe them.

Note to mod authors: Check LoadMode or AppMode[www.skylineswiki.com] before initialising your mod if you want to prevent it from being used in asset editor.
Game crash/hang on exit
Nvidia graphics card?

Turn off FXAA in the Nvidia control panel.

Too many assets?

If you've installed lots of assets from the workshop, that will sometimes cause crash on exit.

You can quickly test by using the --noWorkshop Launch Parameter temporarily disable all assets.

See also the Performance Tuning Guide which has some other suggestions regarding workshop assets.
Appendix A: Launch Parameters
This section has been moved to a separate guide: Launch Parameters Guide

(sorry if you scrolled all the way down here to find it)
Appendix B: System requirements
The game is CPU and Graphics intensive, you must meet at least the minimum hardware requirements for it to run. Also, you must be using a 64-bit operating system for the game to run.

Note: Just because you can run other similar games, for example Cities in Motion, Sim City 4, or Cities XL, doesn't mean that Cities:Skylines will run. You have to check the requirements.

You can see a list of system requirements at the following links:

Tip: If you are a Windows user, you can use System Requirements Lab[www.systemrequirementslab.com] to find out if your hardware can run the game.
Appendix C: Log file locations
See Log files (output_log.txt or Player.log).

Some additional information on log files can be found in the Unity documentation[docs.unity3d.com].
Appendix D: Other Support Resources
If this guide has not solved your problem, please let us know by posting a comment below and we'll try and find a solution for you.

There are also several other places were you can get help:

Appendix E: Save Game Folders
Tip: Deleting unwanted save games will make the game load faster!

Windows:

C:\Users\<username>\AppData\Local\Colossal Order\Cities_Skylines\Saves

Mac:

Macintosh HD/Users/<username>/Library/Application Support/Colossal Order/Cities_Skylines/Saves

GNU/Linux:

~/.local/share/Colossal Order/Cities_Skylines/Saves/

Steam Cloud

Note: If you're using Traffic Manager mod, do not save to Steam Cloud as it breaks timed traffic lights.

Go to the Library tab in Steam, and right-click the game name. Go to the Local Files tab and select "Browse Local Files". Look for the following folder (the <steamid> is a big long number):

\userdata\<steamid>\255710\remote
Appendix F: Reinstalling Cities:Skylines
Before doing a reinstall, Refresh your Steam files and see if that solves the problem.

For Windows Users:
  • Remove the game from Steam (delete local content)
  • Delete all these files and folders:
    • ...\Steam\steamapps\common\Cities_Skylines\
    • ...\Steam\userdata\<SteamID>\255710\
    • ...\Users\<UserName>\Documents\Colossal Order\Cities_Skylines
    • Note: For these last two, move their /saves/ folders elsewhere first to keep your save games...
    • ...\AppData\Local\Colossal Order\Cities_Skylines
    • ...\AppData\Roaming\Colossal Order\Cities_Skylines
  • ...then reinstall the game via Steam.

For Mac Users:

?

For GNU/Linux Users:

?
Problem not solved?
Post a comment below and we'll try and find a solution :)
.
< >
103 Comments
michaelyu49 Jul 5 @ 9:55pm 
Some modded buildings pop up way too often, is it solvable?
Rick May 15 @ 10:00am 
I'm having a similair problem like this one below me, I played a modded city and the first few days it just works fine, but after 4/5 days it just freezes halfway the loading screen and won't load, I've waited an hour but it still doesn't work.
HOMERO CHINO Apr 19 @ 7:34pm 
Hi: i installed cities skylines recently it runs perfectly. I installed some mods (this list specifically https://steamcommunity.com/sharedfiles/filedetails/?id=672783307) . It stills run, but days after, the game crashes while i charge mi city. The loading bar gets to the middle and the game starts to crash every 5 seconds, and after 3/4 minutes, cities.exe stops working. I uninstall the mods, the problem stills, i reinstall the game, the problem stills, what can i do? Sorry for my english, but it help me a lot if you give me a solution, thank you by the way!
ferdinand_halaszik Apr 12 @ 8:54am 
Hello, I'm experiencing problem and I would be grateful for some advice.

prntscr.com/j4d0e0

prntscr.com/j4d2u3

I can't delete this trees and lamp posts.
I was trying to fix with unsubscribing all mods but trees stayed and it's impossible to delete with bulldozer. Savegames containing the same problem.
Is it possible to remove somehow?
Thanks!
Sebby Mar 26 @ 10:47pm 
Hi i get the Object reference not set to an instance of an object error whenever i try to place a pump station including vanilla ones. I downloaded a custom one to see if that would work and it still happens.

I tried the reset config method and it doesn't error on a no mods game but I don't know what could be causing this?
PUFFPUFFPUFF Mar 3 @ 11:15pm 
All my mods are up to date, I have removed all the others, but there is still a blue screen, cannot get rid of it. Has the game updated? Haven't played in a long time :)
ChloeLeeFairlamb121 Feb 7 @ 7:14am 
game will not load, have tried uninstalling and reinstalling but nothing works. please help
Rupert Feb 6 @ 12:27pm 
my content manager for assets is blank and mods page only has default mods in, i have done all the steps above and have even re-installed, this has made the problem worse as before the reinstall the assets page was not blank and it said on the right hand side of main menu running the amount i am subscribed to but now it just says out of 5 (the default mods) i have also recently unsubscribed from some mods and assets as this was crashing my game. thanks
MAXiThOz Jan 21 @ 11:12am 
virtual alloc error need help
facundobernardini Jan 12 @ 3:26pm 
hello, i have a problem, i was playing this game in an other computer of mine, now a have new one, in my old pc i started to play and i saved the map in steam cloud, now i downloaded the game in my new computer but my older map didn´t appear, WHAT CAN I DO?
thx