STAR WARS™: Knights of the Old Republic™

STAR WARS™: Knights of the Old Republic™

425 ratings
[How-To] KotOR on modern systems (incl. Widescreen)
By Syn
I'm showing you a step by step approach on how to get this game running on modern systems.
Step 1: Accessing the Main Menu
Step 2: Being able to play the game
Step 3: Playing the game in Widescreen
Some extra advise

This How-To may or may NOT help you, it is just an approach to solving various problems and not the be-all and end-all solution you might be looking for. I am very sorry, but I can't do more than that. Maybe some users in the comments can come up (or already came up) with something that might just fulfill your exact needs.
 
Rate  
Favorite
Favorited
Unfavorite
Step 1: Accessing the Main Menu
  • Go to your steam library and right click on "Star Wars: Knights of the Old Republic". Select "Properties" and now uncheck "Enable the Steam Overlay while in-game".
  • Go to your installation folder ....\Steam\SteamApps\common\swkotor. Your steam folder is most likely to be found in C:\Program Files (x86) for 64-Bit systems or in C:\Program Files if you are using a 32-Bit system. Right click on the swkotor.exe and select "Properties".
    Now select the "Compatibility" row and check "Run this program as an administrator" as well as "Run this program in compatibility mode for:" Windows XP (Service Pack 2).
  • In the swkotor folder you can find the "movies" folder. In it you can find the biologo.bik and the leclogo.bik, these are the bioware and lucas arts intros. Delete them or rename the extensions (e.g. biologo.bik.backup). I also recommend deleting/renaming the legal.bik (pretty much just a picture of this guy[img4.wikia.nocookie.net]). This will save you some time whenever you start the game later on, as does getting rid of the useless Intros.
  • You should be able to start the game and see the Main Menu now.
Step 2: Being able to play the game
  • Don't mess around with the options just yet. Start a game and create a quick testing character. If the game loads and crashes right afterwards, and that is most likely to happen, start the game again and go into the options menu. You can change the resolution, Anti-Aliasing and Anisotropic filtering to your liking. You should also check VSync. Do uncheck Frame Buffer Effects, this is VERY important, and try starting a new game again.
  • The movie should run and the tutorial should load afterwards as well.
Step 3: Playing the game in Widescreen
  • Go to flawlesswidescreen .org and download the x64 Installer Package or the x86 Installer Package for 64-Bit operating systems or 32-Bit (x86) ones. Install and just ignore the First-Time-Setup after you started the program, everything's fine as it is. Now click on "Available Plugins" on the left hand side and after that look for "Star Wars: KOTOR" and select it. Needed files are being downloaded now. Click on "Star Wars: KOTOR" again (you can see that it's under "Installed Plugins" now with an icon) and pick your resolution now (right under "custom movies resolution"). Flawlesswidescreen must be running in the background whenever you play the game.
  • The first time you start playing with flawlesswidescreen you have to change the resolution in-game after the inject worked. Watch the status window and you can see if it worked when the bottom line says something like that right before the game starts:
    (HUD) Input Width=xxxx, Input Height=xxx, Left=0, Top=0, Width=xxxx, Height=xxxx
    x just stands for some resolution numbers you have chosen before.

    In general I can advise you to start the game normally, minimize it (alt+tab) and start flawlesswidescreen afterwards. Now switch back into the game and quit. You can start it again and it most likely will inject properly from the get go. Otherwise just rinse and repeat, it can sometimes be a real pain and take multiple tries.
  • You can enjoy the game now =)
Some extra advise
1. Save often and in a lot of slots. The game can crash while saving, corrupting the file. This will most likely happen while you Quicksave, so never rely on this save alone. Keep your Autosave on. This game may also crash during gameplay, though this should be very rare.
2. If your game crashes after using the Star Map you most likely have problems with the takeoff and landing movies. Go to your "movies" folder again and delete/rename the following: everything from 05_2a down to 05_8e (13 files) as well as LIVE_1a and LIVE_1c.
I also had problems with the Sith Fighter movies: 07_01 up to 07_04 (4 files) and 11a plus 11b. You may also work on the Hyperjump movie: 08
Those movies are not imporant at all, so don't feel like you miss something. But if you really wanna see them, you can download "RAD Video Tools" and watch the Bink videos right from the "movies" folder.
3. If you encounter problems with you character not moving make sure to check VSync, that helped in my case.
4. If you can't see a lot of grass on Dantooine and the lower half of your character becomes invisible standing in it. Just go to options and uncheck grass visibility.
5. If you can't really detect the Sith Fighters in the Turret Mini Game because everything is pretty much black, you can try to uncheck the Shadows option, that may help. I never really bothered and just played the game looking at the mini map, it's doable but a little nuisance for sure.
< >
126 Comments
[3pp] Unbroken Jun 1 @ 2:09pm 
I've done everything covered and nothing helps me
Count_of_Acadia Jan 28 @ 2:54pm 
Did what you said in the first step, now I launch the game, the cursor shows up before crashing back to my desktop.
Kat Jan 12 @ 3:49pm 
FOR THOSE WITH ISSUES: YES YOU, WHO KEEPS GETTING A BLACK SCREEN WHEN TRYING TO CHANGE RESOLUTION.

Download the 32bit version and not the 64 one even if you have a 64bit OS. I was getting black screen issues with the 64bit version. THE 64 BIT VERSION IS BUGGED. The 32 version works perfectly. Enjoy all!
jakethegreatwhite Dec 4, 2018 @ 2:23pm 
Game runs but i get a black screen when i try to change the settings
Niechcacy Nov 24, 2018 @ 12:26pm 
well, game runs but mouse doesn't work. You see the effect on the cursor that clucking is working but no effects to the game. No idea how to solve it.... any ideas?
Avibhrama Nov 23, 2018 @ 7:10am 
I tried the flawless widescreen but it keeps giving me error message "MSCRVP not found.". Similar problem when I tried to use KSE.

I've been updating my Microsoft Redistributable and direct X but still not solved.

And why my Steam copy giving me stretched resolution? I played GOG version of this and it give me unstretched 4:3 ratio eventhough there 're blank screen at the sides. At least I want to know how to turn it that way if a real widescreen is impossible.
Molly Sep 30, 2018 @ 6:50pm 
and all this applies in SWKOTOR 2?
Molly Sep 30, 2018 @ 6:46pm 
Finally, after YEARS, yes, YEARS without being able to play this game for the "DIVERSE" problems that I generated, thanks to this guide I was able to play it, although, I had to translate it from English to Spanish, but the good google resolved me quickly that . Thanks for this guide, now I will be able to enjoy THIS amazing game one more time! :Hand_Shake:
MollieLane Sep 24, 2018 @ 12:58pm 
Followed CittrussI's instructions *and* some of yours (disabled movies in properties/no steam overlay). No more crashing every 10 seconds and now I get to revisit one of my favorite games of all time. Thanks you two.
garamond.jeremy Sep 23, 2018 @ 11:34am 
nothing to do it doesn't work on widescreen =(