Aliens: Colonial Marines

Aliens: Colonial Marines

199 ratings
How to fix the "neverending" relaunch of A:CM
By Kasugano
For some people A:CM relaunches every time you quit the game... there are many tips to "fix" this, but they either don't or just temporarily fix the problem.

You can use my already compiled executable or make your own using my source code, thats up to you.
 
Rate  
Favorite
Favorited
Unfavorite
Source code
I created a repository on github, so you can review the source code there:

https://github.com/vedikasugano/acmsteam-fix
How to fix it.
  1. Make sure you check the integrity of the game files.

  2. Download the latest release from this link[github.com].

  3. Open the folder where the ACM.exe is located: Normally, this folder is "Aliens Colonial Marines\Binaries\Win32".

  4. Rename the existing "ACM.exe" to "_ACM.exe".

  5. Put the downloaded/compiled ACM.exe into this folder, now you have ACM.exe and _ACM.exe in the same folder.

  6. This is what looks like when you're finished:


  7. There is no need to check "compatibility mode" nor "run as administrator" for both files.

  8. Enjoy.
Final thoughts.
  • You need to reapply this fix again if you need to recheck the game integrity, because STEAM will download the original "ACM.exe" again.

  • Use it until GearBox releases a patch. If they're going to release one...
< >
83 Comments
AyleidRuin 15 hours ago 
Thank you for the Fix, Kasugano:Letter_N: Works fine:steamhappy:
Mephy ¦ Recovering skunk Oct 19 @ 4:55am 
Does it still work? I get a green status for a few seconds before it goes back to blue and not launch the game after the splash screen. And if I don't use the .exe, it gives me the infite restarting loop.

I have Windows 10.
Slicarus Sep 26 @ 2:31pm 
Thanks.
Eckard Aug 21 @ 8:16pm 
I'll take the bait, late though I am. racdavies, if you look to the upper right, you'll see some letters and numbers.
Posted
Updated
Sep 2, 2014 @ 3:25pm
Aug 23, 2015 @ 9:49am

Crazy how that works, eh? You're wrong. I just couldn't leave well enough alone and let you walk away without both knowing you're wrong, and being called out for it.

To Kasugano, thanks for the fix. I don't have any mods, not yet, and I've had this problem since my first launch. Thank you.
Xaptor Aug 5 @ 5:08pm 
Yeah, I don't have any mods at all, and the damn thing has been doing this since I first got it. Thanks for the fix. It worked. ^^
xmlWUT Aug 3 @ 1:21pm 
"Easier just to alt tab and restart computer." - Dude, seriously?
No mod here and issue since always. I always tried to close the Steam's "launch" small window before it actually launched the game, but I'll definitely try this.
Thanks in advance.
racdavies Jul 17 @ 4:04pm 
When did you create this guide.
Kasugano  [author] Jul 17 @ 3:46pm 
@racdavies This guide/workaround never stated that everyone have this problem. It says in the description: "For some people" ... and yet, you still come here saying you dont need, what the point?
racdavies Jul 17 @ 3:21pm 
Ok....but like i said i didnt have this issue before the mod so there was nothing to fix.
Kasugano  [author] Jul 17 @ 7:23am 
@racdavies My workaround came long before the Templar's mod.