RimWorld

RimWorld

2,950 ratings
Quality Colors
7
3
12
11
3
2
3
   
Award
Favorite
Favorited
Unfavorite
Mod, 1.2, 1.3, 1.4
File Size
Posted
Updated
317.909 KB
Mar 9, 2021 @ 7:40pm
Feb 12, 2023 @ 12:50pm
20 Change Notes ( view )

Subscribe to download
Quality Colors

In 1 collection by legodude17
legodude17's RimWorld Mods
24 items
Description
Super simple mod, just colors items based on quality. Currently works on:
- Trade window
- Caravan packing window
- Quality labels on the ground
- Inspect pane (Bottom left window when you select something)

Features settings, allowing you to change the color to your hearts desire!

Also features the following presets:
- Legacy (Featured in Preview, the first colors the mod used)
- Default (New and improved colors)
- WoW (Rarity colors used in World of Warcraft)
- Colorblind (My best attempt at colorblindness-friendly colors)
- Final Fantasy 14 (Contributed by Erin)

Should be compatible with everything.

Credits:
- legodude17: Code
- Doom: Idea
- Erin: FF14 Colors
- SY1102: Chinese traditional translation
- Dimos: German translation
Popular Discussions View All (7)
1
1
May 28 @ 2:24am
Guilde on how to added v1.5 tag to the mod.
nhatanh0475
4
Jul 8, 2021 @ 12:11am
FPS drop with the mod
JSTM
3
Jun 4, 2022 @ 8:51am
Bug With RimHUD After Update
dgambino1
257 Comments
Yackle9 May 2 @ 1:46pm 
@nhatanh0475 thank you for the assistance.
nhatanh0475 Apr 24 @ 7:10am 
If this mod still work perfectly fine, let me help you added v1.5 tag.
[h1] How to added V1.5 tag[/h1]
Step 1: Go to mod file. If you using Steam like here, go to SteamLibrary folder where you store the game SteamLibrary>Steamapps>workshop>Content>294100(This is game id)>2420141361 (This is the mod id in the url)>About>About.xml (Open with Notepad or Wordpad or Notepad++ will do). You will see like bellow

<ModMetaData>
<name>Quality Colors</name>
<author>legodude17</author>
<url></url>
<description>Colors the items in the trade window based on quality.</description>
<packageId>legodude17.qualcolor</packageId>
<supportedVersions>
<li>1.2</li>
<li>1.3</li>
<li>1.4</li>
</supportedVersions>
Adding another line right below 1.4 for 1.5 and you are set. Happy editting
nhatanh0475 Apr 24 @ 5:47am 
@igniscryo Thanks you. I knew how to change the version in the setting file. Just have to try to find my old dicussion forum.
wi9390 Apr 21 @ 11:10am 
Plz update!1.5
Pride Kitty Apr 19 @ 9:01pm 
I hope this mod becomes core
Kingdark Apr 19 @ 11:57am 
This does seem to be something that would make the game just that bit much better.
MC_0 Apr 18 @ 5:12pm 
This mod should go core lol.:steamhappy:
Igniscryo Apr 15 @ 11:54am 
This mod works perfectly fine in 1.5! Just need to ignore (or change) the version number.