The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

Not enough ratings
Better Spellbreaker
   
Award
Favorite
Favorited
Unfavorite
Category: Armor
File Size
Posted
0.001 MB
Feb 13, 2014 @ 8:24pm
1 Change Note ( view )

Subscribe to download
Better Spellbreaker

Description
This is a simple shield mod for the Spellbreaker because I think it should have had a better enchantment. This mod changes the enchantment so that it blocks 100 points of magic damage instead of 50. The armor rating changes from 38 to 45 and the value changes from 250 to 500 gold.

Please subscribe and rate! If you have any problems tell me. Enjoy!




Also, my picture may say different then what I said, that's because I changed the default settings of the armor and value, with perks it may differ.
< >
11 Comments
Californian'99 May 4, 2017 @ 9:03pm 
but not enough, i need more block magic to 100 point. still enemy can break throught shield with fireball spell :(
pigwing Mar 21, 2016 @ 9:33am 
Oh, and 'improving' the shield at the workbench reduces it's damage protection an additional 10 pts, and it's value as well
pigwing Mar 21, 2016 @ 9:30am 
So, not only did uninstalling not change the resist magicka stat (remains at one) but with the reinstall the shield *lost* 11 pts of damage resistance, and about 50% of value.
Any Ideas?
pigwing Mar 20, 2016 @ 5:35pm 
Just realized that it only has a resist value of 1, I now understand why she staggers so from such small damage. I'm about to uninstall and reinstall mod & I'll let you know result
raindance maggie  [author] Feb 25, 2014 @ 3:18am 
oh
WishSeeker Feb 24, 2014 @ 10:17pm 
sorry meant re do on the enchant @@
raindance maggie  [author] Feb 24, 2014 @ 3:26am 
there is no remodel
WishSeeker Feb 23, 2014 @ 12:02pm 
will test it out and get back to you with results :) am liking the re model you did for it
raindance maggie  [author] Feb 23, 2014 @ 5:27am 
not sure i don't see why it wouldn't
WishSeeker Feb 23, 2014 @ 12:20am 
i have a mod subbed that makes the shield light over heavy armor, was wondering if this would cause a conflict with your mod?