Cities: Skylines

Cities: Skylines

2,970 ratings
Picker
8
4
33
24
2
4
6
2
2
   
Award
Favorite
Favorited
Unfavorite
Mod
File Size
Posted
Updated
0.313 MB
Jul 20, 2020 @ 9:40am
Sep 29 @ 3:38pm
31 Change Notes ( view )

Subscribe to download
Picker

Description
Compatible with Cities Skylines 1.15.0 (P&P Update)
[www.buymeacoffee.com]

With Picker, you can choose any object placed on the map to open its construction menu and select it, ready to place again. Also known as a pipette or an eye-dropper tool.

New in version 1.6.8: Added support for upcoming mod.

Usage
To activate Picker tool, click on the icon or press T.

To pick an object, left-click or press Enter when it is highlighted.

To cancel, press Escape, T or right-click.

Control+Click on an object to place more instances of it without opening any menus. This can be inverted in Options, so no menu will open unless you Control+Click.

The keyboard shortcut can be modified in Options. The icon can be moved with hold-right-click and drag.

Mod Integration (Optional)
- Find It! or Find It! 2: Props, decals, growable buildings and Ploppable RICO buildings will open Find It. Without either Find It, these objects can not be picked.

- Fine Road Tool (version 1 or 2): The mode (ground/elevated/etc) will be set to match a picked segment. This can be disabled in Options, or Shift+Click to do the opposite (don't set elevation mode, or if disabled in Options, do set elevation mode).

- Move It: Press the Picker key (default: T) to immediately pick whatever object (including PO!) is being hovered in Move It. Please note, the invert functions (Shift+Click and Control+Click) are not available in Move It integration, only whatever is set in Options.

- Network Skins 2: Will be automatically set so any newly placed roads/track/etc have the same decorations as the picked segment.

- Extended Managers Library: Picker works with unlimited props.

How is Picker different to Move It's copying?

When copying in Move It you can place copies of selected objects anywhere on the map, for free. Picker is simply a tool to quickly load a selected object in the game's normal construction menus, ready to place with the usual game positioning and price. This means that Picker does not allow you to do anything that you can't do in the basic, vanilla game - it is just a time saver.

Compatibility
Does not use the detour technique for maximum compatibility.

Does not alter game save files in any way and can be disabled/removed safely at any time.

Not compatible with Building Eyedropper Tool as it does the same thing but for every type of object, and uses the same key. Net Picker is no longer needed as Picker is a continuation of that mod.

Also
Thanks to my beta testers for their testing and suggestions. Icon and workshop graphics by James Chapman[www.twitch.tv], video by Leader of the Monkeys[www.twitch.tv]. Thanks to sway for Find It 2 integration. Thanks to Elektrix for creating Net Picker, on which is mod is based.

Translations by:
Chamëleon TBN, acc[www.twitch.tv], Almi, Armesto, Benjamin Crewz, Deeheks, fgds, Frostbite[www.twitch.tv], gatomo, Geze, Hyposim, Jitaenow, kjmci, KoXz, Klyte45, macsergey, Modocero, 네인 | neinnew, nihShin, Othercakes, Pablo Martín, Palm'sTime, Raistlin46, Ryuichi Kaminogi, shg166, 我家是个大鱼缸 (Slicky), stabby bird, Svis, たこうま (Takouma), Tchelow[tchelow.com], Vinicius, Zarrix

Source code: GitHub[github.com]

[www.patreon.com]
[www.paypal.me]
< >
223 Comments
J/S2046 Sep 24 @ 6:47pm 
is there going to be an update? thks.
Jonut Sep 21 @ 2:57pm 
FYI everyone having issues with picker grabbing the 'wrong' item - unsubbing and resubbing seems to fix the issue. To be clear, I disabled the mod in content management, unsubbed, resubbed, activated the mod again, then continue game. No issues now - hope it helps!
scruffybeardy Sep 17 @ 4:26pm 
Hello Quboid, this mod works well for me but i think the integrated Unified UI settings is kinda have some bugs? because i can't put it back inside UUI
VNDK8R Sep 16 @ 7:53am 
Having issues also. Pick a road, get a random building.
GuilhermeAlcântara Sep 15 @ 11:11pm 
Same Happened to me
mothermatriarch Sep 15 @ 7:09pm 
I got a popup saying "Picker was installed incorrectly. Please try reinstalling."

It was working just fine, but I exited the game to remove some incompatible mods(unrelated to picker), then opened the game again and got the popup.

I don't know if it was the mod itself or C:S just being janky but I wanted to mention it here anyway.
Akyhne Sep 15 @ 6:40am 
About a 500 I would guess. My save games loads around a thousand, but I also own several content creator packs (buildings).
Trees? Not many. 20-30. I'm not the big of a decorator.

I only ever used your mod in the last week. I has worked flawless. 3 mods were broken, due to the update. One - Find It! had to be removed, the two others, there were alternatives, based on the originals, as fixed mods.

Mind you, I only tried playing the game for half an hour, after the update. The issue might be with other things, like roads. I'll tell you, if that's the case.

And thanks for a quick response, very appreciated!
Quboid  [author] Sep 14 @ 5:16pm 
@Akyhne - Thanks for the report. How many assets do you have, and how many of them are trees?
Akyhne Sep 14 @ 4:42pm 
After the latest C:S update, the picker mod picks the wrong tree. It also highlights the wrong selected tree of what you tried to pick.
So if you want to clone tree A, it picks tree B, and highlights tree C.
sway Aug 26 @ 9:49am 
@Votolom
There was a bug in Find It 2 that could lead to the issue you mentioned. The latest update of Find It 2 (2.8.4) has fixed this issue.