Sid Meier's Civilization V

Sid Meier's Civilization V

235 ratings
UI - EditUnitNames
   
Award
Favorite
Favorited
Unfavorite
Tags: Other
File Size
Posted
0.011 MB
Nov 28, 2013 @ 10:32pm
1 Change Note ( view )

Subscribe to download
UI - EditUnitNames

Description
Right-click a unit's name to edit it at any time - not just after a promotion.
Uses UnitPanel.lua - not compatible with any other mods that modify that file.
To get this functionality with other Unit Panel mods, insert the following into the mod's UnitPanel.lua:

Finally updated for Brave New World
I just got BNW and quickly ported the old mod (UI - EditUnitNames 3) - seems to be working fine, but I haven't had a whole lot of time to test it. Let me know how it does.

BNW version of the mod - for other versions look for
UI - EditUnitNames Vanilla
Vanilla Version
UI - EditUnitNames 3
GnK Version

function OnUnitNameRClicked()
-- rename this unit

if UI.GetHeadSelectedUnit() then
local popupInfo = {
Type = ButtonPopupTypes.BUTTONPOPUP_RENAME_UNIT,
Data1 = UI.GetHeadSelectedUnit():GetID(),
Data2 = -1,
Data3 = -1,
Option1 = false,
Option2 = false;
}
Events.SerialEventGameMessagePopup(popupInfo);
end
end
Controls.UnitNameButton:RegisterCallback( Mouse.eRClick, OnUnitNameRClicked );
< >
77 Comments
Inlogica Mar 22 @ 3:28pm 
EDIT*

Just copied your lines into the LUA from the other mod and now it works like a charm. Now i feel stupid and apologise for asking this question. Awesome work and thank you for sharing your mod with us!
Inlogica Mar 22 @ 2:49pm 
a very nice mod indeed but there are conflict issues when using alongside "all promotion tooltip" or something similar. Is it possible to make them work together somehow? Any kind of feedback on that matter would be appreciated.
Bruins Mar 12, 2020 @ 4:04pm 
you are THE man lol.!:clowney:
fwmmog1 Aug 25, 2019 @ 4:51pm 
Doesn't work for me. Tells me that it's "blocked due to exclucivity". What the heck is that?
voxelblast Nov 21, 2018 @ 8:51am 
I tried right clicking on the name and pretty much everywhere else, but nothing worked. I have all the DLC installed if that helps.
Crashlionhart Nov 10, 2017 @ 1:32pm 
Right clicked on the name, picture, icon. Nothing works
Octopus Jul 4, 2017 @ 9:01pm 
Does not appear in mod list after subscribing
vondraco Jun 4, 2017 @ 12:11am 
@jehuxtable - Click on the NAME of the unit, not the picture. If that's what you ARE doing, apologizes, no idea why it's not working for you. I use dozens of mods and this one works just fine for Me.
DiktatrSquid Apr 11, 2016 @ 5:39am 
I subscribed, but nothing appears on my list, nor in my MODS-folder. I have BNW.
jehuxtable Nov 28, 2014 @ 6:10pm 
Doesn't do it for me......Right clicks only get me the civilopedia

I see the above text in
C:\Users\xxx\Documents\My Games\Sid Meier's Civilization 5\MODS\UI - EditUnitNames (v 1)

Only DLC active is BNW, this is the only mod activated.