Natural Selection 2

Natural Selection 2

74 ratings
Fastload Main Menu
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
1.124 MB
Oct 14, 2013 @ 3:07pm
Dec 19, 2013 @ 7:25pm
8 Change Notes ( view )

Subscribe to download
Fastload Main Menu

Subscribed
Unsubscribe
Description
This simple mod replaces the main menu with a static ns2_eclipse background, which the game will load into very fast. Good for slower computers, or those who want speedy menu swapping performance.

- FPS in graphics menu won't be accurate since FPS is rendered so fast
- Removed ugly grid lines

View my other backgrounds (Added biodome, tram, and veil):

http://steamcommunity.com/id/aeroripper/myworkshopfiles/?appid=4920

< >
35 Comments
aeroripper  [author] Feb 14, 2016 @ 5:47pm 
A NS2 update a while ago broke this. I'll set aside some time hopefully soon to get this fixed. I still prefer a static image to the current in-game menu, even after it was trimmed down :)
HKO2006 Feb 13, 2016 @ 9:29am 
still works in 2016?
aeroripper  [author] Sep 3, 2014 @ 1:13am 
This is working fine with NS2+ again (just checked again). Make sure you don't have any other mods enabled that could be conflicting (2 different menu mods running at same time, etc...)
RPZX | jentak358 Sep 2, 2014 @ 9:28am 
Ok after, quite a waiting for some miracle and trying all possible solutions, I still have a black screen :(. Last resort will be to completely uninstall the game and delete all leftover files then install again... let us see what will happen.
aeroripper  [author] Aug 17, 2014 @ 7:44pm 
Mendasp fixed the error with NS2+ ^^
CЯaZyCAT Aug 8, 2014 @ 3:42am 
There is a conflict with NS2+ mod. Background becomes dark. Can you fix that?
aeroripper  [author] Jul 6, 2014 @ 12:16pm 
1) Right click on 'Natural Selection 2' in your game list
2) Click 'View Community Hub'
3) Click the 'Workshop' tab
4) On the right side, under Your Items, click 'Subscribed Items'
5) Unsubscribe from all mods (including mine)
6) Go to Users\username\AppData\Roaming\Natural Selection 2\Workshop
7) Delete all the folders inside that workshop folder
8) Start up NS2

If it's still not starting up, something else is wrong with NS2 and your individual system. Maybe video drivers or something.
RPZX | jentak358 Jul 6, 2014 @ 12:15pm 
Actually now I have remembered that i have subscribed for "Xenoswarm" mod too, so maybe that is the reason. Can you tell me please how can I solve that issue, thank you. BTW I did unsubscribed from both the mods, but it did not help :(.
RPZX | jentak358 Jul 6, 2014 @ 12:05pm 
I have bought the game two weeks ago and it was working ok. I do not remember installing another mod, but just to be sure I will try anything what you wold suggest, so where is that mod menu? Also do not forget I cannot boot the game properly, all I see is black screen and the Windows white/default mouse, then I have to force shut down with windows task manager the NS.exe.
aeroripper  [author] Jul 6, 2014 @ 11:33am 
I would try disabling all your other mods in the mod menu except for mine in the mod menu. I imagine one of them is conflicting.