Arma 3
526 ratings
Simplex Support Services
5
2
3
3
   
Award
Favorite
Favorited
Unfavorite
Data Type: Mod
File Size
Posted
Updated
1.402 MB
Aug 31, 2019 @ 12:23am
Mar 25 @ 12:04pm
10 Change Notes ( view )

Subscribe to download
Simplex Support Services

Description
INFO
CURRENT VERSION: 0.3.2.2

Simplex Support Services is a fully automated, on-call support service system. Created out of the frustration of needing to pre-configure AI and manage the potential of getting Arma'd, SSS is designed to make AI supports reliable and easy to use.

Github: https://github.com/SceptreOfficial/Simplex-Support-Services

For usage instructions, please see the wiki[github.com].

The mod is still under development, with many features yet to be implemented and bugs still to be found.
Feel free to submit issues or suggest any new features via the issue tracker[github.com].

Known Issues:
- AI drivers (land transport) may not start moving immediately (sometimes even after several minutes). This is a BI issue with AI pathing. Waypoints <200m seem to work better.
- Sometimes artillery won't fire on target. BI fault with vanilla artillery commands.
- Sometimes AI helicopter pilots don't land where they're requested. I've done my best to counteract this and make it as uncommon as possible.
- Remote controlling a drone while already remote controlling a gunship will get you stuck in remote control. Respawning should get you un-stuck.

FAQs
Q: Where does the mod need to be loaded?
A: Server-side and client-side.

Q: Is this compatible with X vehicle mod?
A: Should be. Let me know if it isn't.

Q: Can you make a version without ACE?
A: It's possible, but not a priority right now. The project is open source and any contributions are welcome!

Q: Why does this remove ACE FRIES from helicopters?
A: The AI sees it as an external object and tries to avoid it. It makes using AI pilots a hassle.

Q: Your fastroping method isn't as cool as X.
A: I know.

LICENSE
This project is licensed under the GNU General Public License (GPLv2[github.com]).

THANKS
Reidond[github.com] for his code contributions.
Special thanks to the play-testers of the dev version.
Everyone that has helped test and report issues, and everyone else that has contributed and sent ideas.

More Mods
Check out other mods I've worked on here on the workshop and other projects on github: https://github.com/SceptreOfficial?tab=repositories

Popular Discussions View All (3)
88
Nov 22 @ 10:27am
PINNED: OFFICIAL: Bugs, Feature Requests, and Questions
Sceptre
< >
800 Comments
ajwubbin Nov 22 @ 12:04pm 
Unguided bombs consistently fall short using CAS planes. I don't expect them to be laser accurate, but the pipper when you're flying the plane understands wind resistance, why don't the AI pilots?
Sceptre  [author] Nov 20 @ 2:35pm 
MCC is always causing issues.
I do not recommend.
Sgt.CoffeePot Nov 20 @ 11:36am 
Very strange. I suspected the mission or something placed in the mission to possibly be the cause. I made a new mission only placing a unit and the support modules. Everything worked fine and that was with the additional mods. I noticed that after logging as admin and restarting the mission a few times, the supports eventually started to work. I'll keep trying to find which mod is being problematic. MCC is kinda sus, I've always had issues with it.
Sceptre  [author] Nov 19 @ 8:06pm 
Equipment/faction related stuff should be fine. Focus on stuff that adds mechanics or functional changes. Some missions (liberation/hearts and minds) are known to cause issues with modules not initializing as well.
Sgt.CoffeePot Nov 19 @ 6:22pm 
I've tried it without any additional mods and everything worked fine. I guess the hard part is just finding out which of the many mods is causing trouble. The group I play with use plenty mods ( around 50+) but most are just for equipment, sounds and zeus enhancements.
Sceptre  [author] Nov 19 @ 4:12pm 
If you can narrow it down to what's causing the issue, I can try to help.
Sceptre  [author] Nov 19 @ 4:11pm 
Did you test with only the required mods and no extra scripts? Can't troubleshoot when other stuff can be conflicting.
Sgt.CoffeePot Nov 19 @ 9:41am 
Supports are not showing on my dedicated server, yet they seem to work perfectly fine in the editor. I can use zeus to manually create the supports but that is not ideal as I would have to do that every time the mission starts. Any suggestions?
[ST6] Korda Nov 17 @ 4:01pm 
@PS1 Hagrid @Sceptre When I rename the gunship module for the USAF MOD AC-130 spooky it does not appear in multi on dedicated? I see the crew in free fall. And in SP it works without worries. Do you have an idea for this problem? (Sorry for my english via translator)
Sceptre  [author] Nov 13 @ 12:46pm 
Videos are outdated. Follow wiki instructions.