The Elder Scrolls V: Skyrim

The Elder Scrolls V: Skyrim

79 ratings
Chronoweaver's Coil
File Size
3.180 MB
Mar 18, 2012 @ 8:30am
Mar 20, 2012 @ 7:03pm
4 Change Notes ( view )

Subscribe to download
Chronoweaver's Coil

This Mod adds a ring into the game that allows the wearer to slow and speed up time at will! You can launch an arrow, and run right by it as it flys through space. Or you can speed up time and enjoy the world as everyone breezes by you. It is a great tool for videos and such. It is also fantastic for faffing about and watching arrows fly about at 1/100 the time scale. It is just a fun overall toy to play with.

To obtain the ring, head to Riverwood and meet a strange Orc outside the Inn. Kill or speak to him.

To stop the time effects, unequip the ring or set time scale to default (you will still be slowed however, so you probably should still unequip ;) )

Updated to 1.1: Fixes quest not starting for some.

What it does specifically:

alters the Global Time Multiplier, slowing or speeding it at will. Can be great for videos or for screwing around.

Known issues:

Menu for functions pops up twice on the first use. I don't know why, get used to it. It is only on the first equip.

You can't wait with it on.

If you play a kill animation camera with it equpped, your player will speed up 1000x normal speed. Just unequip it.


Nexus Link :
< >
Dat Newb Dec 3, 2016 @ 2:43pm 
Could you upload this to for consoles?
A Bloody Spy! May 27, 2016 @ 2:48pm 
needs to be a race
Cifer Null Mar 30, 2016 @ 6:23am 
I second DerpyCakeMan, that would be great.

Also a slight bug I sometimes encounter is while using spells during slow time.
Sometimes the spell charges up normally, but occasionally the charging never finishes and so no spells can be cast, except channeled ones. This seems to occur at random.
Derpy Dec 31, 2015 @ 5:17am 
Just a suggestion is to add attack speed and movement speed according to the time scale you picked so you are normall while every one is slower
TheMadGunner Oct 17, 2015 @ 11:11am 
Reminds me of bullet time from Sniper Elite V2/3
somebody touch`e da queen May 19, 2015 @ 12:03pm 
i can`t get it, he isen`t in riverwood at all. And i have doubble checked that the file is downloaded
Rockglop Apr 21, 2015 @ 8:17pm 
To the creator of this mod, "If you liked it then you should've put a ring on it". You clearly liked this mod, so where the hell is the ring.
TTPowell Jan 20, 2015 @ 11:54am 
I really like this mod. It isn't working anymore. The orc isn't carrying it dead or alive. I tried the player.additem 05000d65 1 and it says Compiled script not saved! I unsubcribed and deleted it then re subscribed and found it back on the file list. Still not working. Please fix. Thank you.
Bilbino Dec 21, 2014 @ 6:07pm 
Well i found the right orc, but first of all, he was wasn't by the inn. Also, when i spoke to him, it didn't let me go into a conversation with him, and when i killed him he had no ring. I've tried almost everything, fix please, if you can.
bforrester24 Dec 21, 2014 @ 5:26pm 
try 05000d65
player.additem 05000d65 1