Age of Wonders III

Age of Wonders III

Not enough ratings
Weapon Re-size PBEM Patch
   
Award
Favorite
Favorited
Unfavorite
File Size
Posted
4.580 MB
Nov 3, 2018 @ 1:28pm
1 Change Note ( view )
You need DLC to use this item.

Subscribe to download
Weapon Re-size PBEM Patch

Description
This mod re-sizes weapons to be more proportional. Some differences are huge, like the Longswordsmen or Orc Spearmen, other more subtle, like human Archers or Frostling Raiders. Some, I could only do so much with, due to the grotesque comical proportions.

This is a patch for the PBEM & Single player balance mod, main branch
< >
4 Comments
pipo.p Nov 4, 2018 @ 10:02am 
I understand the problem: it's really a patch to an existing mod. I thought there was a chance that you need internal names only and not the very mod's name (at the risk of unwanted effects in case the player doesn't load the expected-but-not-explicitly-required mod). Let's cheer this patch for the main branch, then. Thank you very much for all of its users.
Goldfinch  [author] Nov 4, 2018 @ 7:46am 
I think it would be possible to play with the newer version, but I'm not sure. Any updates to the main branch version should not be a problem, unless the name of the mod is internally changed in the package manager.

The main reason these requirements are there, is because AoW3 won't let you mod an imported project, you can only link to that project's resources. Without that link, this mod would overwrite any stats changes. It's really annoying, I know, but seems to be the only way to make patches to other mods.
pipo.p Nov 4, 2018 @ 7:26am 
I mean that you could assume that all the knowledge you've collected so far (in-game references?) is enough for your patch to run safely with any newer version of the mod. Is this reasonable to think so?
pipo.p Nov 4, 2018 @ 7:23am 
Hello, good new!
I quickly tested with T1 Orcish units and the expected improvements are here.

Although making explicit mod requirements is safer and the normal way to go, in case of PBEM & SP balance mod, I wonder if you could be less strict about those requirements. Racial Patch is now integrated into the mod, and this mod's component won't change until the stand alone patch is changed itself. However, PBEM & SP balance mod is due to change several times more, and you'll have to update your mod each time a new main branch is out (am I correct?). This is without saying that your mod is curently unplayable with the beta version.
Would it be then possible to just indicate in the changelog which version of PBEM & SP balance mod your patch is optimized (tested) for? And let the players use it with any newer versions of PBEM & SP balance mod?