Atari Vault

Atari Vault

Not enough ratings
Easter Egg room in Atari Vault's Adventure -- as mentioned in "Ready Player One" [SPOILERS]
By IceHippo
How to find the "Easter Egg" room in Adventure. If you read "Ready Player One", this is the world's first hidden room in a video game.
   
Award
Favorite
Favorited
Unfavorite
Intro
Most people who played Adventure on the Atari 2600 are aware of the secret room. The publication of "Ready Player One" has introduced this to a new generation of gamers. With the Steam release of Atari Vault, there's a chance that there might be gamers who do not even realize it exists or why it is a key part of video game history. Either way, this is a simple guide to finding it. Assumes you know the basics of the game. Needless to say, spoilers ahead!
Pixel Hunting!
The key to the secret room is a light gray 1 pixel x 1 pixel item (sometimes called the "dot", "pixel", or "speck") that is always located in the Upper Catacombs (e.g. the area within the Black Castle that is lit by torchlight). You need to play on the "Large Kingdom" setting to have it exist in the game world.

To get to the dot, you need to open the Black Castle and have the bridge with you.


Go into the Black Castle, past the room with red walls, and into the Upper Catacombs.


There is a narrow passageway at the top of the first room in the Upper Catacombs, just to the left of top-center. The room you need to go to is directly to the left of the first room. However, to get there you need to take a winding path through the top of the first room and the room above it (if you have the bridge you could take shortcuts, but I'm keeping it simple here).

The path through the winding area is UP-DOWN-UP-DOWN. Then head left into the pixel room. The pixel is in an enclosed chamber just to the left of bottom-center in its room. The only way into this chamber is with the bridge. In the catacombs, your torch will flash if there are two or more items in a room. You know you're in the room with the pixel when you see the flashing.
(Make sure you have sound on for this next bit) Move down and left to get to the lower center of the flashing room. Go through the bridge to enter the small chamber and poke around the bottom-right corner. The pixel is against the wall of the chamber. What makes this part difficult is the pixel is the same color as the walls, so you can't see it.

As you move around, listen for the "pick up item" sound effect. Once you hear it, you know you've got the pixel. Carefully make your way back through the bridge. Don't touch the bridge, because you will drop the pixel and pick up for the bridge (again, listen for the "pick up" sound). Leave the Black Castle and head for the corridor below the Gold Castle.
Assemble the items, open the wall
You'll also need the magnet and sword to open the wall. There are other possible combinations of item, but this seems the easiest. But first you should find a safe location for the pixel.

What do you do with a tiny, near-invisible item? It's the same light gray as the background for almost the whole game world. I prefer to park it along the outside of the Gold Castle, where it is both out of the way and visible against the castle (click on the picture to the left to zoom). You could also get the other items before the pixel, but I prefer to get the pixel first. If you do this, make sure to leave the pixel right against the wall as shown, like the wall has a small bite taken out of it. Otherwise you might need the bridge to revrieve it.


There are three rooms with green walls that form a corridor below the Gold Castle. At either end of the corridor is a thin black wall.


This black wall changes color depending on the color of items in the same room. Move the magnet and sword to the room on the far right of the corridor. Get the pixel and move it there too. Again, I like putting the pixel against one of the walls so that it is visible.

At this point the wall will flash black-gold, and you can move through it. Move to the right until you reach the wall. You will find that as the wall flashes, you will be able to move through it. Do that and keep moving to the right to enter the Easter Egg room.






Final thoughts on the secret room
The secret room has the name of the game's creater[en.wikipedia.org] (Warren Robinett), and this is considered to be the origin of the term "Easter Egg"[en.wikipedia.org]. There are a few other things you can try with the pixel and other combination with different objects in the secret room, should you want to investigate. Regardless, I'm grateful that Mr Robinett had the guts to do this without telling Atari.

Thank you for a game well done, and thanks especially for inspiration for many more Easter Eggs over the years!
< >
5 Comments
dorian_rpg Feb 4 @ 10:44pm 
going to be honest, I've known how to do this since the early 80's a few things though, first, the main reason to use multiple items is simply because the Bat is a jerk, he can and will steal anything he can. if you have at least 3 items it doesn't matter what he steals because whatever he replaces it with will do the trick. also, you can actually take other items into the room (it's tricky but fun to try) and the bat cannot enter this room to steal them.
InvisibleMR_DADAS Apr 19, 2020 @ 2:06am 
yhehehehehehheheheheheehehehehheh\
IceHippo  [author] Oct 18, 2018 @ 5:22pm 
Been trying this out again, and I found that single items can work, but only if you enter from the main corridor to the left of the secret wall. If you enter from the bottom passageway that connects with the catacombs below the green corridor, then it won't work. Here's the order I used:
1. start with no items in the room with the secret wall
2. drop the pixel in this room
3. Start with the white key near the gold castle area
4. Move it to the right through the green corridor and into the secret wall area
> The secret wall turns gray and opens

but

3. Start with the white key in the catacombs near the white castle
4. move it up and into the room with secret wall
> The secret wall turns white and doesn't open

What makes this even weirder is that sometimes (<5%) if I follow the top set of instructions, the wall turns white instead of gray.

IceHippo  [author] May 15, 2018 @ 4:34am 
Thank you SilentBoy741! It never occured to me to try items like the dragon bodies with the wall. Will definitely check this out. I've noticed that the order of adding items sometimes makes a difference too.
SilentBoy741 May 15, 2018 @ 12:06am 
When I first read of Mr. Robinett's Easter egg some 20 years ago, the consensus was that you had to make the wall flash by piling up items after dropping the dot. Since I've had some time to mess around with it, I've found that you can do it using just one item, if it's the right one.

Any item that makes the wall turn gray (invisible) after you've placed the dot will let you into the secret room. After you've put the dot in position, drop the item onto the barrier wall. Don't carry it into the secret room, or you might get trapped in there!

Single items that worked for me:
The gold key
The black key
The white key
The sword
The body of the Green dragon

That last one was accidental. I had the sword next to the wall when the bat swooped in and stole it and dropped the Green dragon. It still worked, but I haven't the patience to try to get the bat to do it with the other dragons.

By the way, great guide!