Audiosurf 2

Audiosurf 2

Not enough ratings
S3RG Glowing Remastered
 
Rate  
Favorite
Favorited
Unfavorite
Tags: Skin
File Size
Posted
Updated
12.064 MB
Jan 30 @ 10:12pm
Apr 17 @ 7:43pm
3 Change Notes ( view )

Subscribe to download
S3RG Glowing Remastered

Subscribed
Unsubscribe
Description
something i missed? bugs? feel free to comment them!
< >
18 Comments
irvin Jul 12 @ 10:41am 
nice
TBX-SRK9F Jul 9 @ 10:28pm 
I would love to see motion blur (link below to .lua / skin i'm reffering to for blur), colorful wakes, color to be more in-your-face rainbow stuff, and just want my eyes to puke rainbows for the entire duration of a song. thanks! I mean, not like they do now, but I'd like it to be more obvious.
WeldonWalker Apr 19 @ 4:19pm 
Thank you so much for taking the time to fix it! :D
Sergalicious  [author] Apr 17 @ 7:43pm 
IMPORTANT NEW UPDATE-- the skin actually works now... finally.
TBX-SRK9F Feb 23 @ 8:45pm 
An unexpected character is near string 786, check it out please! ^^ would love it if i could play it.
Sergalicious  [author] Feb 22 @ 10:12pm 
@WeldonWalker, thanks alot for the info. Good to know!
WeldonWalker Feb 22 @ 9:24pm 
Hi, @Sergalicious, I think this is what corrupted your lua script:

local laneDividers = skinvars["lanedividers"]
for i=1,#laneDividers do

The local variables ( specifically in AS2 skin lua ) are kind of unstable, if you have more than one of the same "local" in your script ( in this case you had two "laneDividers" ), it will corrupt the entire script and you have to start a new one, in another word rebuild the skin.

Not an expert here, but I had the same problem when creating my skin, simply remove the other "local" doesn't help, re-work is probably the only way to go. Sorry you had to experience this :(

Side note: If you want two CreateRail() to use the same "local" variable, put them into one "local" like this:

local shoulderLines = skinvars["shoulderlines"]
for i=1,#shoulderLines do
CreateRail{ -- lane line
something
}
CreateRail{ -- lane line
something
}
}
end
Ixoithaas ( voxel.gg ) Feb 11 @ 6:38am 
I bet you could find another skin creator (that uses Lua code for their skins) and ask them for some help. - (Not everyone on the Internet is an ass :P )
Sergalicious  [author] Feb 10 @ 11:59am 
well, maybe someday ill rebuild it. maybe it something simple but i cannot find the error causing it not to load. ive removed almost every bit of code except for the default needed code that i havent modified much. still get the same error, just in a different place. welp, if i dont find a fix within a few days ill remove this from the workshop untill i fix it.