RimWorld

RimWorld

206 ratings
Parallel Power Grid (Parallel Conduits)
2
   
Award
Favorite
Favorited
Unfavorite
Mod, 1.0, 1.1, 1.2, 1.3
File Size
Posted
Updated
0.706 MB
Jan 21, 2018 @ 5:38pm
Apr 20 @ 2:02am
34 Change Notes ( view )

Subscribe to download
Parallel Power Grid (Parallel Conduits)

Description
Parallel Power Grid (Parallel Conduits)

Description:
This allows you to use multiple layer of conduits on the same tile.

Additional Info
This mod adds Parallel Conduits in Red and Blue. I had planned a green conduit but I was kind of lacking space on the tile to make it reasonably visible.

these conduits don't allow devices to directly connect to them (consider them underground and out of reach), but link up to a Parallel Conduit Sockets instead.

A Parallel Conduit Socket is your bridge linking all conduit layers together (including normal conduits or power grid).

Power can go both ways, so it can draw from or charge up batteries if there is a lack/surplus of power.

Power will go directly to the sockets on the grid that power is required to go to, and will split between the sockets on the grid there.

[ko-fi.com]

Credit
TheWireLord for Power Conduit Deconstruction Mod[ludeon.com]
Acker for the Chinese translation
Proxyer for the Japanese translation
Popular Discussions View All (9)
89
Feb 24, 2020 @ 4:58pm
BUG thread
Twilight
3
Jan 18, 2019 @ 11:42am
PINNED: Test Build
Supes
2
Feb 25, 2020 @ 12:25am
Bug with 1.0
Jean-Cassio
< >
172 Comments
EvolvingCode Apr 12 @ 6:55pm 
It seems that placing a colored socket on another colored socket crashes the game, Could a Fix be in order for this?
ttr Apr 10 @ 3:20am 
... and it still works;)
Supes  [author] Apr 9 @ 6:53pm 
I do still maintain this mod
EvolvingCode Apr 6 @ 9:13pm 
Is this still being updated? This is brilliant!
ttr Sep 13, 2021 @ 10:33am 
Tested with Your mod only
https://steamcommunity.com/sharedfiles/filedetails/?id=2601236102
As you can see, middle green socket is selected and shows 0/0 while geo-thermal is working (bottom line is powered). Also battery on right is not charging.
tried to use "regenerate network" button but no luck there.
ttr Sep 13, 2021 @ 10:24am 
@supes,
Looks like Your current update (13th sep) is broken - none of parallel grids do transfer power
all wires show that power are 0/0, and socket are only isolated to what is directly connected to them.
ttr Sep 8, 2021 @ 1:54pm 
ok, did some testing.
If device is connected to socket is behave as described (flickers on grid construct/deconstruct and is powered off on game load). If it's connected to vanilla conduit (even one tile from socket) it works fine in both situations.
ttr Sep 8, 2021 @ 10:51am 
@supes. any chance to disable network re-creation on each cable is build? If i"m doing big rebuild, all my base is flickering. I would not mind to hit button "rebuild grid network" in some options when I'm done.

Second, but not sure if this is vanilla game or mod - on load of game, whole base is un-powered and takes some time (even 2 in game hours) to all devices get power back.
Any help will be appreciated.
ttr Aug 18, 2021 @ 5:21am 
@Wolfie, Your light is connected to dead battery in corner - if light was constructed before socket it will not update it's connection to socket - reconnect (H) or if option not available, reconstruct/move light. on left side, that 'printer' have exactly same issue.
Proxyer Aug 17, 2021 @ 5:00pm 
Hello, author Supes. Thank you for 1.3update!
So, I update the Japanese translation for this mod. Please download from the link below and confirm and merge. Thank you.

File name : 13_ParallelPowerGrid_JPKit.zip
Download Link : Google Drive [drive.google.com]