XCOM 2
125 ratings
WOTC Suppression Visualization Fix
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
0.218 MB
Sep 8, 2017 @ 1:44pm
Oct 6, 2017 @ 2:41pm
3 Change Notes ( view )
You need DLC to use this item.

Subscribe to download
WOTC Suppression Visualization Fix

Subscribed
Unsubscribe
In 1 collection by kregano
Kregano's Mods
14 items
Description
NOTE: This is now integrated into the WOTC Community Highlander. If you use it, DO NOT use this mod.

Designed to allow guns without Suppression animations to run Suppression. This only affects the Suppression visualization, not the actual ability or the X2Effect.

Known Bugs
Sidearms and Pistols with Suppression will not fire. Instead, Primary weapons will execute a Suppression animation. This seems to be a WOTC error, since I've seen screencaps of other pistol abilities causing the same thing.

Special thanks to Maluco Marinero for showing me how to improve this fix.

If you like this, try out some of my other mods:
-WOTC: Ranger and Grenadier Rebalanced - Get Implacable and Suppression as a Squaddie abilities, then an AOE Suppression ability on Grenadiers and a detection radius reduction for Rangers at higher ranks.
-Exclude Same Class Skills - avoid rolling your base game class' own skills in the XCOM skill tree.
-Rapid Fire Reverted - gets rid of the unmentioned cooldown on the WOTC version of Rapid Fire.
-Pistols Rebalanced - feel pistols are too weak to be of value? Try this out! Has experimental support for Primary Pistols.
-Crysis 2 Music - Listen to the epic score with the Music Modding System. Compatible with vanilla XCOM 2 and WOTC.
-Suppression Weapons - get Suppression on base game, DLC/WOTC, and some mod guns.
< >
30 Comments
Jukse Aug 2, 2018 @ 7:03pm 
Hey, Kregano! First of all, thanks for this mod - this already saved my hide enough by making Suppression usable at all.

I was wondering if, by any chance, are there any plans to update the similar Area Suppression Visualization Fix by Reality Machina to WotC now that the LW Perks have been ported over.

The issue seems to be same - weapons added via RFA mod, for instance, will not (visually) fire when using LW2WotC_AreaSuppression. Using the non-WotC version results on a CTD upon launch.

Once again, thanks for all the great stuff!
kregano  [author] Dec 29, 2017 @ 7:30am 
@RaptorBroccoli: the folder name should be 1130825409 .
RaptorBroccoli Dec 25, 2017 @ 10:29pm 
Can someone give me the file name in the workshop folder? I unsubbed and deactivated the mod, but I don't think it deleted it out of my workshop
pauloel7 Dec 15, 2017 @ 9:52am 
Cool, thanks!
kregano  [author] Dec 15, 2017 @ 9:45am 
I checked the Mac Community Highlander's upload date, and based on when it was uploaded, it should have this fix built into it.
pauloel7 Dec 13, 2017 @ 5:33pm 
X2WOTCCommunityHighlander (MacOS/Linux)
kregano  [author] Dec 13, 2017 @ 4:50pm 
Don't know what the MAC highlander is, so I can't speak to compatibility.
pauloel7 Dec 12, 2017 @ 8:50pm 
BTW, how does one knows whether a fix has been integrated into highlander yet? I am running lots of fixes with MAC highlander and am not sure how to check that. Thanks!
pauloel7 Dec 12, 2017 @ 7:04pm 
Pardon my asking: is this integrated into the MAC highlander as well?
pvp.........is...........despair Dec 12, 2017 @ 6:39am 
i also downloaded lots of mods and when i tried launching it kept saying the same crash msg and then i tried removing the mods i thought wer the cause,when i finally have the remaining mods i used bfore the lots of mods downloaded it stil giving the same bullcrap only by deselecting all the wotc mods was i able 2 launch the game,i xit selected my usual mods and it gave me the same shit so i finally decided 2 uninstal and then installing it again if this doesnt work goodbye wotc 4 the rest of my life!