XCOM 2
1,138 ratings
Evac All - WotC
 
Rate  
Favorite
Favorited
Unfavorite
File Size
Posted
Updated
0.595 MB
Sep 2, 2017 @ 10:06am
Sep 10, 2017 @ 5:43pm
4 Change Notes ( view )
You need DLC to use this item.

Subscribe to download
Evac All - WotC

Subscribed
Unsubscribe
Description

This version of Evac All is for the War of the Chosen expansion only. Please use the original Evac All mod for the original XCOM2.

If you are subscribed to both mods, make sure you only have the correct version of this mod activated for the game you are playing, not both of them.

Translations for the new config page requested. See the topic here: http://steamcommunity.com/workshop/filedetails/discussion/1126395106/1474221865200290492/



Description

This mod adds an "Evac All" ability to soldier ability bars when they are in an active evac zone. Clicking this button will evac all soldiers currently in the evac zone instead of needing to click the evac button on each individual soldier.

Soldiers not in the evac zone will remain, exactly as before - this mod doesn't add any gameplay change, it's purely an interface change.

Many thanks to the volunteers providing translations for this mod:

esurnir, Lord Yanaek - French
Jack Kwan - Traditional Chinese
Albeoris - Russian
Josemsar, jazzlutty - Spanish
Hamachi - Korean
almasmario - Italian
acosys, Marck - German
Kubak1000 - Polish
nobita - Japanese
♥♥♥♥182 - Simplified Chinese (Sorry, steam doesn't like your name :) )

This mod is also availble through nexusmods at: http://nexusmods.com/xcom2/mods/99

Configuration

This mod supports the Mod Config Menu for in-game configuration, if installed. Otherwise configuration options can be found in the XComEvacAll_WotC_Defaults.ini file in the mod's config folder.

Compatibility

This mod is compatible with existing saves, but will not take effect until the next time you begin a mission after installing the mod. Loading a saved game in-mission from before the installation will work, but no Evac All ability will appear until the next mission.

Popular Discussions View All (1)
7
Nov 29, 2017 @ 3:12pm
PINNED: MCM Translations Requested
tracktwo
< >
248 Comments
batteran Jun 18 @ 2:29pm 
Simple, awesome, thanks.
tmonahan23 Jun 14 @ 7:37pm 
Thanks, ill take a look at !
tracktwo  [author] Jun 14 @ 7:34pm 
@tmonahan23 see just a few comments down where Stormchaser had a similar problem due to having some mods installed that are not WotC compatible. Could be the same issue.
tmonahan23 Jun 14 @ 7:02pm 
The evac all icon isn't showing up but it shows up in the modconfig options? Is there another mod that might conflict with this or a certain file type that might cause this issue to happen?
Stormchaser May 28 @ 9:31am 
Just evacced all out of the blacksite mission! Everything works perfectly.
tracktwo  [author] May 27 @ 12:29pm 
Awesome, glad you figured it out. You should be able to use evac all now with existing campaigns too, but the ability is added to soldiers at mission start so it won't appear on any tactical mission already in progress. But on starting a new mission in an existing campaign they *should* appear... although I have no idea if there is any permanent effect from existing campaigns with those mods that would interfere with that.
Stormchaser May 27 @ 1:14am 
@tracktwo: Okay, so Gotcha was actually totally fine. The conflicting mods were:

Insanity Mind Control Duration Fix (as figured out by you)
Fortress Includes Frost Immunity
Fixed Sniper Hotkeys
Remove Rage Shaking Cam

The common thread? They're all mods by Advent Avenger. I think they were also all originally made for the base game, although at least Fortress is supposed to work with WotC too, if not more.

Without these mods loaded EvacAll shows up using X2DebugRuleset. Thank you for the tip to use that command! It would have been very hard to work out without it. I'll start my new campaign and hopefully when the time comes I'll be presented with the option to EvacAll. :)
Stormchaser May 26 @ 11:22pm 
@tracktwo: Gotcha in my build is modified by the peek from concealment UI fix, so it could be that... I'll do some more testing. I had previously tried removing chunks of mods to isolate the cause, but not yet with a fresh campaign each time. I'll let you know when I find the conflict so that it's documented for anybody else who might come across it. Thanks again for checking this out!
tracktwo  [author] May 26 @ 2:32pm 
@Stormchaser: Looks like that isn't the only one either, I tried your full modlist with just that one removed and it still didn't have the ability in a new campaign. The weird thing is it seems to be related to gotcha again, but evac all and gotcha are known to work together (I used both myself). So my only guess is that some other mod is intefereing with gotcha in some way that is also breaking evac all.

At any rate, I don't believe this is a bug in evac all, you may have other mods in your modlist that are also not wotc compatible and are causing other mods to malfunction. Your best bet may be to try removing chunks of mods to narrow down which one(s) are causing trouble, that's how I identified the MC fix mod. I just start a fresh campaign and check X2DebugRuleset to see if there are EvacAll abilities on the starting units.

If you do sort out which one(s) are the trouble, or if you find out there really is a bug here in evac all please let me know.
tracktwo  [author] May 26 @ 1:36pm 
@Stormchaser: I tracked it down, the problem is the "Insanity Mind Control Duration Fix" mod. I checked that mod's workshop page the author says it's not WotC compatible. Apparently it also can break overwatch all, which makes sense.