Showing 1-20 of 104 entries
May 23 @ 12:44am
In topic Buff Johnny?
I'm quite happy with his playstyle (even though he could use an overhead other then the universals) but his crushing blows, those i really can't get behind, man has less crushings then some other characters and most of them are horroble, getting a new crushing blow or at least increasing the damage on the ones he has would be a great thing for him
If you are not into gore then it would be best for you to stay away from this one, maybe try it out Injustice 2, the graphics are just as good and there is little to no gore, you can customize the characters and play against your brother on local versus and the story is really good, if you want this game because it`s new and there are a bunch of people playing online, you can go for a Dragon Ball Fighter Z or maybe Tekken 7 or even Street Fighter 5, i`m not really sure since i don`t play those games but a lot of people talk about them, so i believe there are lots of players that go for the online mode, but i really think you should sit this one out, there are still dlc`s to come and things will probably get more brutal.
May 6 @ 2:24pm
In topic Johnny Cage Announcer!
Has anyone figured how to unlock it? Or we think this is a dlc? Any ideas?

https://www.youtube.com/watch?v=0I6X0UmvwoE
May 5 @ 11:15am
In topic Shang Tsung?
Any predictions on when he will release? I know the game has been out for 2 weeks, but it's fun to speculate right?
May 4 @ 7:55pm
In topic WTF we can increase fatal blow damages
Originally posted by 【AQUILA】:
https://www.youtube.com/watch?v=-9VfFcayMr8
It's hard to do but it works, i just did 345 damages with Noob Saibot instead of 320
Yeah, don`t know about MK X but this was quite popular in Injustice 2, i thought people knew this was included in MK 11, at least those who played Injustice 2 i believe knew about it
Originally posted by kheyli:
everytime I launch the game I get this following error:
https://imgur.com/4EtitbX
I've tried editing the setting in appdata to turn off the gaymer lighting settings to no effect, tried to reinstall visual C++ Redistributable 2015 - the most current one available to no effect, tried creating a new windows user to no effect. Im kinda lost on what else to try to get it to run, I just wanna play the game I bought so any help is appreciated.

also no response from WB games either yet.
Hey man, i was having this issue since launch, manage to fix this yesterday here`s how i fixed (SORRY FOR CAPS BUT THIS IS SO YOU KNOW THAT I DON`T KNOW IF THIS WILL FIX IT FOR YOU AND I DON`T RECOMMEND DOING THIS UNLESS YOU ARE SURE YOU ARE GONNA GET VIDEO AFTER DOING THIS, I WAS LUCKY THAT I KNEW WHAT TO CHOOSE CAUSE I DID IT BEFORE TO GET MY SECOND MONITOR UP AND RUNNING) with that out of the way. I use 2 monitors but one of them is a VGA and my GPU does not support that, so in order to get 2 monitors running i had to change this option in my BIOS (click on the link to see) my pc was only booting image trough my GPU, and in order to get the second one i had to change the option for the first boot to be done by my motherboard (where the VGA monitor was plugged) i did and never worried about this, until yesterday when i saw a discussion here about booting the game on safemode, and for some reason i remembered about all this, so i went on my BIOS and changed back to what it was when i had only one monitor up, and after changing that the game opened no error at all, but if i want to use my second monitor i have to turn it on on my BIOS again, and yes i tested turning it on again and trying running the game and got the error, so for me that`s the problem, to do that i went on my BIOS> Advanced> Chipset> Internal Grapchics and changed to this one
https://uploaddeimagens.com.br/imagens/monitor_options-jpg
To get 2 monitors i have to change to the 4th option and the 3rd one is the one i use when i wanna play (AGAIN, DON`T RECOMMEND YOU DO IT IF YOU DON`T KNOW IF THIS WILL PREVENT YOUR MONITOR TO GIVE IMAGE, DO A RESEARCH ON THIS OPTIONS TO SEE HOW THEY WILL AFFECT YOU, JUST TELLING YOU WHAT FIXED FOR ME) I hope you find a way to get your game running bud, good luck
May 1 @ 2:33pm
In topic The recent update...
Originally posted by KripTed:
The only thing I can think of is that the old traces C++ are still there from previous installations.
DUDE, I CAN FINALLY RUN THE GAME YAY (sorry for caps, i`m just really excited)

I don`t know why i did this but i use 2 monitors so i tried turning the old one off on my BIOS, just leaving my new one active, and the game opened, no errors no nothing, just opened, thank you for all the support you`ve given me buddy, don`t know you irl but you sure gave me a lot of support this past few days, so thank you kind sir
Apr 30 @ 3:08pm
In topic The recent update...
Originally posted by KripTed:
Originally posted by Kaliin:
I`ll try the clean boot once i get home, and the packages i did download them from the microsoft page, didn`t change a thing

Well maybe you're missing some. I showed which one's I have so you can see. Maybe getitng the exact same one's I have might fix the problem. Chances are the game itself is broken.
Thank you again bud, once i get home i`ll try reinstalling them againm who knows what may work right? Thank you =)
Apr 30 @ 3:07pm
In topic The recent update...
Originally posted by ngoni615:
Originally posted by Kaliin:
What ticks me the most is, i know a few people that are playing a pirated version of the game, and they can run the game, while i`m here in this situation, it`s bs at this point
There is no pirate copy of this game lol are you insane? its definitly your pc not the game and please mention specs. I think the issue might be your cpu if you have an fx series chip
I believe there is, since one of my friends keep bugging me and sending me pics of him playing, and he doesn`t have the game nor he can afford, about the specs, i posted them early in here but here you go, 12GB RAM FX 8300 and GTX 1060 6GB, so yes i have an FX 8300 not the best by a long shot, but it should be able to run the game, one of my friends has a FX 6300 and is running fine for him, so i don`t believe that`s the case, unless it`s FX 8300 specific problem
Apr 30 @ 3:01pm
In topic The recent update...
Originally posted by KripTed:
Originally posted by Kaliin:
Here you go, that`s the message that it keeps showing
https://uploaddeimagens.com.br/imagens/mk_erro-png-6fbc113e-c843-4d1b-84ae-4dcf9e6bc6b7

I see.

Try putting your computer in a clean boot. See if that fixes it.

https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows

If not, then uninstall all the Microsoft Visual C++ Packages.

Try downloading these one's.

Direct download links:

Download Microsoft Visual C++ Redistributable 2015 (32bit)
http://download.microsoft.com/download/9/3/F/93...

Download Microsoft Visual C++ Redistributable 2015 (64bit)
http://download.microsoft.com/download/9/3/F/93...

If that does not work, install the 2017 version instead:
Download Microsoft Visual C++ Redistributable 2017 (32bit)
https://go.microsoft.com/fwlink/?LinkId=746571

Download Microsoft Visual C++ Redistributable 2017 (64bit)
https://go.microsoft.com/fwlink/?LinkId=746572

You can download other packages here:

https://support.microsoft.com/en-us/help/2661358/minimum-service-pack-levels-for-microsoft-vc-redistributable-packages

The one's installed in my PC are these one's.

https://imgur.com/a/D8WXLwa

Maybe installing the exact same one's I have might help.
I`ll try the clean boot once i get home, and the packages i did download them from the microsoft page, didn`t change a thing
Apr 30 @ 1:42pm
In topic The recent update...
Originally posted by KripTed:
Originally posted by Kaliin:
No luck W10 keep giving me the C++ Visual error, reinstalled all the packages, but still giving this one, so far people that are having this issue haven`t been able to find a fix for this, and there were no mentions of this weird bug when they talked about crashes, don`t think they found what`s causing this, i add a person who was having this problem a while ago, and the new patch did not fixed for him either

Does it give you more of an error? Like does it give you an actual code?
Here you go, that`s the message that it keeps showing
https://uploaddeimagens.com.br/imagens/mk_erro-png-6fbc113e-c843-4d1b-84ae-4dcf9e6bc6b7
Apr 30 @ 1:25pm
In topic The recent update...
Originally posted by KripTed:
Originally posted by Kaliin:
No luck bud, thank you for all the suggestions btw, didn`t work but at least you are trying to help, i`m updating to W10 for the third time to see if it`ll work there, my W7 just closes the game but W10 i get the C++ visual error, wanna see if anything changed after this patch since W7 for me doesn`t look like it will run, and again thank you for everything

Okay that's a start. Go to back Windows 10. If you're still getting a C++ Error, it's probably a Microsoft Visual C++ Package you need. You might have to just download it and it might just work after that. No problem man, I'm trying here. It's not guaranteed but like you said, least I'm trying I guess.
No luck W10 keep giving me the C++ Visual error, reinstalled all the packages, but still giving this one, so far people that are having this issue haven`t been able to find a fix for this, and there were no mentions of this weird bug when they talked about crashes, don`t think they found what`s causing this, i add a person who was having this problem a while ago, and the new patch did not fixed for him either
Apr 30 @ 1:21pm
In topic The recent update...
Originally posted by Crueler:
This probably won’t fix your issues, but I’ve known people with weird monitors that can’t open games on their default resolutions. They had to force windowed mode or use GeForce Experience to correct the settings.
I`ve tried that bud, didn`t work either.
Apr 30 @ 12:03pm
In topic The recent update...
Originally posted by cezar:
I never had any issue with the game since it's launched. If you have any issues please report them officially and don't whine here:

https://steamcommunity.com/app/976310/discussions/0/1681441347871883299/
I`m sorry if this will come out as rude, but that was actually the first thing me and OP tried, if you read the posts you`ll see that both of us did that, no answer so far on either of the 2 emails i`ve sended
Apr 30 @ 12:01pm
In topic The recent update...
Originally posted by KripTed:
Originally posted by Kaliin:
What ticks me the most is, i know a few people that are playing a pirated version of the game, and they can run the game, while i`m here in this situation, it`s bs at this point

Try what I said above. Maybe try this as well.

Start Task Manager. Load up the game. Go to details in Task Manager. Look for MK11.exe.

Right click it. Set Priority to High.

Another thing you can take a look at is the NVIDIA Control Panel. If you have an integrated graphics card, make sure you switch it to your dedicated GPU.

Right click your desktop. Click on NVIDIA Control Panel. Manage 3D Settings. Make sure "Preferred Graphics Processor" is selected to "High Performance NVIDIA Processor"

Go to Program settings. Select Mortal Kombat 11 from the drop list. Now below that, scroll down to "Power Management Mode" and change it to "Prefer Maximum Performance"

Also what Windows you running?
No luck bud, thank you for all the suggestions btw, didn`t work but at least you are trying to help, i`m updating to W10 for the third time to see if it`ll work there, my W7 just closes the game but W10 i get the C++ visual error, wanna see if anything changed after this patch since W7 for me doesn`t look like it will run, and again thank you for everything
Apr 30 @ 11:46am
In topic The recent update...
Originally posted by KripTed:
Originally posted by Kaliin:
Didn`t mentioned on the post but i tried that already, also tried running on compatibility, but to no avail

Have you tried Steam Launch options such as say running it in a different Direct X? Worth a shot. It's the -dxlevel one.

https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947
Just gave it a shot, still nothing, keep seeing the same thing on my library, Running then Syncing, game closes
Apr 30 @ 11:42am
In topic The recent update...
Originally posted by Hi, I'm Groot.:
Originally posted by Kaliin:
I give up already, over 2 hours of played time only on that Scorpion splash screen, i`ve been more than polite so far, but now, no official word if they even know about this crash, emailed them once my DXdiag like they asked and a second time explaining the problem and asking for advice, no luck getting even an answer, my graphic drivers are always updated, reinstalled my OS 2 times and nothing, this patch and the previous one didn`t helped at all, tried all the workarounds the community found from trying to turn it off the RGB lights to Controller settings, new profile with admin status and all, it just doesn`t work, i really don`t think it`s my spces since they are able to run Injustice 2 just fine with no issues with max graphics, one would think they would be able to run just as much, in case you ask.

GTX 1060 6GB
FX 8300
12GB RAM

Not perfect but more than enough to run this, now i have no idea when a patch to fix this will come out, no words at all, i`m tired, mad and angry and at this point i give up. Sorry for the long rant guys, i`m just pis sed and tired of being polite.

I know what you mean man, it is infuriating. There is nothing we can do and we paid good money for this, its not something i would expect from such a big company.
What ticks me the most is, i know a few people that are playing a pirated version of the game, and they can run the game, while i`m here in this situation, it`s bs at this point
Apr 30 @ 11:40am
In topic The recent update...
Originally posted by KripTed:
Originally posted by Kaliin:
I give up already, over 2 hours of played time only on that Scorpion splash screen, i`ve been more than polite so far, but now, no official word if they even know about this crash, emailed them once my DXdiag like they asked and a second time explaining the problem and asking for advice, no luck getting even an answer, my graphic drivers are always updated, reinstalled my OS 2 times and nothing, this patch and the previous one didn`t helped at all, tried all the workarounds the community found from trying to turn it off the RGB lights to Controller settings, new profile with admin status and all, it just doesn`t work, i really don`t think it`s my spces since they are able to run Injustice 2 just fine with no issues with max graphics, one would think they would be able to run just as much, in case you ask.

GTX 1060 6GB
FX 8300
12GB RAM

Not perfect but more than enough to run this, now i have no idea when a patch to fix this will come out, no words at all, i`m tired, mad and angry and at this point i give up. Sorry for the long rant guys, i`m just pis sed and tired of being polite.

Try running the game through Steam's folder. Try giving this a shot, it's basic and probably won't work but give it a try. Try running the game through Steam's folder and opening it up there and Run as administrator.
Didn`t mentioned on the post but i tried that already, also tried running on compatibility, but to no avail
Showing 1-20 of 104 entries