Showing 1-20 of 272 entries
Nov 8 @ 12:38pm
In topic End-game side boss help
Okay, thanks for your time. I hope you're enjoying your work on Another Star 2!
Nov 4 @ 7:00pm
In topic End-game side boss help
This thread is about Tomte Man. How are you supposed to beat this guy? He puts my party to sleep and then party wipes me by casting Gatremor over and over. If I somehow survive and wake up, it's back to sleep and back in the rock zone. His party seems to be impervious to sleep and to net. I'm not sure what I'm supposed to do.

I don't recall there ever having been any accessories that prevent sleep except for the headband that prevents all ailments in the dream world. That thing's expensive as heck anyways. Is having three of those the intended method to beat Tomte Man?

I beat the game without having beaten him or gotten the equipment he's guarding. I've beaten Neo Ankou, Mandragora, and Rainbow. Is there any other end-game or post-game content that merits having what Tomte Man is guarding?
May 8 @ 6:34am
In topic How to fix Himno on Linux (Guide)
Originally posted by XÆЯO_Vince:
I just downloaded and the game just worked. This bug seems to have been fixed. Probably can delete this thread now.
The bug might not manifest if you install the game on a case-insensitive file system like NTFS.
Apr 10 @ 8:10pm
In topic Linux?
Thanks for your honesty; Proton it is, then.
Apr 2 @ 8:15am
In topic Linux?
Well I appreciate your patience and compassion! :D
Apr 1 @ 2:44pm
In topic Linux?
> nobody is expecting you to buy before it's done

Actually, it's funny you say that. You may have noticed a lot of vaporware anxiety in regards to Linux ports, and it's in great part because we have repeatedly been burned by crowdfunding campaigns who did precisely that, and then either reneged on the promise of a Linux version, or just went radio silent about it, and then subsequently had the audacity to make *us* look like the bad guys when we were justifiably upset about it. Street Fighter V counts too. It's the most famous example of the bait-and-silence.

I don't feel like this is what you guys are trying to do. You've supported us with Megabyte Punch and the first Lethal League. I trust you, but I just wanted to chime in and explain why there might be some tension over this, and try to bring some sympathy in.
Jan 2 @ 12:06pm
In topic Linux?
There are eight reports, all very mixed. I was gifted this game before the promised Linux port, so I'm gonna give it a whirl later. https://www.protondb.com/app/553310
Jan 2 @ 12:05pm
In topic Linux?
We only have one report so far. It was submitted as Gold, but doesn't say what workarounds were necessary. https://www.protondb.com/app/565170
Nov 26, 2018 @ 11:08pm
In topic No controller support on linux?
Originally posted by Cheeseness:
something that's an upstream issue and beyond the developers' ability to control
Upstream as in not only nw.js, but further up: upstream as in Chromium. The HTML5 gamepad tester fails to see my gamepad in Chromium. Wish I knew what version it broke in so we could have clues toward fixing it.
Nov 16, 2018 @ 10:29pm
In topic Last Man
No Cristo Canyon or Marianne Velba DLC? Gosh darn it.
Nov 14, 2018 @ 6:34am
In topic SteamOS port ?
I heard that they don't have Denuvo because they can't afford it... but that's good for us; it'll make it easier for us to run it in Proton if they aren't able to swing a native port.
Oct 14, 2018 @ 10:04am
In topic Controller mappings incorrect under Linux
I switched the page that the nwjs_new branch loads to http://html5gamepad.com and it doesn't even work there. It does work in Firefox. But it doesn't work in Chromium!

So what I can conclude is this isn't something you guys have control over.

EDIT: I also mentioned MoltenGamepad in my old thread... well, I turned it off, and made my DualShock 4 visible to regular users. It works in other stuff, but it *still* doesn't work in html5gamepad, and *still* doesn't work in CrossCode.

Chromium broke this somehow between versions 50 and 66 (the versions reported by old and new branches), and has done nothing to fix it in 69 (the version in the repos). I'm on Xubuntu 18.04.1.

EDIT 2: Tried to run CrossCode's Windows version in Proton using Native2Proton, just for giggles. It doesn't work; it gets stuck on a white screen and does nothing.

I'm tired of debugging this, I'm gonna roll back to old and get on with playing the damn game.
Oct 13, 2018 @ 9:29pm
In topic Controller mappings incorrect under Linux
That's so curious; my controller doesn't work *at all* on nwjs_new.
Oct 7, 2018 @ 8:12pm
In topic A few minor issues on Linux.
The thing about processes sticking around on exit is because of the dialog box that pops up and then vanishes if you roll back to an old NW.js after trying a new one. You have to delete everything in $XDG_CONFIG_HOME/CrossCode except for the save files.

Crashes don't happen anymore on the old branch with Web Audio disabled.

The new branch still completely ignores my gamepad. Real nice of you to push out a "performance warning" with that still busted. I don't care how slow it runs, I'm not playing this game without my gamepad. You're not giving me any guidance to debug this so I have no other recourse.

Honestly, I'm more likely to play the new branch in Wine than I am to play it without the gamepad. Heck, I might actually even try it. If NW.js sucks on Linux, that's just what it is. We do have Proton now, after all.
Originally posted by popsUlfr the Linux Wolf:
A new version has been pushed, now after exiting the game the process still lives on in the background and the only way to kill it is with a kill -SIGKILL . Seriously annoying.
This happens because if you try out a new NW.js and then roll back to the old one, a little dialog box pops up right before the game starts complaining about profile incompatibility, but then the game starts and you can't ever dismiss the dialog box.

To fix it, you basically have to delete everything in $XDG_CONFIG_HOME/CrossCode except for your save files: Default/cc.sav*
Oct 4, 2018 @ 10:08am
In topic Linux?
The arcade cabinets run on a custom Linux variant, right? Why no Linux for the home release? That seems strange to me.
Sep 24, 2018 @ 10:35pm
In topic A few minor issues on Linux.
Effectively, an Xbox 360 controller. I use MoltenGamepad, which is kind of like Steam Input as a system-wide daemon. Real controllers get mapped to 4 virtual 360 pads that are always present. Every other game recognizes them fine, and the old branch recognizes them. The claim that the new branch is supposed to have *better* controller support just makes this all the more confounding.

I thought that this bug might be related: https://github.com/nwjs/nw.js/issues/6792 So I replaced NW.js with a nightly build, but that didn't let the gamepad work. There's no terminal output at all. I have no idea what to do to diagnose why the gamepad isn't working. I feel like it might be a NW.js issue but I have no idea how to verify that. Do you know of any free NW.js games I can use to test this?

I don't get crashing on exit in the new branch. It seems like it's faster, too. On the new branch, I can smoothly use pixel size 2 everywhere, but on the old branch I have to use pixel size 1 to avoid framerate drops in some areas.

I'm kind of torn as a customer who just wants to play in my preferred way, and a technologist who wants to help test, investigate, and fix the problems. As a customer, I'm gonna go through the game with my gamepad even if it means I have to use the old branch and endure its issues until they get worked out. As a technologist, you tell me what to do to test and fix the gamepad support in the new branch, and I'll do it.
Sep 24, 2018 @ 8:52am
In topic A few minor issues on Linux.
Originally posted by lachsen:
One thing I can recommend is trying to switch to the "nwjs_new" beta branch and test if this improves things.
I mentioned in the OP that this is a non-starter for me because controllers don't work on it. I mean, sure, I agree that it's a good idea since it could find what differs from the default branch in terms of performance, crashing, etc, but controller support is a very essential thing for me.
Sep 23, 2018 @ 10:38pm
In topic A few minor issues on Linux.
Okay, so I had another random crash in the middle of gameplay. Again, no crash report.

In addition to what I mentioned above, whenever I close the game or the game crashes, sometimes defunct processes will be left behind, and I'll have to do pkill -9 CrossCode to get rid of them. Regular SIGTERM does nothing to them. They also leave behind the singletons in the config directory.

The game isn't making any useful output to stdout or stderr either. However, I do record every game I play. Would videos of the game leading up to the crash be useful?
Sep 23, 2018 @ 9:43pm
In topic A few minor issues on Linux.
Hi there. Just got a few issues that I've noticed since the 1.0 release. I was an early adopter, and got about halfway through when the content ran out, so I decided I would take a rest and jump back in with 1.0 to get the full intended experience!

In the default branch, there is no Vsync. I am able to fix this by using a compositor.
I am also able to fix this by switching to the new branch, however controllers do not work in the new branch at all! This is pretty critical and makes using it a non-starter for me.

I don't know if this happens in the new branch too, but sometimes the nice-looking linear scaling filter will turn off and it'll be ugly nearest filtering. Eventually the linear filter comes back. There doesn't appear to be a user-accessible setting for this.

I had a crash when I talked to Carla in her room, but the game didn't put any crash reports in the crash reports folder (which I understand to be $XDG_CONFIG_HOME/CrossCode/Crash Reports).

Thanks for your time.
Showing 1-20 of 272 entries