Showing 1-20 of 42 entries
Jul 9 @ 8:39am
In topic ChangeLog
2019-07-09 - v1.8.377 - Deadlock fix
  • Added (another) possible fix for rare deadlock on startup, suspected to be related to when a Corsair Gaming Keyboard is attached
Jun 29 @ 7:10am
In topic Cant get passed the menu
Just a shot in the dark, but try editing the screen_resolution section in My Documents\AtomicTorchStudio\VoidExpanse\SettingsClient.xml?
Could not invite K^rM. Their friends list is full.

:fscared: I and another helped Deadmeat get the 4-player achievement last night, it's super quick if we're all online, so feel free to add me and I'll message ya if I see enough people online =).

I'm always up for helping people out getting the multiplayer achievements =). I still have 4 friendly people on my friends list from when we were trying to assemble 8 players (only need 4 now, I think), so it shouldn't be too hard to get them. Feel free to friend me!
Tried playing using a controller, but it breaks way too often to be a fun experience, or even playable at times.

Game-breaking issues (require keyboard/mouse):

When out of supplies, the starvation dialog would often pop up underneath another window (map, I think), and nothing would be focused. Absolutely no button on the controller would do anything other than Start, had to go into options, disable controller, click once to close the map, go back into options, re-enable controller. Was *really* frustrating. If the mouse was simply not disabled when the controller was enabled, that would have saved a ton of hassle when something goes wrong.

Can lose focus in character creation, I couldn't get back in there to see exactly where, but I think it was when choosing a background, if you pressed left one too many times, it's lose focus and couldn't get it back again without hitting RB/LB to go back/forward between pages to reset the current page or something.

When in dialogs (such as when talking to your officers), it says "LT to switch panels" on the bottom and (if one is visible) "LB/RB" to swap between pages (I want to look up if I have more Mirrors or Veils before choosing an option), but those buttons don't work - again I need to go into options, disable game pad, click the arrow to switch tabs, then go and re-enable gamepad.

I can't figure out any way to level up with controller - I see an up arrow on my character icon in the corner, but appears to be no way to select it. I didn't even realize I could level up on my first captain, since it was not an interactable element with the controller!

All the enable/disable wouldn't be so bad if it could be done with just a gamepad and a mouse, but requiring a gamepad, mouse, *and* keyboard (have to press Escape a few times) makes playing this on the couch or recliner really awkward.

Terrible experience issues (make me want to throw my controller at the screen, usually I just Alt-F4 instead):

Inconsistent dialogs - after a conversation/bit of text, it seems that half of the time I have to press A, half of the time I have to press B, with no indication of which.

To make it worse, if I sometimes press B in the wrong place, it exits back to sea, err, space, with the the Dock / Explore button prompts, and I have to go through lots of menus to get back to where I was. I seem to often press B thinking I'll go back any time I press Y to see the area list, and the focus is on the Stories sub-section - Up doesn't seem to go anywhere, just makes the cursor disappear (presumably actually focuses the already selected Stories, but should really focus Shops, as that's the only selectable thing up there), so I press B, hoping that'll bring me back a menu so I can select Shops, and then everything disappears. Alternatively, in this case, LB/RB could toggle the Stories/Shops tabs, like they do in other (identically styled) toggle switches in other dialogs.
I also seem to often press B when I press A to select a shop from the area list, it's not the one I want, so I press B, thinking I'll go back to where I was a split second earlier when I pressed A, but, nope, exit port, and then press 3-5 more button presses to get back to where I wanted to be.

More minor issue, but at stations (or probably any large dialog), the cursor moves to items that are off screen if there are more than 4 (have to manually scroll down with RS otherwise end up selecting something you can't even see).

The store page advertises "Full Controller Support", but this absolutely does not qualify. I have to use keyboard and mouse every 5-15 minutes or so, depending on how lucky I get. Get totally stuck when playing via Steam Link and a keyboard/mouse is needed.

I loved Sunless Seas and am glad I backed this one on Kickstarter, and would *love* to play it, but I think it's just too buggy to play with controller right now :(. Please fix!
Jun 12 @ 3:41pm
In topic ChangeLog
2019-06-12 - v1.8.376 - Deadlock fix
  • Added possible fix for rare deadlock on startup, suspected to be related to when a Corsair Gaming Keyboard is attached
May 26 @ 6:39am
In topic Won the Controller Lottery Achievement
Though there's little purpose (besides making testing easier), you can run multiple copies of Splody on one computer ;). Might have to run Splody.exe directly, and not through Steam, if Steam complains. I think there are also some "virtual joystick" programs that can add virtual joysticks (though I haven't tried that approach myself).
May 25 @ 10:19pm
In topic Won the Controller Lottery Achievement
I'm always willing to jump into large multiplayer games ^_^. The bot on the Discord channel is good for knowing when they're going on, however, it's been a while since there's been an 8+ player game. I've considered trying to organize a large once-a-month game on a specific day, but it's a bit difficult since most of the active players are in very different timezones than I am.

If you just want the achievement, there are cheesy ways to get it even with just one person. I'm also considering dropping the achievement down to fewer players, now that its harder to find active games - I certainly understand wanting to get all of the achievements =).
May 15 @ 6:38pm
In topic games like this ?
Recettear is similar (less clicker, slightly more RPG) and a fantastic game: https://store.steampowered.com/app/70400/Recettear_An_Item_Shops_Tale/
Because it was reduced to needing just 4 people, it's not *so* hard to get anymore. I can certainly help people get the achievement if there's a need =).
Apr 15 @ 8:53am
In topic ChangeLog
2019-04-15 - v1.8.375 - Extended character support
  • Add support for a large number of "letter-like characters" that exist in Unicode by mapping to characters found in the font (bug credit: "ʳᵒᵃᵈ₂ᶰᶸᶫᶫ", previously known as "���������")
Apr 3 @ 6:55pm
In topic Cannot complete tutorial
Looks like it's erroneously cutting some stuff off, perhaps due to widescreen resolution?

https://steamcommunity.com/sharedfiles/filedetails/?id=1702626879
Mar 30 @ 2:09pm
In topic Mods?
Though I don't know of any mods, there's not much reason to carry chests around, other than the one time you explore out in each direction. I just put a chest between each pair of buildings, and only move them a tiny bit if I want to pick up stuff in bulk.
Mar 30 @ 2:07pm
In topic Opening two menus with one keypress bug
If I try to use a chest and I'm near the intro/tutorial thing, it pops up both windows, but then after I dismiss the chest, my mouse disappears and I can never click to dismiss the help window, and the mouse stays hidden when I try to build things, etc. Exiting the game seems to be the only options. Was just killed because I was unable to build anything in this state, so I exited the game and when I came back in, I was dead (I was, admittedly, at 1 health and near some enemies when I exited) :(.

Slightly related, as it helped cause the same death to occur, the dwarf chest that follows you around stops you from interacting with all sorts of stuff, I was trying to heal myself, and the chest kept running over next to the herb I dropped and picking it up, and then I picked up the chest instead of the herb, and repeated that a couple times. Wish I could just dismiss/destroy that chest the same way I can destroy other unique buildings!
Mar 27 @ 2:49pm
In topic ChangeLog
2019-03-27 - v1.8.374 - Animated Avatar Support
  • Support animated avatar icons, for users on platforms that provide them
Mar 21 @ 3:58pm
In topic ChangeLog
2019-03-21 - v1.8.373 - Controller Support Update
  • Better support for Wii U/Switch USB GameCube controller adapter
Mar 17 @ 7:40am
In topic Questions for curator listing
Originally posted by Electron:
OK I got Jimbly's SDL to compile and for the first time I have 5 XInput controllers working! Yay :-)

However, these patchs haven't been accepted into mainline SDL yet, so I don't know how well tested they are. If no-one much has used them they could have some hidden bugs still. Maybe I could figure out a way to offer a choice of normal SDL and Jimbly SDL to the user.

My SDL fork was off of the absolute latest code of SDL, which may have some fixes beyond what's in 2.0.9, it also looks like they merged in a relatively recent gamecontrollerdb (not sure if that was in 2.0.9 or not - I know 2.0.8 had a tiny, tiny list of gamecontroller bindings that definitely didn't support any MS controllers in XInput), so that might explain some of the differences. It's definitely best to grab the latest gamecontrollerdb.txt (and add the line of code that actually tells SDL to load it) though.

Really weird that you'd get a working polling API but not Events - as far as I understand SDL (which is now pretty thoroughly), the polling API just looks at the data of the most recent events... though maybe one of the joystick drivers changed since 2.0.9 and when I dove in to make my changes, I did see a couple of (now disabled) code paths doing weird things or Xbox One that perhaps were enabled in 2.0.9...

Previous to making my recent changes, I was using SDL 2.0.8 in DirectInput mode (with latest gamecontrollerdb), and never had users have any problems, so you may want to see if that behaves differently for you.

As for stability, I have released my fork to users of Splody, but that's like 10s of users testing per day, I'd also be slightly hesitant using it at launch on a new game until it gets some additional testing (and some SDL maintainer's eyes on it).
Mar 13 @ 4:58pm
In topic ChangeLog
2019-03-13 - v1.8.371 - Controller Support Update
  • Update to newer version of SDL and GameControllerDB to better support more controllers with good default button mappings
Mar 11 @ 2:15pm
In topic ChangeLog
2019-03-11 - v1.8.367 - Launch Reliability
  • Fix crash at startup if running Splody with the wrong working directory - e.g. by double-clicking the executable in Finder (OSX) or through a shortcut with an incorrect "Start in" setting (Windows) (bug credit: SilverHawk)
Mar 4 @ 8:16am
In topic Multiplayer crash bug in cutscenes
We received this same crash when the host (accidentally) started Journey of the Pirate King.

<Event {LINK REMOVED} <System> <Provider Name=".NET Runtime" /> <EventID Qualifiers="0">1026</EventID> <Level>2</Level> <Task>0</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2019-03-03T05:16:23.163509000Z" /> <EventRecordID>43964</EventRecordID> <Channel>Application</Channel> <Computer>DESKTOP-FQADJM4</Computer> <Security /> </System> <EventData> <Data>应用程序: Stardew Valley.exe Framework 版本: v4.0.30319 说明: 由于未经处理的异常,进程终止。 异常信息: System.NullReferenceException 在 StardewValley.Tools.FishingRod.tickUpdate(Microsoft.Xna.Framework.GameTime, StardewValley.Farmer) 在 StardewValley.Farmer.updateCommon(Microsoft.Xna.Framework.GameTime, StardewValley.GameLocation) 在 StardewValley.Farmer.UpdateIfOtherPlayer(Microsoft.Xna.Framework.GameTime) 在 StardewValley.Game1.UpdateCharacters(Microsoft.Xna.Framework.GameTime) 在 StardewValley.Game1._update(Microsoft.Xna.Framework.GameTime) 在 StardewValley.Game1.Update(Microsoft.Xna.Framework.GameTime) 在 Microsoft.Xna.Framework.Game.Tick() 在 Microsoft.Xna.Framework.Game.HostIdle(System.Object, System.EventArgs) 在 Microsoft.Xna.Framework.GameHost.OnIdle() 在 Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame() 在 Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(System.Object, System.EventArgs) 在 System.Windows.Forms.Application+ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32) 在 System.Windows.Forms.Application+ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr, Int32, Int32) 在 System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner(Int32, System.Windows.Forms.ApplicationContext) 在 System.Windows.Forms.Application+ThreadContext.RunMessageLoop(Int32, System.Windows.Forms.ApplicationContext) 在 System.Windows.Forms.Application.Run(System.Windows.Forms.Form) 在 Microsoft.Xna.Framework.WindowsGameHost.Run() 在 Microsoft.Xna.Framework.Game.RunGame(Boolean) 在 StardewValley.Program.Main(System.String[]) </Data> </EventData> </Event>
Showing 1-20 of 42 entries