Showing 1-20 of 436 entries
Aug 22 @ 12:51am
In topic Linux VR Games List [WIP]
Steam Play OpenVR bridge is made specifically for SteamVR, and that includes Vive. Yes, get your setup going again :)
Jun 4 @ 12:16am
In topic Samsung Odyssey
Just in case you're not trolling...

A Linux version of the Windows Mixed Reality runtime EVER happening is about as likely as there ever being an official Linux version of DirectX. It's not happening. Ever.
The game seems a lot... crashier now. Always an instant, unexpected CTD. Oftentimes the host rewinding 2-3 times in a row will do it. Have a hard time collecting details as it's intermittent and I can't find where TTS drops the crash dump/logs.
If a player has the HUD hand display enabled, they move a card from their own hand or into their hand space, and they are not the host, it ceases to move from their perspective. Other cards in their hand will move in response to the card's actual position, creating the appearance of a gap. The host can see the card's actual location. Didn't investigate too closely what other clients see.
Mar 10 @ 10:37pm
In topic Linux tablet....?
Originally posted by locoparentus:
Unless were going to see a hop from Unity 5.6 to 2017 and upwards

Yes please! I want Linux VR and Vulkan!
Mar 4 @ 12:15am
In topic Linux tablet....?
Originally posted by locoparentus:
I believe the Embedded Browser used to make the tablet is a Third Party add on and has no support for Linux.

To get this to work they either need to change this component completely or Work with the creator of the current version to make it compatible.

https://assetstore.unity.com/packages/tools/gui/embedded-browser-55459

I didn't even notice this doesn't support Linux when I was googling. It's just a wrapper around CEF, right? CEF is fully crossplatform and works very well on Linux; Steam itself uses CEF on all three platforms. What is this plugin doing wrong?
Mar 3 @ 10:47pm
In topic Linux tablet....?
I'm really curious how this has gone unimplemented for so long and what the hurdles you're facing are. Are you using some obscure, non-standard browser library? Is CEF somehow unsuitable?
Feb 28 @ 9:24pm
In topic Linux support?
Originally posted by Cheeseness:
One thing I have noticed, and I don't know whether there's anything specific that you can do about it is that the hands/Vive controllers disappear from the game if I bring up the SteamVR dashboard while the game is running.

For what it's worth, one thing I noticed is that even on Windows games would do this if you had the dashboard up while the game was booting.
ALL keywords stack? I didn't notice a difference between "hilly" and "hillyhillyhilly".
So I wanted to see if I could make it worse... I made it worse. A lot worse.

twistylonglonglonglonglonglong

15fps in places. Many places.

Appropriately ominous music too. And it had some interesting map generation anomalies, like a camera drone INSIDE the track and a drop so steep it resembles a sheer cliff.
No, it didn't crash or anything like that. It just... lagged. My machine is no slouch -- i7-4770 + GTX 1080Ti. But I was still getting 25-28fps towards the start of the track and it only started to hit 60 right at the end.

Need a stress test to identify sore spots needing optimization? Here you go :)
Jan 17 @ 5:52pm
In topic Any chance of getting VR?
Originally posted by ZNix:
As far as I know, PAYDAY 2 on Linux uses modern OpenGL. At least on Windows, SteamVR only supports ancient versions of OpenGL (<= OpenGL 2, ~15 years old iirc).

Wrong, dead wrong. You could be using OpenGL 1.0 or 4.6 or anything in between, it makes no difference. SteamVR doesn't care what OpenGL version you are using. It has a couple different ways to do it, but it simply imports the buffer into a DXGI/D3D11 (Windows) or Vulkan (Linux) instance before doing anything with it, so it needs a whole lot of nothing in terms of your OpenGL context.

Ideally, the GL host should have GL_EXT_memory_object_fd & GL_EXT_semaphore_fd as they're needed for the "fast" import path, but the game doesn't have to do anything to enable this; it's totally dependent on the graphics driver.
Dec 31, 2017 @ 10:39am
In topic Technical Support Sub Forum + Support Thread
Originally posted by Ruzgfpegk:
I don't think that's the problem, because as I mentioned earlier it also happens on Windows Mixed Reality headsets which also run at 90 Hz.

WMR headsets are 60/90 switchable. Doublecheck the performance readout under the supersampling slider in SteamVR settings actually says 90Hz.
Dec 30, 2017 @ 1:35pm
In topic Technical Support Sub Forum + Support Thread
Originally posted by hardcastlemccormick:
So this is a strange issue, and I don't expect any official support, though maybe somebody else is trying this and found a solution.

I'm playing the game in VR using Trinus VR on my Playstation VR headset. (Yes, the Steam version, through SteamVR.)

Area X plays incredibly. Holy cow. It's technically perfect and my PC can handle some higher settings. Looks great.

The rest of Rez runs at about half speed or so. The framerate of the image appears high enough, things look very smooth and input is not an issue, it's just that the game logic, sound effects, and everything related are all about half as fast as it would be otherwise.

This issue does not go away no matter what I do to the VR video settings. I set them all as low as I could and it still ran sluggishly.

Given that the game runs perfectly in Area X and I appear to be getting a good framerate, I don't think it's a performance issue. I am running i5 6500, 16 GB RAM, and a 1060 3 GB.

If I were to guess, the game is expecting a 90Hz HMD, and winds up at 2/3 speed since the PSVR is actually 60Hz (at least, the way Trinus initializes it). If that's indeed the issue, unfortunately there's no way around it.
Dec 9, 2017 @ 1:21am
In topic Linux/SteamOS
Originally posted by Blueteak:
I tried another build since someone said it was working with 2017.2 (https://www.reddit.com/r/Vive/comments/7hvbyj/despite_the_official_line_the_unity_steamvr/), and have uploaded it to the Demo linuxtest branch. If anyone could let me know if it's working that would be awesome :)

It doesn't look like Steam will let us download the demo if we own the full game. Would it be possible to add the linuxtest to the full game?
Also having the same problem in Ubuntu GNOME 16.04

Is it working right on any distro?
Dec 5, 2017 @ 7:14pm
In topic Unity: Fixing it ourselves
Originally posted by chrix:
Yes, the vr compositor should definitely run without a desktop compositor. Gnome is a bit bad because you can't disable compositing.. Maybe you can just start a second X session with a bare bone window manager like openbox and run steam + steamvr there and just switch with ctrl+alt+fX for testing the actual VR stuff.

The real answer to this issue is to bypass the X (or Wayland) display management entirely and give the VR compositor exclusive control over the CRTC connected to the HMD -- what's called "direct mode". This is already fully implemented in NV binary drivers, and development is underway for Mesa (see: https://keithp.com/blogs/DRM-lease/ ). Anything short is a stopgap that's probably not worth the effort. Personally, my Radeon is supposed to be just for smoke testing with RADV, and it won't be an issue for me once I get my 1070 back.

The thing is that even from Unity it sounds like it's disabled and they are working on it. Let's see what they say first, not that developers put in some effort just to get it disabled with the next release again

If it breaks, we'll fix it. I was fully expecting to have to do so in the first place; how things have actually turned out so far is a VERY pleasant surprise. Besides, attempting a Linux build is very little work on the developer's part and likely to trigger/highlight any issues that will need to be fixed either way.

You're right in that an official blessing would be very nice, though.
Dec 5, 2017 @ 6:30pm
In topic Unity: Fixing it ourselves
Originally posted by chrix:
Turns out even though it was not enabled in the 2017.3 beta I tried nor being mentioned in any documentation or release notes, it's working as you'd expect it on 2017.2.0f3

I think I'd like to try it on NV hardware before saying that 100% (I'm on my backup RX 480; my usual 1070 is out for RMA), but it is looking pretty good/bad depending on your point of view...

Still working on reproducing myself, but I think there's enough evidence to see if we can get a developer to try this with their actual game.

Update: I got it to work. Bad performance issues, but I think I'm also seeing tearing, so it's probably just mutter interfering with extended mode. My GeForce cannot return fast enough...

Let's get a discrete "how to build" going and find some willing devs.
Dec 5, 2017 @ 5:15pm
In topic Unity: Fixing it ourselves
I'm tired of waiting. Let's see what we can do.

Unity plugin is on github: https://github.com/ValveSoftware/steamvr_unity_plugin

I cloned the repo, imported it as a project into Unity 2017.2.0f3. It gave multiple warnings about the project being made with an older Version, and that it will make significant changes. It appeared to create the project without incident.

Immediately, got a dialog with two warnings. I don't recall the second one, but the first was basically "we recommend building for windows x64". Lol no.

Target platform: Linux standalone. Architecture: x86_64. Development build, because why not.

It built fine, no errors. No warnings that I can tell (not familiar with Unity, maybe they're buried in some dialog or tab somewhere). IT RUNS.[imgur.com] HMD tracking is working. But it's just this background. I suspect there's supposed to be more to it, based on .

Where to go from here? Well, figure out what exactly this full project is supposed to do, and make it do just that. I'm off to my Windows partition!
Dec 5, 2017 @ 3:45pm
In topic Linux VR Games List [WIP]
Originally posted by chrix:
Cool, but I thought it sits on top of Unity's "native" SteamVR support, which they have disabled?

The C# header for the OpenVR API itself is in the tree[github.com] and the names of the source files under Scripts/ imply it doesn't rely on any API-specific VR code in Unity itself. And others have said they've gotten this very very close to working.

I've never done any real work with Unity... I'm starting to think maybe I should. I've hit a wall with WOVR in which I'm having a hard time wrapping my head around certain Vulkan concepts, and I can already see another wall looming in the crazy amount of internal Wine infrastructure that needs to be tweaked to get the important bits of DXGI doing what they should. This looks like I don't need to know any graphics API details to get it going.

Let me make sure my setup still works, then I'll dig a bit.

Update1: My setup took a bit of fixing with using the backup (Radeon) card, but it's functional. Let's have a look at Unity.

Update2: Thumbs up, let's do this!
Showing 1-20 of 436 entries